Stuck on "Zotero is updating your document. Please wait" in Google Docs

This discussion was created from comments split from: Zotero Google Docs is very, very slow.
  • I am stuck in
    "Zotero is updating your document.
    Please wait."

    and there is no progress bar to predict, or let me know, how long I should wait.
  • The progress bar is displayed by Zotero, not the browser, so you should look through the Zotero windows. If you cannot find a progress bar try restarting Zotero and your browser and try again.
  • Is there any news on this challenge? I have had the same issue now multiple times and am having trouble finding information about what to do about it. This is rather frustrating, particularly since Zotero doesn't seem to be integrating into my Microsoft Word properly. As such, I do not have a backup plan if troubleshooting Zotero in Google Docs doesn't work.
  • Zotero works well both with Google Docs and Word. If you are never seeing the citation dialog or progress bar pop up, it is likely because you are minimizing the Zotero window which unfortunately makes it impossible for Zotero to focus those dialog windows correctly. You should instead switch away from the Zotero window using the bottom toolbar. There is unlikely to be any changes regarding this.

    If you want help regarding Word integration troubleshooting please create a new thread and describe in detail what the problem is and what troubleshooting steps you have taken.
  • I wrote another thread about this a little while ago but it doesn't have to be posted. You actually have to manually switch, or other, to the Zotero Add/Edit Citation window which will be up and waiting. I am used to Word, where the Add/Edit Citation window pops up on top of Word, so you can choose an article. Pick the item and it will plunk the citation into your Google Doc switching you back automatically to the doc. BTW I am using Chrome with Windows7
  • I was having this same problem and finally thought to check the Windows Defender. I added Zotero to the list of apps allowed through the firewall and then it worked.
  • [solved by myself] I was having this issue for many times when opening a word-format doc through Google Doc. But it was resloved when you copy every text into the Google doc directly, then Zotero can detect the doc and the tool bar shows out! I mean, open file directly from Google Doc, not open a doc. or docx. file via Google doc.
  • @jasmineHZ: Yes, the plugin won't work if you open a .docx file directly in Google Docs via Google Drive. It needs to be a native Google Doc document. We're going to see if we can add a clearer warning about that.
Sign In or Register to comment.