Zotero picker not always coming to the front (WIndows/LibreOffice/BBT)

I have written a powershell script for Windows 10 which makes a curl request to insert citations into Scrivener using the BBT picker (https://github.com/AmomentOfMusic/Zotero_scrivener_picker_windows). For the most part, it works great.

My main issue is that the picker, the first time it is called, does not appear on top, but rather buried under my other active windows. After the first time I manually bring it to the top, Windows seems to "remember" it's position and the subsequent times I call up the picker, it does remain on top. That is, until I change my active window and then the problem happens again.

@emilianoheyns has suggested that this is a Zotero bug. I have been able to reproduce this issue in LibreOffice by maximizing, then minimizing the Zotero application, after which, when returning to LibreOffice, the picker remains buried behind the other windows.

I have not been able to reproduce the issue in Word, which suggests that there might be something I can do on my end to fix this problem - any suggestion would be welcome (I've tried using "setforegroundwindow" commands, but to no avail due to sequencing issues). Alternatively, is there a way on your end to embed a sort of "always on top" property to the picker to prevent this bug?
  • We are aware of this and have a ticket, along with an earlier forum discussion.

    I can only reproduce this in LibreOffice, and not Word, and also annoyingly inconsistently (so when you think you have a fix, the bug just pops back up). See the reasons listed in the last discussion on why this is not very high priority. If somebody is willing to venture into the plugin code, they are very welcome, but I cannot provide any timeline for when this will receive attention again.
  • The only time I've seen it was with word, unfortunately timed as I had meant to extol the virtues of reference management to new students, but instead struggled seeing clicks of the "insert citation" button doing seemingly nothing. I've not seen it since for the simple reason I don't use Windows or Word myself.
  • Solved for me.
    I had this problem while using Zotero with Windows 10 and Libreoffice. The citation dialogue box always appeared behind my Libreoffice window, and I would have to click it on the taskbar to bring it to the front.

    I found a solution here by user bknorn:

    Go to your Zotero program, Click 'edit', 'preferences', 'advanced' and then click 'config editor' down near the bottom. Click 'I accept the risk'. This will bring up the config editor.

    In the search bar at top, search for 'integration', and find the line item:


    If its value is 'false', you need to change it to 'true'.
    Right-click on it, and select 'toggle', to toggle it to 'true'.
    Then close the window.
    This fixed the problem for me.
Sign In or Register to comment.