Hidden dialog when creating citation

When using Zotero in LibreOffice (in Windows 10), the dialog for creating a new citation is in most cases hidden behind the LibreOffice window.

Steps to reproduce:
1) Open Zotero
2) Open LibreOffice Writer
3) Click on "Add new reference"

Expected behaviour: Dialog window should appear as top-most window to ensure visibility.

Actual behaviour: Current active window (LibreOffice Writer) is top-most, which generally causes the dialog window to be hidden. The hidden window can be found by clicking the Zotero icon in the taskbar.

This problem seems to have started with Zotero 5. For earlier versions, the behaviour was as expected. I have tested the behaviour with both LibreOffice 6.01 and 5.4.3, with identical results.

Can this be changed by a setting in Zotero? If not, is there a chance that a bugfix version will change this?
  • I've just tested this and it seems that we never did anything special for Windows (unlike other platforms) to focus the citation dialog. It works without issues for Word.

    I've tried some quick fixes available to us, but nothing seems to have any decidable effect. However, it seems that under some conditions the citation dialog comes up fine. If after clicking add/edit citation you switch to the citation dialog manually (not the Zotero window), it then comes into focus for every subsequent citation until the Zotero window is focused. Another thing that seems to help is if you had Firefox focused before focusing LibreOffice. Can you reproduce any of this @larsjoedal?
  • (do you mean _Firefox_ or Zotero in your last sentence?)
  • Thanks for quick response!

    I can confirm that if the citation dialog is manually switched to, then it is also focused next time. Apparently, this continues to be the case until Zotero is closed - after restart of Zotero, the dialog is out of focus; restart of LibreOffice changes nothing.
    I cannot reproduce influence from Firefox, though. (I do have the the Firefox connector installed, but it has not been involved in this quick test.)
  • Fearing that this issue has been set aside as "not really a problem at all", I write again to say that this continues to be annoying: Inserting a new reference in LibreOffice on Windows 10, time and again I have to seek for the "Insert reference" dialogue window. I know where to look for it (behind the LibreOffice Window, connected to the Zotero Window), but it does not come up automatically.

    Every time a new version of Zotero is released (which happens with impressive frequency), I hope that FROM NOW ON the "Insert reference" dialogue window will automatically be in visible and in focus. I am still hoping :-)
  • Sorry, this is an issue, but fell out of scope. I have created a ticket to track this, but last time I tried to fix it, nothing obvious worked. LibreOffice on Windows has a fairly small audience, so this is obviously not very high priority, especially because the fix isn't trivial, but it should get attended to eventually. We will update this thread when there are news.
  • This is also happening for me too (same situation, LibreOffice in windows 10). I'm interested in any workarounds or long term fixes.

    "I can confirm that if the citation dialog is manually switched to, then it is also focused next time" works intermittently for me.
Sign In or Register to comment.