'Insert citation' window always appear in background

It's annoying when it happens, as I have to activate the window first and only then type in the citation. Adds unnecessary and counterintuitive actions.
Is it working as intended or a bug?
Zotero Standalone 4, Linux Mint Mate, LibreOffice.
  • the window should appear in front, but I'm not sure how much troubleshooting devs are going to be willing to do across linux distros.
  • Already any solutions for this problem, @treglin? A couple of days ago, this started to happen on my system: Zotero 5.0-beta.213, Ubuntu 17.04, LibreOffice 5.3.1.2. Thanks for any suggestions.
  • @bknorn it's working fine with the same setup for me. Most likely to do with (changes in) your desktop environment config. A computer restart might be a simple fix that works.
  • i experience the same behaviour
    especially when multiple libreoffice windows are open,
    the insert-citation dialog somehow appears at a random 'levels' between "Front of all windows" and "Back of all windows"

    --
    Win 8.1
    LibreOffice Version: 5.3.4.2
    Zotero Integration for LibreOffice: 5.0.4
    Zotero: 5.0.6
    --
  • I've been (inconstantly) bitten by this one for as long as I've used Zotero (since the halcyon days of 2.x) and the LibreOffice plugin, both on Linux and on Windows. Similarly, the "Set document properties" windows appears (almost) always *behind* the LibreOffice window. Grrr...

    I's just a booboo, but an annoying one.
  • Please see https://www.zotero.org/support/kb/addcitationdialog_raised: If you switch the preference "integration.keepAddCitationDialogRaised" to TRUE, you can keep the Zotero word plugin interface for adding citations always at the front. Access these preferences now through the Zotero "Preferences" window, "Advanced" tab, click on "Open about:config".
    This solution might help for MS Windows users. In Ubuntu 17.04 with Zotero 5.0.6, however, the behavior of the Add/Edit Citation window is odd after changing this preference: No window frame; writing into the search field not possible.
    Therefore, I used the CompizConfig manager instead, see: https://help.ubuntu.com/community/Zotero#Window_management_for_the_OOo_extension. I did not need to change the window rules. I just changed one setting (Step 4): "General Options", "Focus & Raise Behavior" tab, set "Focus Prevention Level" to OFF.
  • @bknorn: thank you very much, solves my problem.
  • edited June 25, 2019
    FYI for others.
    The suggested solution:

    integration.keepAddCitationDialogRaised to TRUE

    ...only worked temporarily for me. The issue reverts back next time I open a document/start up zotero.
  • In Windows: Try putting LibreOffice Writer in front of (left of) Zotero in the task bar.
  • Is there any news about this behavior?
  • @bknorn Thanks! Your fix worked for me, on Widows 10, Libreoffice.
Sign In or Register to comment.