BMC Microbiology style file not working

I downloaded the BMC Microbiology CSL file from the style repository ( but when I try to use it I get the error message "The style you have selected does not appear to be valid...." I followed the link to the validator ( but this tells me the file appears to be correct ("Good job! No errors found.")

I do not have experience of CSL files. Can anyone tell me how to identify (and fix) the error? I tried downloading another BMC style but it also fails. Other styles work OK.

  • The style on is fine; something else is going on. Could you reset your citation styles from the advanced tab of the Zotero preferences and try again?
  • I did a reset as you request and all of the styles I have installed are gone. The link from the Preferences Cite tab to get additional styles does not work (it is blocked by our office network policy) so I downloaded the BMC Microbiology style from the repository. I double clicked to install it but got the message "An unexpected error occurred while installing "C:\..\Downloads\bmc-microbiology.csl"" and it does not appear in the list, even after restarting Zotero.

    Can I just copy the csl file to the styles folder or is it necessary to "install" it? When I do it reappears in the list but I am back to the original error when I try to use it.

  • oh you need to mention these things. Having Zotero's access to the internet blocked will break all sorts of functionality.

    You can download this style: which is equivalent to BMC Microbiology and place it in the CSL folder and that will work.
  • (No need to manually put anything in the styles folder. Double-clicking to install the Vancouver one is fine — the issue here was just that you were trying to install a dependent style, and when you do that Zotero automatically tries to download the parent style, which will fail if you don't have internet access.)
  • Thank you for the explanation. I am still trying to get my IT administration to open the internet access.

    Now I understand that I have to search for and install the independent parent style as long as I do not have internet access from Zotero.

    Thank you very much for your help. I was puzzled by why some styles worked and others did not.
  • Sorry, can you help me again?

    I downloaded the springer-vancouver-brackets.csl file and placed it in my styles folder. It works, but to help me to remember which one to use in the future I edited the field to BMC-brackets and saved it under the name BMC-brackets.csl. Now it appears in Zotero under both names.

    But when I tried this with the style entomological-society-of-america.csl, renaming it to Journal of Economic Entomology and resaving it unde a new file name the original Entomological Society of America name appears in the styles list but not the Journal of Economic Entomology. Do you know why?

    I did not change anything else in the csl file except to comment out the original line and as far as I can understand there are no other dependencies. The only difference I see is that the second style includes a field. This is happening with several other styles where I tried to do a name change.

    Thank you.
  • edited March 29, 2018
    Yeah, don't mess with the names — too complicated.

    If you want to mirror what Zotero does, you can create a 'styles/hidden' subdirectory, put the parent style in that, and then put the dependent style in the main 'styles' directory.
  • This looks like a good idea, but unfortuantely you are advising someone with virtually no experience of XML. I presume that the link in line 7 of the dependent style file, currently

    needs to be changed to a reference to the parent style on my local hard disk, but I do not know how to reference a local file rather than an internet address.

    Also, do either of the other links need to be changed (lines 6 and 8, rel="self" and rel="documentation")?
  • Sorry, the XML line I included was removed. I hope you can work it out from the line references.
  • You don't need to edit any files.

    Just delete anything you've done so far and then put bmc-microbiology.csl in styles and springer-vancouver-brackets.csl in styles/hidden and restart Zotero.
  • Thank you very much to both of you, all the styles are working correctly now and I will know how to deal with new styles in the future.

    I apologise for asking so many questions, I am rather new to Zotero and trying to run it in a very restrictive IT environment. It is a great tool and I really appreciate it.
  • My IT support have finally resolved the internet access issue. I report what I was told to do in the hope it might help others in a similar situation, even though I do not understand what is being done.

    The problem was in the proxy settings. In Zotero Edit - Preferences - Advanced - Config Editor I changed the network.proxy.type value to 4. This allows Zotero to retrieve new styles and also for the styles to link to the parent styles (without having to download them to the styles/hidden folder).
  • edited May 16, 2018
    Just to reiterate, that will fix a whole bunch of things in Zotero that depend on network access, not just dependent style installation.

    (And to explain the technical part of this, 4 means automatic proxy discovery (WPAD). Zotero uses the system proxy settings by default, but Mozilla has made a security decision (which we follow, being based on Firefox) to not use automatic proxy discovery even if the system is set to use that, because WPAD, while used in some institutional environments, is a fairly common and dangerous attack vector. So this mode has to to be explicitly set in Firefox and Zotero. Since this is a relatively rare configuration, in Zotero we've never bothered to put this in the visible preferences.)
  • Thanks.
Sign In or Register to comment.