Zotero upgrade crashing Microsoft Word

  • Is the latest attempted fix at least relatively more stable than what we push with updates right now? I assume what we push now leads to crashing nearly every time you attempt to add/edit a citation? Is this any better?
  • I, just, had a whole group of students try to install and it crashed the lab Windows machines. Then tried to install Simon's Build, which should work, but what else do they need to do to install it. Do they need the Chrome plugin first?
  • just restart Zotero
  • But do they have to try to download and install Zotero for windows first?
  • edited January 17, 2018
    Wait, we may be talking about something different here. If installing Zotero crashes the computer, that's not the same problem and that's almost certainly a computer set-up problem (since no one else has reported this). The issue discussed here are Word crashes.
  • Okay, got it. Thanks.
  • The only fix that has remained stable for me for any length of time is Simon's build. Everything else, including updates to Zotero, cause crashing in Word.
  • I have this problem too. I am using Zotero 5.0.34, and Word 2010. Works for the first new reference added, crashes for the second. I have followed all instructions carefully. I had to submit a paper imminently and so had to create a Bibliography manually, which maes me less in love with zotero
  • I have been experienceing two types of problems.

    1) The first problem (since two to three weeks back) is the one discussed here i.e. inserting a citation while in Word 2010 causes the program to crash. However there is no error message mentioning Zotero, just Word reporting that it has crashed and will try to restart (which it usually does but sometimes fails to dog).
    Should I also try what this threads refers to as "Simon's build"?

    2) The second problem has started to turn up just this last week. It takes anything from 5-15 seconds until the insert citation pane appears on the screen. Sometimes it will appear immediately but most of the time there is that wait of 5-15 seconds.
    Is this problem related to the first one or a completely different issue.

    I'm using:
    - Word 2010 for Windows (32-bit)
    - Zotero Word for Windows Integration 5.0.7.SA.5.0.34
    - Zotero 5.0.34
  • I have precisely the same issues as andeholmberg - both the crashing and the delay
  • edited January 23, 2018
    I have the same issues. Even with Simon's build, I am finding that the connection to Standalone is extremely slow (sometimes taking more than 10 seconds to search for a reference using the Word extension). Previously I thought this might be related to the size of my library (5000+ references) and/or the performance of my laptop, but I was not experiencing this previously, and others seem to be experiencing the same.
  • I have experienced problem 2 (at least similar) described by andeholmberg for a few weeks (I cannot remember when it started). Depending on my location I use a PC or a notebook.

    Both have Word 2010 for Windows and Zotero 5.0.34. Sorry, I don't know where to look up the word integration version.

    During adding citation on my PC it takes 5-10 seconds until the citation pane appears and every follow-up step (until citation is found etc.) takes simply annoyingly long.

    It is worse on my notebook (might be due to WLAN). It is not practical to work there anymore.

    However, I never had any errors or crashes mentioned above.

    Can I do something myself?
  • @Malachit start a new thread, and produce a Debug ID from Zotero for a citation insert.
  • edited January 26, 2018
    @adomasven are you saying that the speed issue is completely separate? Several of us seem to be having the two issues together as @andeholmberg describes. It can take 30 seconds or more to add a citation into word even using Simon's build.
  • Yes, the speed issue is separate and seems to have begun when we started signing our plugin macros. The crashing has started occuring earlier. Some of the users seem to be experiencing both issues, some only one, but not the other. Simon's build doesn't include the signed macros, which is why that solves the speed issue.
  • edited January 27, 2018
    Ahh. Thank you. I had been using the slightly newer set of files which solved most of the crashing but I still had the speed issue. I will (very thankfully) go back to Simon's build - it has been driving me up the wall!
  • Then your issue is by all accounts different from anyone else's, since the issues reported here go away with Simon's build. The speed of Zotero does depend on the size of the document -- have you actually had better beformance in a document of the same/similar size previously?
  • @adamsmith i think you're replying to a message I edited. I made a mistake - I had changed the files to the newer version on a request from one of your colleagues and forgotten that I had done that. Simon's build seems to be solving the speed issue now for which I am very relieved.
  • (yes, sorry, forum took me to the wrong place in the thread)
  • Sorry, I am having problems. After updating Zotero to 5.0.34 and earlier one, each time I try to cite and open the citation panel, word crashes. I tried to log in "Debug log in", word still crashes and I obviously can not work?!!. I am also not that good at computer and troubleshooting. I need to submit my thesis by tomorrow to my supervisor and within ten days to the doctorate board. Please, what must I do??

  • @ShathaS: What exact version of Word is this?
  • forgot to say that the word version I am using is Microsoft office 365 Proplus, version 1708. I think an update was installed automatically yesterday evening.
  • @ShathaS If you look back on this thread, you will see instructions to change a set of files to 'Simon's Build'. Follow those carefully and the problem may be solved. Good luck with submission.
  • Look back to 20th December message from @adomasven and the few messages after that. Make sure you have the right set of files - he corrected the link in a message below the first set of instructions. It is quite simple to do.

    Make sure that you save the files in case zotero automatically updates when you reopen (it does this maybe once per week). If it does, you will then need to replace the files in the WinWordIntegration file again.
  • @adomasven have you thought of having a 'known problems' / 'solutions' page for collecting these kind of fixes. They are easily lost in the threads. I, for instance, had not realised that the speed problem could be fixed by reverting to simon's build so had been struggling for days with it. It might save you a few unnecessary queries too? Just a thought .... Thanks for all your help with this. The quick and helpful forum response (in addition to the product itself) is what keeps me using zotero.
  • We've recently had a bunch of Word problems crop up, both on Windows and MacOS that have been creating confusion, but I'm optimistic about resolving them (and we have managed to tackle MacOS stuff, it seems), which is why this hasn't been documented in our knowledge base. The Windows problems have been a bit more mysterious and inconsistent, which is why it is taking a while.
  • Hi I'm having the same problem Using word 2013. Zotero citations crash on two different computers. Several files.
    I see references to 'Simon's build' but I'm not sure what that is or what the steps are to try to use it.
  • I'm also having the delay- lag with the pop-up box.
  • edited February 15, 2018
    For people that can fairly consistently produce Word crashing with the latest version of Zotero (, could you test a few more things?

    1. What are your system specs - processor and RAM available?
    2. Is the crashing reduced if you disable any security software you run? And if so, what software that is?
    3. Does it occur if you change from an in-text citations style (like APA) to a footnote based style (like Chicago (note)) or vice-versa?
    4. If you open Task Manager before inserting a Word citation, do you see anomalies, like Word using more than 90% CPU or more than 500MB of memory? (Right-click on taskbar, select Task Manager and click "More Details" at the bottom, if the window is not expanded already).
  • Same problem here. Since switching to stand-alone zotero, it keeps crashing ( MS office 365). Error messages are: Zotero experienced an error updating your document. The remote procedure call failed [insertFieldRaw:docment.cpp]

    The crash occurs when inserting at a certain location, while at other works. however, both in newly made documents or old the problem repeats. (one workaround is to insert the citation at a place where it accepts it and then copy paste it to where you need it - nevertheless the document keeping crashing makes work with zotero hard)
Sign In or Register to comment.