Zotero upgrade crashing Microsoft Word

Since the automatic update to zotero a couple of days ago, word is frequently crashing (i.e. error message and closing all open word documents) when I attempt to insert a reference. The error message is as follows:

"zotero experienced an error updating your document. The RPC server is unavailable. [cursorinfield:document.cpp]"

What can I do to stop this?
  • PS I am using Standalone.
  • What versions of Zotero and Word are you using?

    That error message typically indicates that you have a broken citation in your document somewhere (though it usually doesn't make Word crash—that's odd).

    Try to find the broken citation and replace it by following these steps carefully:
  • edited December 20, 2017
    Hi. I'm sorry for the delay. I was hoping that the slew of recent zotero updates would resolve this problem. However, it is worse than ever. The start of this coincided with one of the first recent zotero software upgrades.

    I am using Word 2013 (as part of Office 365 if that has any relevance?) on a university network. And most recent update to Zotero Standalone.

    This does not just happen on one document. It is repeatedly happening on multiple documents. It almost invariably happens when I try to enter a reference for the first time (i.e. a fresh word doc with no potential for broken citations), and very often when I enter a new reference after opening an existing document (again there has been no problem with broken citations). I get the message 'word has stopped working' and sometimes the option to restart word, or often just 'close the program'. Word is often closing down multiple times in succession.
  • edited December 20, 2017
    PS I am no longer consistently getting the error message in the original email. Today's message is "zotero experienced an error updating your document. The RPC server is unavailable. [setText:field.cpp]" But I don't always get an error message - often just crashes word.
  • Is there a possibility of returning to an older version of Standalone to resolve this in the short term? If so, could you tell me how to access this? It is almost impossible to use the software at the moment.
  • In Zotero go to Tools -> Add-ons, what is the version of the Word Integration plugin?
  • 5.0.6.SA.5.0.32
  • This is on the computer that you see the crashing on?
  • Ok, lets try this fix. Follow these instructions carefully:

    1. Open zotero installation folder (default C:\Program Files (x86)\Zotero)
    2. Navigate to extensions\zoteroWinWordIntegration@zotero.org
    3. Download test-v120xp-runtime.zip
    4. Remove the contents of the folder you had opened and replace them with the contents from the zip (you will need to navigate to zotero-word-for-windows-integration-test-v120xp-runtime within the zip file).
    5. Restart Zotero

    Use Zotero with Word as you do normally and report whether you still get any crashing (or, whether you don't)
  • edited December 20, 2017
    So far so good - no crashing on first testing. Will update when I have been using a bit longer. Thank you for now.

    Do you have a sense of what the problem might be? Should I ignore standalone updates for the moment (presume this is an old set of program files?)?
  • I spoke too soon. Still having the same problem.
  • edited December 21, 2017
    Ok, let's try this version. https://github.com/adomasven/zotero-word-for-windows-integration/archive/test-v120xp-vs2013.zip

    For what it's worth, you can use these files in the interim, which use the older versions of the libraries and shouldn't cause crashing. I do ask you to continue in helping us debug this, as we need to find a solution to produce the plugin that does not crash Word to be able to support new features and provide bugfixes.

    EDIT: I'd originally posted the wrong link and edited after, so make sure you get the updated one, i.e. https://github.com/adomasven/zotero-word-for-windows-integration/archive/test-v120xp-vs2013.zip
  • Thank you. I'll get back to you when I have had a chance to test it. Happy to help with debugging. Back in a few days.
  • I've been having the same problems, and this patch seemed to do the trick! I have been using it for the last two days quite intensely; lets say I added / edited ~100 citations. Before it would crash every couple of times, sometimes it would keep on crashing continiously, but now that happened (only) once.
    This one time it still seemed to be caused in the same (myserious) way. It showed the same error and occured once I clicked 'add/edit citation' before the dialogue would show up. Unfortunately I didn't have debugging on at that time.
    Generally though it works 99% of the cases, so I guess this patch would make a lot of people happy.
    Thanks for the support!
  • Has this continued to work for you? I've been experiencing the same problem and I've lost a ton of work due to it. I tried the patch and so far (*knock on wood!*) it's working. Is this a permanent solution?
  • I've been offline for Christmas but will be using standalone again in due course and will report back ...
  • How can I stop Standalone automatically installing new updates if I close standalone? (I've been leaving standalone open)

    I think that closing and reopening will automatically install new updates and that this will override the set of files I have changed (as instructions above) in extensions\zoteroWinWordIntegration@zotero.org ?
  • Zotero will require a restart after updating (and you will need to replace the plugin files after it updates), but the updates are not very frequent, currently about one a week. Have you had any luck with the updated files in using Zotero with Word?
  • I have not been working as intensely over the last week but it has seemed better.

    However, I am having the same problem again today.

    I am wondering whether this issue is related to the 'speed' at which the university system is operating (sorry I'm not very clued up on the technical language) and the new updates to zotero being 'too much for it'! The university system is getting higher volumes of traffic again today (post Christmas holiday) and I have noticed that documents are back to taking longer to load.
  • Slow computer speed could be causing some problems, but there's also certainly a crashing bug that we have introduced, which some users have reported to be fixed with the latest version above. If word is crashing make sure you're using the latest "fix" version and Zotero hasn't updated recently (as updates will remove the temporary fix).
  • I am definitely using the latest version (have been hibernating rather than closing down machine). Have now restarted (which may make the system run better) and replaced the zoteroWinWordIntegration files again.

    I'll keep testing and report back.
  • Mine has started crashing regularly again. I am still using the updated files.
  • That's a shame. Can you confirm that Simon's build certainly doesn't produce crashing at all, since it's regular?

    After that, let's try this version https://github.com/adomasven/zotero-word-for-windows-integration/archive/test-v120xp-vs2013-cleanup.zip
  • Hi,
    I tried Simon's build and it's been 4 days I guess without crashing. So maybe that's the one that works best?

  • I have not been using zotero so intensively over the last few weeks but it has not been crashing using simon's build (only the one time as reported above).
  • I have downloaded Simons build - or is it your build you'd like me to try?

    Will report back either way.
  • Simon's build is generally known to be working and stable, but we need to find a way to update existing code for future features and compatibility, so please test the new one to see whether the crashing is fixed: https://github.com/adomasven/zotero-word-for-windows-integration/archive/test-v120xp-vs2013-cleanup.zip
  • I just downloaded an update and immediately Word crashed again. Tried the new build and got it to work. I'll see if it keeps working. Simon's build had been stable for the last week or so.
  • Oh actually, spoke too soon. It crashed too. I'm back to Simon's build.
Sign In or Register to comment.