Word plugin errors with Word 2016 for Mac version 16.9

edited January 19, 2018
Hello, my Zotero word plugin is no longer able to edit existing citations. I am running Word 16.9 on a Mac.

From my document if I click on "add/edit citation" I get the following error message: "Zotero experienced an error updating your document. The operation couldn't be completed. (OSStatus error -1728.) @[prepareReadFieldCode:document.m:205]"

I reinstalled Zotero, and this did not fix the problem. I also received another error message: "Zotero Integration Error, Zotero experienced an error updating your document. The operation couldn't be completed. (OSStatus error -1728.) @[prepareReadFieldCode:document.m:205]"

Please help!!
  • This is not an insider edition. It is the current version of Word.
  • (@adamsmith, version 16 was released today.)

    We're looking into this.
  • edited January 18, 2018
    Edit, actually checking right now. They may have updated today. CC @adomasven
  • I've updated to High Sierra OS 10.13.2 and Word 16.9 and lost all ability to have the zotero add-on. I've reinstalled and updated everything to no avail. It seems like Word no longer recognizes zotero as an add-on. This has been going on all week.
  • When I just tried again to reinstall the Zotero Word for Mac integration, I get the following incorrect error message: [Exception... "Word does not appear to be installed on this computer. Please install Microsoft Word and try again. @[install:install.m:159]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: file:///Applications/Zotero.app/Contents/Resources/extensions/zoteroMacWordIntegration@zotero.org/components/zoteroMacWordIntegration.js :: checkStatus :: line 212" data: no]
  • Word 16.9 came out today, so this wouldn't have gone on all week but yes, Zotero won't work with the just released Word for Mac version.
  • So I've uninstalled the new word, installed a version 15, tried to reinstall the add in (and received no error message), but I still can't see the add-in within word. Any ideas on how to return functionality? I have a grant due within a few days!
  • Version 15 should still work fine. Make sure you've restarted Word after reinstalling the plugin, and also try these steps. If you're still having trouble after that, start a new thread and we can look into it further.
  • We're hoping to have a fix for Word 16.9 within the next day or two. Subscribe to this thread for updates. Sorry for the trouble.
  • I am experiencing exactly what sweetanniegreen experiences. Also on a Mac, also High Sierra (sigh...) and also Word 16.9
    I can't edit a footnote or add another one. Also, Zotero disappears from the screen. Oh well, I need to do a 100.000+ book with circa 500 footnotes... and I love Zotero. Word seems to want me to use their own software for this but I believe I have no time. Any help?
  • As I say, we should have a fix for this very soon. While you can try downgrading to Word 15, I would recommend just manually inserting citations with some format that you can easily search for (e.g., "%%Smith 1989%%") and then replacing those with the fixed plugin as soon as it's out.
  • (would it be good to announce on Twitter from the Zotero account that this issue exists? That might allow some people to disable/delay their Word updates until this has been fixed and let them avoid any downtime)
  • Même problème, après mise à jour de word 16.9. Il ne reste donc plus qu'à attendre la mise à jour, et en attendant, travailler sur une version antérieure de word ou sur libre office... Same problem, after word update 16.9. It only remains to wait for the update, and in the meantime, work on an earlier version of word or free office
  • My zotero is inserting duplicates of the same citation. Could this be due to the word update?
  • Do you have Word for Mac version 16.9?
  • Then yes. You'll have to wait for the updated to fix this.
  • Commenting to follow thread since I'm also having issues with the new Word 16.9 for Mac update. I'll report on mine too, since they're slightly different (maybe more details will help?): Installed new Word last night. Could have SWORN Zotero was working just fine immediately after. This morning went back to work on the same document, now when I hit the add/edit button it briefly loads Zotero and then fails to load the actual enter citation window. Tried with the macros, same thing. Tried multiple documents, same thing. Restarted computer, installed new Mac update - all same. Came here, saw that it's a known issue.

    Thanks so much for all your diligent work keeping up with the broken updates Apple and Microsoft keep pushing! :-)
  • Same here. Update made everything worse :/
    Really hoping for a convenient solution...
  • That'll learn me to let Office autoupdate. Roughly the same problems here, waiting patiently for a fix. Thanks for all your efforts!
  • We've just released Zotero for Mac, which adds support for Word 16.9. Let us know if you run into any trouble with the new version.

    Thanks for your patience, and sorry for any inconvenience this caused.
  • I have downloaded Zotero for Mac, I am able to add new citation (which I could not do before) but it still will not let me edit citations. I had been using 4.0 standalone before. Any suggestions?
  • What exactly happens when you try?
  • (Editing is working for me.)
  • edited January 20, 2018
    Editing existing citations isn't working for me after installing the Zotero update and I'm getting the following error message:

    Zotero experienced an error updating your document.

    The operation couldn't be completed. (OSStatus error -1728.) @[prepareReadFieldCode:document.m:205]

    I'm running Word 16.9, Zotero, and I've tried reinstalling the plug-in as well as copying the text into a new document.

    The error also occurs when trying to add a citation within an existing discursive footnote that doesn't already contain a citation.
  • Can you 1) provide a Report ID after this occurs and 2) provide the exact steps to reproduce this in a new document, if you're able to? If you're not, could you copy the smallest amount necessary to reproduce this in a new document and email it to support@zotero.org?

    If you used the plugin in Word 16.9 before Zotero, it's possible there are broken citations in your document that you'll need to correct with the Debugging Broken Documents steps, but we'd be able to say more after looking at an error report and an example document.
  • The Report ID is 362373068.

    I receive an error message when I try to modify an existing citation in a Word document, and Zotero will not proceed with the operation.

    Steps to reproduce:

    1. Start Zotero. Open a Word document containing a citation.
    2. Click on "Add/Edit Citation" in the Word Plug-In while the cursor is within a citation field (in the footnote).

    Zotero displays the message:

    Zotero experienced an error updating your document.

    The operation couldn't be completed. (OSStatus error -1728.) @[prepareReadFieldCode:document.m:205]
  • The question to reproduce was about a _new_ document. Can you trigger that error starting in a blank document, i.e. insert citation, then try to edit it --> does the error occur?
  • Yes, the error still occurs in a new document.
This discussion has been closed.