Word Crashing Consistently

Dear Zotero Community:
I need help with a frustrating problem, please. Ihave downloaded the new Zotero for Windows and have the word plug in installed and Firefox open. Yet when I click the tab to cite, it causes Word to crash, and Ilose my work. I have lost a significant amount of writing because of this problem. Now I am afraid to use zotero.

I am using Office Student edition 2013, and Windows 7.

Does it matter that I have the Zotero tab AND the (old) Ad Ins tab (where Zotero used to be found) on my Word?

Thanks for your help!

  • What version of Zotero are you on?
  • I downloaded the most recent version. So Zotero 5.
  • I am not connected to the internet. Does that matter?
  • No. But the exact Zotero version would be good to know just to be sure. Find it in "About Zotero" in the help menu.
  • Is this consistently reproducible? Does it happen in a new document, or only in an existing one with many citations?
  • edited November 7, 2017
    I have the same issue consistently with the latest Zotero desktop version 5.0.24
    Microsoft Word from Microsoft Office Professional Plus 2016 32 bit.
    System Windows 7 Enterprise 6.1 Build 7601 SP1.

    Every time I try to insert a citation from the tab in Word, it crashes. The very first citation in the document, however, doesn't cause this issue. Interestingly, I experienced this problem also before I've updated Zotero to the latest version (not sure if it was already updating automatically, however).

    Please, help.
  • Does it happen every time after the first citation or is it not consistently reproducible?
  • In a totally new document it doesn't occur. But in the old one (where the issue was experienced) it is reproducible:

    "The remote procedure call failed. [insertFieldRaw:document.cpp]"

    Every time I put the first reference, add bibliography and then try to add the next citation.
  • Dear All, Thanks Vasili for posting! Now I know I am not crazy! I just reporoduced it myself. A new document where you select the doc preferences it does NOT crash. On an old document it does not put the citation even after repeated tries, and/or crashes Word. I have updated Connector. Still does it.
  • If this is one specific document, worth running through: https://www.zotero.org/support/word_processor_plugin_troubleshooting#debugging_broken_documents

    If this is all old documents, probably not worth it.

    (same issue was reported a while back in 4.0.29.x https://forums.zotero.org/discussion/59124/word-crashes-after-adding-citation-error-code-1317923451 )
  • I'm having the same issue with an existing Word document. The thing is, Word crashes every time I try to put a citation in a specific section of my document and other parts of the document work just fine. That specific section contains some tables with their captions but there isn't any citation in captions as it is mentioned in the "debugging broken document" link above.
    Removing those tables fixes the issue for me, so it has to do something with tables, images or these kinds of items in the document.

    Zotero 5.0.24
    Connector 5.0.26
  • What version of Word? Would you mind extracting the snippet that causes the issue (if it can be reproduced after removing the surrounding text) and sending it to support@zotero.org with a link to this thread?
  • Hi All, I replicated it again. I copied and pasted the entire chapter into a new document, reset the Zotero preferences, and it still crashed. Then, I decided to try the "old Zotero" tab on my Word -- the one that says "Ad Ins" -- and it worked consistently. It has not crashed yet. So, to repeat. When I used the new "Zotero" tab on my Word it crashed. And when I used the old "Ad Ins" Zotero tab, it functioned fine.
  • Hi All, i got the same problem here:

    I fill in a Citation at any place in my Document and Word crahes directly. Word just says it has to be restarted...

    The Error Msg. of Zotero (in german) says: "Ein Fehler ist beim Update Ihres Dokuments aufgetreten. Der Remoteprozeduraufruf ist fehlgeschlagen [insertFieldRaw:document.cpp]"

    My current workaround is to delete all existing Zotero Citations; save the document and then create the citations again which somehow worked finally. I guess the code of some existing Citations got corrupted somehow...
  • btw:
    Zotero 5.0.27
    Microsoft Office 365 ProPlus Version 1710 (Build 8625.2121)
    Windows 10; Version 10.0.16299 Build 16299
  • Yes, it appears that some of your existing citations got corrupted somehow. In the future, you can try going through these steps to avoid having replace ALL of the citations and just find the broken one:
  • the solution of taylorspencehd with the Ad Ins didn't work here
  • You have a corrupt citation in your document. Follow the troubleshooting steps I linked to to find it and replace it.
  • I did what you suggested bwiernik, but I think the update I installed on Zotero fixed the problem. I copied and pasted the text in a new document, and then reset the Zotero preferences, and now it seems to be working.
  • Same problem (not systematic crashes, but regular ones), on various Word files.

    Zotero 5.0.31 (but since the new version compatible with new Firefox), Word 2010.

    I didn't understand Taylorspencehd's solution (installing the old Zotero tab?).
  • Hi All,
    The old Zotero tab used to be part of the Word Plug In. IT was under "Ad Ins." Now I cannot get it off my Word for some reason. The new Zotero Tab, with the new Zotero is not now crashing all the time. So the fixes they have done have helped. But it is STILL crashing, as you say regularly. It is a bummer because I love Zotero, and all my work is deeply intertwined with it. So I am kind of stuck. It would be great if someone here could give a really good and permanent solution. The one suggestion of debugging a document is simply too time consuming. I tried it and it took like 2 hours on a fifty page document.
  • See the thread adomasven posted just above. It’s not a widespread issue, and the Zotero devs are trying to figure out where the crashing is coming from.
  • Thanks, but I would add, that though it may not be widespread, it is a major problem for me.
  • Thanks Adomasven, I'll try this solution if the issue get's unmanageable.

    As Taylorspencephd, I can't realistically debug the doc (more than 250 footnotes, several of them with multiple Zotero references, on about 80 pages, for one of my main doc) - and i'm inclined to think that's not the real issue anyway.

    Crashes are both regular & irregular : I can sometime use Zotero without problems for various hours, even days, and all of a sudden I again get some crashes, than it stops after like 6 to 10 crashes (sometimes with an error message, sometimes not).

    Short story: it doesn't stop me from working right now, but really slows me down when it happens.
  • @taylorspencephd To be clear, I wasn’t suggest that it isn’t a problem for you, only that the issue isn’t widespread, so it is difficult to figure out why it is happening. If you can answer some of the Zotero devs’ questions in the other thread, that would help to find the issue.

  • I just want to reply on this - brand new document - constant crashing. I'm saving before I'm putting in footnotes now, but it is making zotero unusable which is devastating as I've been a huge fan until now.
  • edited January 14, 2018
  • Great Adam - will give it a shot.
Sign In or Register to comment.