ZotDroid - A Zotero Client for Android

  • edited October 18, 2017
    I have few times to test it, and I have to say, that it is not working for me on Samsung S3 Neo. After the start of the application, I see the only blank screen.
    EDIT: After few minutes I see list of document, a lot of documents are no title - no author. If I try to download any pdf I got message about synchronizing, but thats all
  • Hello LiborA

    Yes, for larger libraries there is a bug where the initial load takes quite a while. I think I need to work that through. Its on the list.

    No title and no author is interesting. If there is no parent item, this tends to happen. I'm working on this today so hopefully I can get these issues solved.


  • Next version, 0.4 has been released. New functions include:

    * Added support for custom SQL DB directory
    * Small speedup in collection creation
    * Case insensitive search
    * Added Licence

    Next, I think I'll look at notes, adding them and deleting them I think.
  • Hi OniDaito,

    Just FYI, the top bar appears to obscure the first entry of a list (you can see this if you make a collection with just a few entries). Keep up the good work!
  • edited October 21, 2017
    On my S3 Neo, the list of publication is over the blue bar on the top and over the link circle in the bottom. Is that correct?
  • edited October 23, 2017
    I think I'll need to simulate your specific device, as that doesn't sound quite right. I'll add that to my next build cycle. Cheers!
  • I peer from underneath the mountain of my MRes to hand out version 0.5! :D

    Things I've added in this release:

    More metadata on each entry
    Fixes for different screens, specifically the 4 and a bit inch phones
    Fix for the top element being obscured
    Fix for the cancel button
    Added icons to show whether or not an attachment is available for offline viewing

    Progress is slow but on-going. Notes and tags are next up.


  • edited November 7, 2017
    Hi Ben, first up thanks for your continuing efforts on this. It's much appreciated.
    Zotdroid 0.4 [edited, foolishly didn't check which version and assumed it had updated when it hadn't] appears to be working on my Samsung tablet, even with my large library (I just had to be patient to wait for it to load).
    I haven't (yet) set up the webdav, but will in the future.
    Is there a way to collapse the folder structure in he left-hand pane ? If not, can I add this as a feature request.
    Secondly, how are items being sorted? I see that sorting by multiple options is on the to do list, brilliant, but presumably there's some default way they're currently being sorted that I can't figure out.

    hmm, just tried to sync Zotdroid as I'd noticed there were some missing items (they were old items too, not things I'd recently added) and Zotdroid seems to have hung after getting to the Loading 100.0% complete but the error message I got is that:

    "Chrome has stopped"

    is that expected?

  • Hello there,
    It's becoming clear to me that my library is in no way the biggest out there :/ Clearly I'll have to figure out a way to sort that in the future.

    Left hand pane... sadly not. I did originally want to do that but as far as I can tell, Android does not have a "more than two level" list structure unless perhaps I write one myself. I'll add it to the list though. I kinda thought it would come up.

    Items are sorted by their 'natural zotero sort' which is, I believe, the last edited date. I'd like to add a few more sorts. I'm just wondering how to put that into the program from a UX point. I'll add that as well.

    "Chrome has stopped" - I'll look into that but it doesn't sound good. My suspicion is that larger libraries are simply taking up too much memory and I think I'll need to add a feature to get around that. I'll keep at it mind.


  • Just to give you a figure to work with : my library has 8,300 top level items - and I suspect that fits nicely in the "big but not huge" kind of range. That's just a result of my having used Zotero for eleven years now!
  • I still see only version 0.4 for download.
  • LiborA - it might not appear right away, depending on store settings but it should be there now I'd have thought.
  • @LiborA should be there now.
  • Hi Ben, nope, the PlayStore is still showing version 0.4 - which means my earlier comments were wrong, I actually checked this time and I'm still running version 0.4 [I've edited my earlier comment to reflect that]
  • Great app! Thanks a lot for your effort. Version 0.4 doesn't quite work for me (my library is about 7000 entries long). I also don't find the newest version in Google Play. Have you considered uploading to F-Droid? Or linking to an .apk file?
  • Version 0.5 is available for download already. I see cca 880 items No title - No autor(s) and it seem as all of them have the same date. Maybe it should be great to add an info about the type of document. The starting of application spent about 2 minutes and the screen was black. For new users it can be little bit frustrating, some starting message on the screen should helps.
  • I could see part of my collection, not all of it, and right afterwards it hangs and doesn't load again.
  • @LiborA so I'm glad it finally loads for you, though I agree, theres some definite slow down and that can lead to confusion. I think we do need a dialog box. Once I've found out where that slowdown is, I can optimise that and possibly provide feedback to the user. Regarding the author sections, no-author usually appears if the item has no authors listed in the author fields. It might be the names appear under different metadata for other kinds of items. At present, I don't differentiated between item types as that was Thanks for the feedback.

    @fmuro how large is your collection roughly? It would be nice to get a sense of how
  • ... people organise their collections as I feel that there is a limit on how big one can make a 'list-view'. It's becomming apparent to me that some form of 'pagination' on listviews might be appropriate.

    Lots more work to do it seems :/ I'd best get on with it :)
  • edited November 9, 2017
    I would like to test Zotdroid but I do not know what to enter in "User Secret".
    I know what "User ID" and "User Key" is but where can I find the "User Secret"?
    Login to WebDAV works....
  • @OniDaito about 7000 entries. Thanks for looking at this.
  • @OniDaito but I have only 97 items without autor in My Library and all of them has Title filled in. In group libraries I have about 40 items with empty field Autor and about 10 are without Title too.
  • What is the "User Secret"?
  • @fmuro @LiborA righty-o then. I'll bump these fixes up the priority list for next week. Hopefully I can take care of that. The author one is quite odd as it's a field I do check for (I don't hold them all).

    @rainerstahl You don't need to fill in user secret or userid. These are automatically filled in when you do the 'OAUTH Dance' with the Zotero server (where ZotDroid asks you to login, then chrome fires up and loads the Zotero page etc etc). It is simply convenient for me to hold these details in the preferences setting instead of, say, the database. I might change that around to prevent such concerns in the near future.

  • Hi there, I checked what version I'm running before posting this time, and good (ish) news 0.5 seems to be working.
    [ I'm trying this out on a Samsung Tab A (SM-T580), which I'd hope isn't too underpowered. Might give it a go on my phone too. ]
    However: it took ten minutes to go from a blank white screen to showing the items on first opening Zotdroid.
    I then realised it wasn't updated so hit sync. The sync itself seems to finish pretty quickly.
    But then I had to wait another fifteen minutes before Zotdroid became responsive again and showed the newest collection.
    But at least it's not crashing.
    Haven't enabled webdav yet.
    Yet another feature request / suggestion: could it automatically sync before it tries to do anything else? This would (hopefully) remove one long wait.
  • edited November 15, 2017
    Search function dnes not find co-authors, only first author is found.
  • hello, I have tested the webdav. Since I build webdav server myself, with self-signed certification, so here are two suggestions/problems:
    1. It seems not support the self-signed certification
    2. when I change to http:// instead of https://, then when I hit "Test WebDav Connection", the app crashed.
  • Thanks for the updates everyone. I've added some fixes to the list. At the moment, I'm working on 'paginating' the results so it only loads a certain number of items on demand from the database. I'm *hoping* this means we get past the long load times people are seeing. I'll hopefully get this version out this week so folks can test it.
  • Well, that answers that one! :) Initial population of the DB is the cause.


    I think I can fix that :D
  • I think my db is too heavy for this app: took 5-10 mins to sync, and since then it either freezes or crashes. (I have 4000+ items)
Sign In or Register to comment.