ZotDroid - A Zotero Client for Android

145791012
  • Very interesting. If it's possible to get a trial account with box I shall do that and test things from my end. I can take a look at that later today hopefully.

    Are there any others errors you receive?
  • Sadly, Box don't do trial accounts so I can't test from here. I'll see if there is any literature on their specific setup.
  • Are there any free alternatives which are tested to be compatible? I can switch to that if possible.
  • @OniDaito Box has free individual accounts with access to WebDAV. What exactly is the issue you are having?
  • I believe they want you to pay up front first though. Whether or not this is refunded later I've no idea but I looked before and that was the case. I suspect they will have some api guide I can look at. For my test setup, I've used my own webdav backed by nginx which seems to work fine. I suspect there might be a URL formatting issue or something. Taking a look today.
  • I notice that the url for webdav access for box is:

    https://dav.box.com/dav/zotero

    Where does that extra number come from? I'm intrigued
  • Ok, I tell a lie, it is possible to get an account for individual use - it's just a little more buried than the business ones. I'll take a look
  • Ok, I've found the answer. Webdav actually does work with Box as I suspected.

    What *doesnt* work is the Test Webdav. The reason? Box does not allow you to perform a GET request on a directory. Essentially, you can't just view the contents. This means I need to perform a different sort of 'test' on webdav servers to confirm that a connection works. I'm not sure what that would be (maybe something like HEAD or OPTIONS). That might work a little better.

    You should be able to use the attachments as they stand right now. I'll fix the test section in the meantime.
  • @chendan93 version 1.1 is now out and should fix this. It is literally one line I've needed to add to change from a GET to OPTIONS request. Quite irritating but at least we've ironed it out. Thanks for your help!
  • @OniDaito installed ZotDroid v.1.0
    Have sent through another crash report - still can't reliably (or quickly) select a folder without the app hanging.
    Samsung S7, Android 7.0
  • @Jon%20Rubin hello there. I see only one bug report dated on the 4th of Feb which I assume is yours (they are anonymous of course).
    If this is the case you are definitely using the older version of the code. The report tells me the version numbers. This one is is clearly from an older version.
    Two possibilities. Either this report is not yours (and the one you sent didn't make it to me) or you still have the older version installed.
    Latest version is 1.1 and it has the Red Z pixelated logo.
  • @Jon%20Rubin there is a third possibility actually. Looking at that report, assuming it is correct, I wonder if the program is trying to upgrade it's database? Have you completely 100% removed ZotDroid BEFORE installing the new version? The reason being is that it could be calling older code before it performs an update. It's a long shot but Android might be trying to be clever. The error I'm seeing is all to do with updating attachments - an error I've definitely fixed in the later versions.
  • edited February 4, 2018
    @OniDaito when you say "completely 100% removed ZotDroid" do you *just* mean uninstall it? Or do I have to manually delete anything as well?
    It's very possible I'd let Zotdroid automatically update.
    I'd installed version 1.0 - will upgrade to 1.1 (I thought the difference between them was only relevant to webdav, which I have not yet tried to get running).
    Have unistalled Zotdroid and will try reinstalling it and running it again, cheers.

    Still getting the same result. Have sent through more crash reports.
  • @Jon%20Rubin so I can confirm I don't have the reports. Not quite sure why that is but it does explain a few things. It's a bit problematic as I really need to see these reports. Presumably you are connected to the internet when you are using ZotDroid yes?
  • @OniDaito yes I am connected to the internet! That is weird. I do get the "Thanks for the feedback" splash screen pop up. Have just sent through another report. Stuck my name in the feedback - at this point annonymity is more of a possible hindrance than a help!
  • @Jon%20Rubin Interesting. Are we talking about the same thing here? I don't think you can stick your name in the feedback of the bug reports - they are automatic. I've still not received any. I'm not quite sure what to suggest at this point.
  • @Jon%20Rubin actually Jon, best thing at this point would be to take this off the forum and email me at me@benjamin.computer - perhaps we can skype this and you can show me exactly what's going on and we can sort it from there.
  • edited February 7, 2018
    @OniDaito When downloading attachment through webdav, it shows that: Error: Problem writing to location. Check your downloads directory setting in webdav setting.

    I did not make any changes to the download directory of the app.
  • @Alsichkann-Zhang Hello there. Sometimes, Android chooses the incorrect directory to save attachments. More often than not it works, but sometimes, it has trouble.

    Go to the general settings and type in the save location under 'download directory'. I use my sdcard / external storage, so something like /storage/emulated/0/Documents/ZotDroid.

    Selecting a public directory always works.
  • edited February 8, 2018
    I love this app so far.

    I downloaded v. 1.0 a few days ago from Google Play Store. When I launch app says 1.0. On v1.0, WebDav test fails for me similar to what others have described (I have been successfully using box WebDav server for over a year on Zotero standalone). I should add that I have not been able to access .pdf files, though ZotDroid indicates they are stored (albeit somewhere). Now supposedly ZotDroid v1.1 is available.... but Play Store dsiplays buttons for Open and Uninstall (but not Update or whatever it says if update available). I restarted phone to no avail. Don't know how to update to v1.1. Hmm, what to do. I have high hopes for this app!!
  • For these trying to upgrade, please give this a go:

    https://support.google.com/googleplay/answer/113412?hl=en

    I don't have much agency within the android store - I can only confirm 1.1 is there and that's the one that appears on the page.

    In the interim, webdav attachment downloads will still work
  • Two things.

    First, regarding the Google play store link above: I followed 3 suggestions in the link. a) I already had/have auto-update enabled. b) When I navigate in play store app to Updates, ZotDroid is not listed there. c) When I navigate in play store app to Installed, ZotDroid is there and the button says Open. I still have ZotDroid 1.0 not 1.1 according to the splash screen in-app in ZotDroid (are you sure you updated the splash screen?).

    Second, regarding "In the interim, webdav attachment downloads will still work". Not for me. I get an error message Error: Could not find file to write to. Consider changing your Downloads directory to a publically accessible folder. In settings general, Downloads Location, I tried to change to /Internal Storage/My Documents/ or /Internal Storage/My Documents (which details for one of my documents had... and had the format of original Storage Location, respectively. In both cases download didn't work (Same error message). When I went back in to settings general, Downloads Location, I notice (in both cases) it has reverted back to the default /storage/emulated/0/Documents/ZotDroid.

    So, in the interim, so far, I am unable to make downloads work with what appears to be ZotDroid 1.0. Thanks for your efforts writing and supporting this.
  • @protein%20function Thanks for getting back.
    Problem 2 is as it sounds - the directory just can't be written to by zotero or possibly read by the pdf reader. Ultimately it's a permissions thing. It seems the various androids do things differently and there's no consensus as to where to store.

    Not sure how to fix the first thing. I've followed everything on the Android store. I'll have to pester or read around a bit in order to sort it I suspect.
  • @protein%20function Actually, reading your response again, I should point out the directory either needs to already exist, or be in a place where Zotdroid can actually create it. Given all the sandboxing that goes on, I'd suggest somewhere like the external storage / Documents / ZotDroid. This works for all android versions I've tested. Which are you using?
  • edited February 8, 2018
    @OniDaito I am using Samsung Galaxy S8, Android 7.0. OK, I will try a path like external storage / Documents / ZotDroid

    Side note: Until your comment 'use external storage' (and then researching it), I did not clearly understand that my phone CAN accommodate an SD card. I thought I remembered it could.... but never confirmed or understood that (and how) it could until now :-)
  • @protein%20function yeah, I've had a lot more trouble with this than I thought I would. Zotdroid needs to read and write to a directory AND your PDF Reader etc ALSO need to read these directories and that's a bit of a pain for Android Security reasons. I test for this in code and it works *most* of the time.

    Often, so called *external storage* isn't often external. On my Nexus 10, it's actually internal and simulated, so even that name makes no sense. Something so simple has proved to be a real pain.
  • @OniDaito Well, many thanks for your effort. I am excited to be able to access Zotero libraries and pdfs using Zotdroid. This morning in lab meeting (based on a presenter comment) I found a reference on my Android phone web browser that I'd like to send to my Zotero library. I don't believe Zotdroid can do this (yet)..... but would be awesome to have this obvious functionality.
  • @protein%20function so does it work for you now? I hope so!

    I originally wrote ZotDroid because I really wanted to read my papers on my hammock (that was originally going to be the name!) and so the last thing on my mind was organising or adding new things. I find tablets and phones really awkward for organising things so Zotdroid was designed to be read-only. However, it's not just about me I realise; getting all the feedback on what folks want has been really good.

    However, as you've noticed with the downloads, interaction between programs on Android is a real pain! I've yet to be able to add a logout feature, because a program can't make requests of a browser. Sandboxing for security has done away with that, and for good reason. Even the desktop is going this way, with Firefox forcing Zotero to change their plugin.

    I suspect the best answer in your case is to install one of the official connectors from Zotero into your mobile browser. That way, you could add and then resync.

    A few folk have asked for this functionality and I admit I can see the appeal but aside from a clunky 'cut-and-paste' link affair, I'm not sure how it can be done. Also, I'd have to figure out a way to take apart a link and do all the author / title / metadata stuff which would be a lot of work, if its even possible.
  • edited February 8, 2018
    @OniDaito

    You asked "so does it work for you now? I hope so!" I won't know until I go home tonight and insert a microSD card. I will let you know (sorry for the delay).

    Regarding adding citations via Zotdroid and alternatives: While I don't PREFER to do new research on my mobile device, sometime it just happens that way (and you don't want to lose it). I did not realize it was an option to add an official connectors for Zotero into my mobile browser. I will try this and wish I would have known this was feasible. I would be fine --actually thrilled-- with this workflow for getting from mobile into Zotero.
  • @protein%20function cool! Let me know how you get on. A few folks have asked for saving to ZotDroid. I've not tried the connectors myself (maybe I should) but it'd be nice to know how well they work and whether or not it's worth me adding this functionality somehow.
Sign In or Register to comment.