Mac Office 2016 Zotero 5 Addin doesn't appear

edited August 7, 2017
Hi folks,

i have read a ton of manuals and workarounds but i don't get the "Add-ins" tab shown.
I installed the newest Zotero version and i am using Mac Word 2016.
The *.dotm is in the correct folder (see screenshot #1) and is activated automatically when Word is started.
But i don't see an "Add-in" Tab with Zotero Buttons.
I tried also the file, but this does also not work.
If i trigger the zotero macros manually via Macro List (screenshot #2), it works.

screenshot #1:

screenshot #2:

I also tried to reinstall the "MS Word Addin" in the Zotero Settings several times.

Thank you for your help
  • That is quite odd to have the macros show up and work in the macros list, but not to have the Zotero tab appear. What security settings for macros do you have set in Word?

    If you open the Customize Ribbon tab, do you see the Zotero icons in the “All commands” list?
  • We have had a few reports of this for Word 2016 with the Zotero 4.0 plugin interface, but this is the first one for the updated plugin.

    You could try these recommendations by Microsoft, reinstall the Zotero plugin and see if the Tab appears.
  • SOS. Similar problem even worse.After upgrading to Zotero 5 The Mac Word 2016 plug -in is not working. I have tried everything including manually installing the dotm file several times. The add-in tab has disappeared from Word and I get a message 'compile error in hidden module' . I have also tried installing back Zotero 4 but I get a message that the database is not compatible now. I have a deadline coming up and I have been struggling with for two days to fix this. I really like Zotero I never had problems till now. Urgent help needed. Thanks
  • Have you tried resetting the normal template as described in above link and reinstall the plugin? Did that do anything or no change? When do you get the "compile error in hidden module" message?

    You can awkwardly access Zotero macros by going into Word Preferences -> Ribbon and enabling the Developer tab, then in the Developer tab clicking Macros.
  • Hello, I have the same problem. I only can use Zotero using Macros. I tried to follow the Microsoft recommendations but I didn't get results. Can you help me please?
  • Ok, let's try this. I've taken it from Endnote instructions and adapted for Zotero, since it seems that this is just a general problem with Word 2016:

    1. Quit Zotero, Word and any Microsoft application.

    2. Find and drag the Nomal.dotm template to your desktop.

    3. To access this folder, please click on the Go menu of your Finder and then press the "Option" key on your keyboard. Library should then appear as an option in the Go menu. Click this and proceed to Group Containers/UBF8T346G9.Office to find the Normal.dotm file.

    4. Rename this file Abnormal.old

    5. Look for any pre-2016 Normal templates on your computer. Drag them to the desktop and rename. The location would depend on the version of Word:

      • Word 2008 and 2011: Click on the Go menu of your Finder and then press the "Option" key on your keyboard. Library should then appear as an option in the Go menu. Click this and proceed to Application Support/Microsoft/Office/User Templates to find the Normal.dotm file.

      • Word 2004: Users/[your login name with the house icon]/Documents/Microsoft User Data.

      • Word X/Microsoft/Office X/Templates.

    6. Remove or rename the following files/folders if they exist:

      • Users/[your login name with the house icon] /Library/Containers/

      • Users/[your login name with the house icon] /Library/Preferences/Microsoft/Word Settings (10)

      • Users:[your login name with the house icon] /Library/Preferences/Microsoft/Word Settings (11)

      • Users/[your login name with the house icon] /Library/Preferences/com.Microsoft.Word.plist

      • Users/[your login name with the house icon] /Library/Preferences/Microsoft/Office 2011 (The entire folder would need to be renamed or removed here)

      • Users/[your login name with the house icon] /Library/Preferences/Microsoft/Office 2008 (The entire folder would need to be renamed or removed here)

    7. Restart your computer.

    8. Empty the Trash.

  • Unfortunately not working. I've removed all of the files listed above, the re-started the computer, and while the macros for Zotero are easily listed, the icon still does not appear.

    So I tried removing the files normal.dotm for all listed again in the same locations, then restarted the computer again, and prior to opening either Zotero or Word went to see if the files were still present - and they were present, again in the same location (file normal.dotm). So despite deleting it, emptying the trash and removing all of the other files as recommended, somehow Word is bypassing it and re-installing the template file normal.dotm. Are there other plist files that need to be removed or any way to prevent this from re-installing the normal.dotm files?
  • The removal of normal.dotm is required in case it got somehow corrupt. When it is not present upon starting Word, Word creates one directly from the application, so what you are seeing is correct behaviour. I'm pretty much out of ideas to test, but there have been many reports of Zotero (and Mendeley too) plugins not appearing in Mac Word 2016 for people, so we should start complaining to Microsoft by this point, although it seems that their support is limited.

    One more thing. If you open Zotero.dotm itself with Word, do you get the Zotero tab then?
  • Thank you for these instructions, @adomasven. I was able to find and rename the Normal.dotm file, but that did not resolve the issue. I wasn't sure how to locate the Library file under Users (is it the same Library file in which the Normal.dotm file was located? Please forgive my ignorance! I'm still rather new a Mac environment).

    So for, I still have no Zotero tab when I open Mac Word 2016 on my MacBook Pro. However, I haven't, as I said, tried renaming or removing the other Users files you listed. I am also not sure how to open Zotero.dotm from within Word itself. Would you be willing to provide instructions?

    Thank you!
  • In finder if you press Cmd-Shift-G you'll get a location prompt where you can enter the locations manually.

    To find zotero.dotm see the first part of manual installation instructions.
  • Thank you, @adomasven. I checked for all the other files. None of them were on my computer. I also opened zotero.dotm using Word. No Zotero tab appeared, even when directly opening zotero.dotm.

    Any other ideas?

    Any help will be greatly appreciated!
  • You could technically install the, which is the older version of the plugin we still support for previous versions of Mac Word and it will likely work. Just follow the manual installation instructions above and place instead in the word startup folder. This is not a long-term solution, but we'll try to talk to Microsoft and see if they have any thoughts on this.
  • Right, so another thing to try is going into Preferences -> Ribbon & Toolbar, clicking the gear in the bottom right and resetting all customisations.
  • There's also an option under Preferences -> General labeled "Show add-in user interface errors", that you might want to enable, restart and see if you get prompted with anything.
  • I had exactly the same pb :

    I did exactly what was precise here :

    Then I closed everything and miraculously I could re-install my Zotero Word Mac integration!! (tool>extension)

    Hope It'll help

  • I had thought that this trouble making Zotero 5.0's Word integration work was only going to be a problem for people on our campus network, whose computers are not allowed to enable macros. So I was shaken when I was helping a colleague with a Zotero class, and it turned out fully half the students in the group could not get the Word plugin to work on their laptops. We've never had so many problems with Word integration as now. It's worrisome.
  • As you can tell from the above (the instructions copied from Endnote for the identical issue), all reference managers are having these problems with Word 2016 -- it would seem particularly on Mac. It's very frustrating for everyone involved.
  • Ok, let's try this. Could anyone in experiencing issues try manually installing this Zotero.dotm file and seeing if the tab shows up?
  • Thank you again for your help, @adomasven. I just reinstalled Office 2016, and now Zotero is working. I'm not sure why, but I'm glad!
  • I am another user who is having this problem. I have reinstalled both Zotero and Word and have followed all solutions with no luck.
  • could you specify this a bit more? In what way _exactly_ is it not working?
  • edited September 19, 2017
    There is no 'Add-In' tab in Word. I can see the macros, and have done all of the above steps including reinstalling both Word and Zotero, as well as re-installing the plug-in and manually installing the plug-in.
  • but you're seeing the macros and are able to call them from the developer tab?
  • That is correct.
  • @jzgarrod Does installing the alternative Zotero.dotm or the older manually produce no results either?
  • That's correct. Neither work.
  • After installing say (not the dotm, to be able to distinguish), do you see it under Developer -> Word Add-ins?
  • I wasn't able to get the Word add-in to work (Mac, Word 2016, Zotero 5). Reading advice on this page I found Zotero.dotm installed in the correct Word folder. I had changed my Word startup folder, so I reset it to the default. When I closed and reopened Word, the Zotero tab was visible and I'm set to go. Resetting your Word startup folder to the default may be the answer if you having problems!!
  • Nope, still doesn't work.
Sign In or Register to comment.