ZotFile - Advanced PDF management for Zotero

  • @ben.hjorth Sorry, I can't reproduce either of those problems. I am leaning to thinking that something is wrong with the installation/file structure of Zotfile or Zotero on your system. Do the problems persist if you install them on a different computer (for testing)?
  • Yes, I keep downloading Zotfile again and again (I'm not a Firefox user normally, so maybe it did not do it properly). When I told you that I added a Dropbox subfolder in Zotfile, I meant from the Zotfile preferences (which I accessed on Firefox).

    Zotero version:
    Firefox: 52.0.2 (64-bit)

    Could the problem be linked with the fact that I have always used Zotero Standalone until now (with Chrome), and that there is a problem since I changed, for instance on the repository?
  • My first recommendation would be to just go back to using Zotero Standalone. The Firefox-based version will be discontinued very shortly when Zotero 5.0 is released (currently in Beta and very close to ready).
  • I did. And it works perfectly! :)
    Sorry for disturbing you for nothing, I will now discover Zotfile!
  • thanks @bwiernik - yes the issue is the same across both PC and Mac versions of Zotero Standalone 5.0-beta.180+de7b56b and Zotfile 5.0.0b3. I'm also not the only one experiencing it - see here on github where at least two others report the same problem: https://github.com/jlegewie/zotfile/issues/268.

    could it be related to using Dropbox for my storage directory? to repeat, the path is
    Users\bensefth\Dropbox\zotero\library, with %c entered as the subfolder definition. So, instead of (for e.g.) Dropbox\zotero\library\masters\hegel they're being saved in Dropbox\zotero\library\undefined\masters\hegel, etc.

    I did see something upon installation of Z5 warning against using Dropbox - however for me there's no real alternative in terms of having my attached documents available on multiple computers. tho I have also been getting strange behaviour on both the PC and Mac where the "Conflict resolution" screen flashes up (and then immediately disappears) a few times whenever I add a new file on either machine, and I had wondered if this had anything to do with using Dropbox, which obviously syncs itself independently of Zotero as well...

    as for why the author/editor issue can't be replicated, that remains an absolute mystery to me, but is of far lesser importance than this problem.

    thanks again @bwiernik really appreciate your help
  • The warnings against Dropbox only apply to storing your Zotero database in Dropbox. Using a cloud drive as your Zotfile folder shouldn't be a problem.

    Do you mean Zotero's or Dropbox's conflict resolution window?
  • edited April 23, 2017
    I *did* have my database in Dropbox... I wasn't aware this was such a problem. Tho now I read you commenting elsewhere that "It takes a lot of diligence to be sure that no Dropbox sync is ever running when the database is open in Zotero, which will cause corruption." eek. I have not exercised said diligence. Is my database likely to be corrupted? Can this be repaired?

    I have now moved the Data Directory location back to the default, i.e. my laptop hard drive - I understand that it will still work on different machines via Zotero's own online sync. I also moved the "Linked Attachment Base Directory", which had also been set as Dropbox, to the hard drive. Tho my understanding is that this isn't particularly relevant to me, as I rename/refile everything via Zotfile - to the "library" folder and %c-defined subfolders (preceded by the mysterious "undefined") on Dropbox.

    I have also updated to 5.0-beta.182+d472752 on the Mac (running Sierra 10.12.2). Not currently able to change the settings on the PC but the computer should be asleep, so not syncing.

    And yes the conflict resolution window is Zotero's - it flashes up and immediately disappears. It's still doing this after changing the database location and the update.
  • A small feature suggestion for Zotfile.
    I frequently use HTML formatting in title fields, especially around things like book titles in article titles to italicize them. Zotfile handles this by replacing <i>Word</i> with iWord-i, which is fine, but it would be more elegant to drop the tag and its contents entirely.
    So my suggestion is to add a checkbox option such as "Ignore HTML tags" to the Zotfile preferences, which would instruct Zotfile to simply strip away anything between angle brackets.
  • You should not be placing entire fields in HTML markup to format them. That should be done using the CSL style. Markup should only be used to style specific words within a title (e.g., to italicize species names in biology).
  • edited April 23, 2017
    Sorry if I wasn't clear--I'm not using tags to markup entire fields, just terms within them such as foreign words. By "book titles in article titles" I meant italicized book titles that are mentioned in the title of an article, e.g., "No Elephant in the Room: The Absence of Pachyderms in Hamlet." My ideal outcome would be that the filenames that Zotfile creates for such titles skip over the HTML tags.
  • Hi,

    I was hoping someone could help me. Essentially Zotfile is extracting incorrect annotations.

    I am using windows and the firefox zotero version. I can annotate PDFs fine and these are saved appropriately in the child file in zotero.

    Zotfile seems to extract the annotations but they are all incorrect and not what I have highlighted at all.

    Incidentally I am using a Surface Pro 4 with surface pen to highlight on windows 10. I don't know if that should make a difference.

    Thanks in advance for the help.
  • What (software) are you annotating with/on exactly? I'd try Acrobat to be sure you're using something that others have tested.
  • thanks for the reply @adamsmith.

    I am annotating with Adobe Acrobat reader DC. I'm pretty sure it's the latest version.

    Any thoughts on what the problem could be?
  • Hi, not sure if this is the right place to consult but I have been having trouble with my extracted annotations. Just wondering if anyone knew why/how to combat the problem of the extracted annotation links opening in Preview in Mac instead of the Adobe Acrobat reader? Acrobat is already set to the default program for ALL my PDFs so it is not a problem with my Mac preferences.

    It sound kind of unclear, its hard to explain but lets say I have a book titled: Bob Goes to the Store in my collection, within that book (RIS citation file) I have in it a PDF and the yellow sticky note indicator file for extracted annotations. The PDF attached to that book item when double clicked opens up in Adobe Acrobat (as it should) but when I go click on my yellow sticky note heading (my extracted annotations) and click on the hyperlinked part next to my quote [Ex. "Bob said he went to buy cat food..." (Lee2016:3)] The hyperlinked part is opening up to the highlighted page in the Preview application for some odd reason despite the fact that the linked PDF opens in Adobe Acrobat.

    Any and all help is appreciated, thanks!
  • I'm having the same problem @dks1570 .
  • edited May 6, 2017
    @dks1570 and @sete: The developer states that on the Mac the backlinks are working either with Preview or with Skim. (Changing from one to the other is possible via hidden options in extensions.zotfile.pdfExtraction.openPdfMac_Skim). For more see Zotfile ("Goto annotation in PDF" section). If I'm not mistaken Acrobat was never on the cards. I agree that it would be desireable as a third option.
  • (originally posted this in main forum - didn't realise there was an uber thread for zotfile)

    Hi guys

    I'm using Windows 10 and the Drawboard universal app. When I go into annotations that Zotfile has created, the link opens up a blank white page. It should open Drawboard. When I open PDFs normally in Zotero, they open in Drawboard, so it seems like the default viewer is set okay. In the about:config settings, the zotfile viewer is set to "default". I haven't changed it to the Drawboard exe file because for some reason the exe doesn't work when you run it as a standalone file.

    Has anyone else got this working or is it just a limitation of Drawboard?

  • @kithairon thanks for that information! This entire time I have been really paranoid that something was going wrong and it would affect my work later on. Thanks!
  • I have a weird problem... using Zotero standalone with Zotfile 4.2.8 (I think those are the latest of each?) on Windows 7/64.

    I have Zotfile set up with its tablet folder on Dropbox, and this has worked well for a few years now. Today I wanted to send some new stuff to the tablet, and found that it worked for some items and not for others. All of the items in question are present on the PC's local drive, but with some of them clicking "Send to tablet" does nothing.

    I realise that this is almost certainly too vague to help from, but can anybody tell me what other information might be useful? I'm at a bit of a loss as to how to diagnose!

  • Do you have those items open in your PDF reader? Zotfile won't move them if they are.
  • Fair question, but... no. I just tried, having double-checked.
  • AH! Mystery solved. I have no idea how, but the problematic files had lost their .pdf extensions. They are all papers with very long names, so possibly there's an issue with Zotero's rename features in that case (or not - I haven't investigated much), but it's not a Zotfile problem.

    The extensionless files still showed with PDF icons in Zotero, and would still open when double-clicked (but via an Open With dialog), but I'm guessing Zotfile simply couldn't see a PDF file attached to that item and so did nothing.
  • edited May 23, 2017
    I'm having some trouble getting Zotfile to rename my files. I created a user wildcard set which is valid JSON, and the preview in the Zotfile prefs window works just fine. However when I use the context menu to rename the attachment, nothing happens. If I add a new attachment, the correct filename is given to it, based on my zotfile format. If I switch to using Zotero for renaming, it'll work.

    I've now deleted my user wildcard, so it's just {} again, and still nothing happens if I have Zotfile set to use my format for renaming.

    (The problem I'm trying to solve is having tags in the title, as in "\<\i\>Italicized Title\<\/i\>". Zotero keeps the "i", though it drops the angle brackets, and I thought I would handle it with Zotfile. Other solutions welcome.)
  • thank you for developing this very useful tool.
    I have a question, I cannot really understand what the Attach New Files to Zotero Items function is, and how is supposed to be used. I have read and reread the description but I do not understand if it is automatic, if it is user triggered, and how does it actually work.
    I would appreciate if you could explain this.
  • It looks in the folder you specify in the Zotfile settings and attaches the most recently added file to the currently selected item in Zotero. It is manual, not automatic, as of Zotfile 5 (currently in beta). (Zotfile 4 and earlier included an option to "watch" this folder and show a pop up automatically to add new files, but this feature was hard on performance and didn't always work reliably, so it will be disabled once Zotero 5.0 releases.)
  • @bwiernik Thank you, in fact it is a really useful feature. Is it possible to avoid putting conjugations and articles in the title, or avoid word of 2-3 letters? I would like to have titles without "in","the","on", etc. Thanks
  • Feature request: When you set %c for subfolders, zotfile prompts which subfolder if item has multiple zotero paths. If you are renaming files from within a subfolder, could the selection default to that current subfolder?
  • Any major bugs remaining with Zotfile and Zotero 5.0?
  • @xxtraloud You could add a user-defined wildcard that runs a regex on the title to remove filler words, but there is no way using the default wild cards.
  • I've upgraded to the latest version of Standalone Zotero. (I'm a Mac user.) Have been trying to get Zotfile to work with it. Standlone Zotero says there incompatibility with Zotfile. According to this thread there's Zotfile 5 (in beta).

    Is this correct? If so, how do I get
This discussion has been closed.