ZotFile - Advanced PDF management for Zotero

  • Hi Tsau017, it wasn't on the list, but I've unchecked the option and restarted, and I'm still having no luck. I'm wondering if part of the problem may be that macOS appears to treat the epub as a package/folder, rather than as a folder.
  • hi, apologies if this has already come up -- I didn't seen anything quite like it on a seach. I've successfully downloaded and installed zotfile and having been playing with the renaming rules to suit my preferences, but they seem to have become stuck. In the plugin preferences, I have for "Format all types except patents":

    {%a } - {%t} ({%y})

    with "Change to lower case" checked, and the "Use Zotero to rename" box unchecked (checking it doesn't seem to make a difference). When i use the "Update" button in preferences (for a preview of the renaming rules) it works correctly, e.g. it will show:

    walton - ramus and bacon on method (1971)

    But if I actually run "Rename File from Parent Metadata" in Zotero, the file will be renamed in this format (for comparison):

    Walton - 1971 - Ramus and Bacon on method.pdf

    These settings correspond to a previous set of renaming rules (i've been trying different rules); it worked correctly at first but, like i said, it seems to be stuck with an older set of renaming rules that won't update. I have tried removing and reinstalling the plugin after re-downloading, restarting Zotero, restarting my computer, etc., and nothing seems to work. Any help would be much appreciated. thanks -
  • The "Rename File from Parent Metadata" function is the native Zotero renaming function. To use Zotfile's format, look lower in the context menu to Zotfile's section: Manage Attachments -> Rename attachments
  • thanks, bwiernik --
  • Identified by adamsmith as a zotfile error - please see Zotero Forum Discussion item https://forums.zotero.org/discussion/63547/zotfile-tablet-transfer-error#latest

    Essentially I have 4000+ items in my library that I wish to send as pdfs to a new HDD folder - call it C:\Zot_temp. Most, but not all, of these items have previously been sent to a different HDD folder (e.g. C:\Zot_pdfs) after retrieving metadata from pdf. When I now select the items & use "Mange Attachments" -> "Send to Tablet" I get the error msg captured on https://www.dropbox.com/s/zsypyg9zmw7sp1u/Zot1.docx?dl=0 (see towards end, and also most recent comments by adamsmith on above Zotero Discussion thread). No pdfs get transferred over.

    Using latest Windows 10 updates & Zotero with zotfile 4.2.7 (updated 13.11.2016).

    Many thanks Richard
  • In case anyone here may find this useful, I made some tweaks to get Extracted Annotations in different in-text citation formats.


    Many thanks for Zotfile!
  • Just a quick recap (concerning only 2 points):

    How to just move files without renaming? (= change folders but not file name)
    In Zotero Standalone, go to Actions->Preferences->Advanced->Open about:config. Set extensions.zotfile.disable_renaming to true

    How to move any attachement (not only pdf, text…)?
    In Zotfile preferences > Advanced Settings > uncheck "only work with the following filetypes (or leave it checked and add your extensions)
  • Hi all. Firstly, a shout out to the people tirelessly answering questions and providing help on these fora! Thanks. Can I make one suggestion first off - shunting all Zotfile-related queries to this one thread (as happened here, for one of many examples: https://forums.zotero.org/discussion/28016/zotfile-broken-source-folder-is-not-valid) makes it very difficult to find the answer to your specific query, as the thread is obviously now 50 pages long. Given the integral role of Zotfile now to a range of Zotero's functions I would've thought it was acceptable to start new threads for specific problems...?

    Specifically, my query relates to finding the Zotfile Preferences window in Standalone for Mac (which I'm running on Sierra), which I've been struggling with for several hours now based on the scant information I could find about fixing the "source folder is not valid" error message. On the Zotfile page (http://zotfile.com/) the description is "For Zotero Standalone, this option has to be changed on the ‘General Settings’ tab in the preference window (Zotero Actions -> ZotFile Preferences)", and this is echoed in one form or another in all posts I've been able to find. But I can't find "Zotero Actions", and this is additionally confusing as "the preference window" could refer to the Zotero Preference pane, which is not the right place for this.

    Finally I was able to find the right Preference pane via Tools -> Add-ons, then clicking the Preferences button next to Zotfile. But is there a quicker way that this? And what about this mysterious "Zotero Actions"?

    Thanks in advance!
  • edited February 26, 2017
    shunting all Zotfile-related queries to this one thread ... makes it very difficult to find the answer to your specific query, as the thread is obviously now 50 pages long. Given the integral role of Zotfile now to a range of Zotero's functions I would've thought it was acceptable to start new threads for specific problems...?
    If I recall correctly, the main reason for pushing people towards this single thread is that, this way, the developer of Zotfile doesn't have to scan through all Zotero forum posts. But the forum software was recently upgraded, and it's now possible to mention people (e.g. @Joscha) to alert them to certain threads, so maybe it's not as important anymore as it used to be.
  • That's correct. I only ask people to move here if I think Joscha needs to see it (and that's also what mronkko does in that old thread).

    The zotero action or gears menu is the little gear icon in the zotero toolbar. Not sure how else to describe that?
  • Thankyou! That's so simple. And yet I didn't encounter anything that actually made that explicit... Maybe the description on zotfile.com could be updated? Still a very beginner user here. Really appreciate your assistance!
  • edited February 27, 2017
    Ever since adding Zotfile, only about 10-15% of the articles I have wanted to add to my Zotero library from the internet have actually ended up in the library. A translation error is cited and the content does not display in Zotero. I have no idea how to remedy the situation or navigate this. I've tried the following and haven't noticed any patterns that would help narrow down the problem: (1) Using different browsers (I generally use Safari) (2) Using different websites with the same information, and (3) Uninstalling Zotfile. (I had no success with this.) My hands are tied and because of this, I can do very little with Zotero or Zotfile.

    I would like to be able to click the Zotero button on my browser and have the article/website upload into Zotero again.

    I use the stand alone version on a Mac computer.
  • This is not a Zotfile problem. Please start a new thread and post an Error ID for a failed import attempt.
  • Hello. I think a small improvement could be done on Zotfile. The name of the last author with an asterisk of a scientific article is usually the corresponding author which is a very important information, because according to this information we can know that this work is done by whose research group and/or the supervisor of this work. If the renaming rules in Zotfile can add a wildcard related to the name of the last author (last name and/or full name), it will be much more helpful. Thanks.
  • another beginner's question: I'm having some difficulty with renaming rules - specifically that, although the Zotfile wildcards list describes %a as for "last names of authors (*not editors etc*)", and lists a separate set of wildcards for editors (%d etc) therefore theoretically allowing for either optional or exclusive combinations of author +/- editor, Zotfile nonetheless insists on including both authors and editors for items that have both listed. this is relatively common in the humanities, e.g:

    Hegel (1986) Phänomenologie Des Geistes. Edited by Eva Moldenhauer and Karl Markus Michel. Werke: [in 20 Bänden], 3. Frankfurt am Main: Suhrkamp;
    Merleau-Ponty (1968) The Visible and the Invisible. Edited by Claude Lefort. Translated by Alphonso Lingis. Evanston [Ill.]: Northwestern University Press.

    in both these cases, with %a (%y) as the opening commands Zotfile renames the files as "hegel, moldenhauer, michel (1986)..." or "merleau-ponty et al. (1968)...", which is not correct in any referencing style I know of.

    I understand it's partly confusing because edited volumes, for e.g., are regarded for referencing (and there for renaming) purposes as having been "authored" by the editor. But in Zotero this only kicks in when there is no author listed. I tried %a|%d to try to make reference to editors exclusive to their being no author, but this didn't work.

    the only way I found to get around it with Zotfile renaming is to list these kinds of editors as Series Editors, but this isn't a solution because although it is strictly the case in the first example above, Series Editor generally implies that this person probably had little or no direct influence on the specific text in question (not generally complete works); further, this results in an inaccurate final Zotero reference that, in most styles, will leave off the series editor. in the second example above, again, it's not correct to call Lefort the Series Editor - he edited this single posthumous volume of Merleau-Ponty's.

    I'm running Zotero Standalone 4.0.28 on Windows 7.

    am I being dumb and missing something as usual? any help much appreciated.

  • edited March 29, 2017
    @ben.hjort I am not sure if I understand you, but renaming rules only say to Zotfile, how renaming your local copy of a document. For example, downloaded document with name "art%3A10.1007%2Fs11192-011-0580-x.pdf" renames Zotfile automatically to "Li et al_2012_Validating online reference managers for scholarly impact measurement.pdf". There is no link to any referencing styles, it is only name of your local copy of PDF.
  • Thanks LiborA - I do understand basically how Zotfile renaming rules work. I was just comparing Zotfile's behaviour regarding authors / editors (i.e. not sufficiently distinguishing them in renaming rules) to the general behaviour of Zotero (which does distinguish effectively in referencing).

    If anyone else has thoughts on this that would be great.
  • It's been a while since I looked at that code, but you should be able to prioritize authors at least by putting them at the top of the creator list for there item. I had thought that the author wildcard did only accept authors.
  • I doubt it's going to help for this (though you never know), but if you're actually using Zotero 4.0.28, you really want to update; that's a year old and something like 20 updates behind.
  • @ben.hjorth For me, %a is only showing authors. %d is only showing editors. To get author or editor, I use {%a|%d}. Please make sure your version of Zotero and Zotfile is up to date (I think I remember this being a bug that was fixed in Zotfile years ago, when the %d wildcard was added). Post back here if it's still not working.
  • Sorry y'all I didn't get notifications for these most recent replies (don't know why, notifications were still on - didn't even get an email when @bwiernik tagged me...). I've just upgraded to Zotero 5.0 (at the university I work on a network PC which requires Admin authorisation for every upgrade, which was why I was stuck at 4.0.28) and Zotfile 5.0 (hoping I did the renaming of the .zip file as .xpi right - it has loaded up in Zotfile OK), and so far it's *so* slow (on Windows 7) as to basically unuseable. I'm hoping this is because it's still syncing - I'm gonna leave it for a bit and restart the machine, as well as download 5.0 on the Mac (I've backed up) and see how that goes.

    But thus far, same problem with renaming - whether with just %a or %a|%d, and allowing 2 author names in the filename (1 + et al for more than 2), I'm still getting "hegel & findlay (1976)..." when Hegel is listed as sole Author and Findlay as Editor. to reiterate, this is a problem only for the Editor field, not for Series Editor. And prioritisation doesn't solve this problem, as regardless of the order, I get either two (apparently) author names, or an "et al", neither of which reflect the bibliographical reality.
  • Did you try putting the %a|%d in curly brackets like I did above?
  • Yes - that *should* fix the problem (with or without curlies actually), but it doesn't. Is nobody able to replicate this problem?
  • while zotero 5.0 has sped up (now, I assume, that it's finished syncing) I'm also having 2 separate problems, running Zotero Standalone 5.0 with Zotfile 5.0 on Windows 7:

    1. with the "subfolder defined by %c" option ticked, the attachments are being saved to a new directory called 'undefined' under the Custom directory I've chosen (Users\bensefth\Dropbox\zotero\library), and then the collection folders as they exist in the library. So that instead of ...\zotero\library\masters\hegel they're being saved in ...\zotero\library\undefined\masters\hegel, etc.

    2. when trying to rename a second attachment under the same item, Zotfile jams, staying stuck on "Zotfile: Renamed Attachments" with the original attachment file name in grey underneath. in the previous version it used to rename the file with a _2 underneath. this may be different on the Mac, which in general seems to handle renaming files better (i.e. will do so even while they're open in Preview) than the PC - I'm yet to try, will report back.

    apologies if this isn't the right forum for these further problems - please direct me to the right one if so. and thanks again.
  • putting aside the unresolved editor renaming issue for now - does anyone else have the same "undefined" folder problem as outlined in point 1 in my last comment? any clues? if I can't solve it I'll have to re-install an earlier version of zotero and zotfile on two machines which will be a major hassle. thanks!
  • Hello, I work on Mac Yosemite 10.10.5 and Firefox (but used to have Zotero Standalone with Google Chrome). I have downloaded Zotfile properly and everything seems okay, but the extension does not appear in Zotero and when I right-click on a PDF file, I can't select ‘Send to Tablet’ under ‘Manage Attachments’ (the options just do not exist). I have restarted Zotero and Firefox several times and don't know what to do. Thank you very much in advance for your help; I'm excited to use Zotfile!
  • Check the Zotfile preferences. Are the settings specifying a tablet location, etc. configured properly?
  • Thanks for your comment. Yes, everything is perfectly fine, in "Preferences", I added a subfolder from my Dropbox. But it does not link with Zotero. From the window "Add-ons Manager" in Zotero, one can see that Zotfile does not appear. I have uninstalled and reinstalled Zotfile at least a dozen of times...
  • Okay, If Zotfile doesn't appear in the Add-ins Manager, then it isn't installed properly (it is the Zotfile preferences I was referring to, not Zotero's general preferences).

    What version of Zotero (number and Firefox/Standalone) and Zotfile are you using? Where did you download Zotfile from?
This discussion has been closed.