ZotFile - Advanced PDF management for Zotero

  • FYI, the highlights moving problem is apparently a Preview problem. Very sad.
    See: https://discussions.apple.com/thread/7322345?start=0&tstart=0

    I'm switching to another annotation program. Thanks for your help!
  • Thanks dragonfly.
  • Hello! I am running into an issue with the PC version of Zotero + Zotfile on Windows 10.

    I open the PDF file in the Windows 10 PDF reader and add highlights/comments. When I go to extract these in Zotero, it fails to do so. Additionally, it appears that when I click "Save as" in the PDF reader, it is not saving the PDF to the same location where Zotero keeps the file.

    This is strange, however, because I can still close the PDF file and double click the PDF from within Zotero with my highlights still in tact. This seems to imply it is saving it, right? Not sure what to do here.
  • What's the Windows 10 PDF reader? I'm not aware of built-in PDF software by Windows. Is this Acrobat or something else?
  • It's "reader" by Microsoft. https://www.microsoft.com/en-us/store/p/reader/9wzdncrfhwg5

    Also - I was able to use "save as" for the PDF, then re-import the PDF to Zotero and extract the annotations.

    Perhaps this is a problem with my workflow of modifying documents in Zotero? I realize this is something I run into on PC and Mac: when I open a Zotero PDF on mac it says I cannot modify the document unless I save a copy of it. On PC, it seems I am not able to save the documents to the location Zotero has for them. Any ideas?? And thanks for the quick reply!!
  • For Mac see here: https://forums.zotero.org/discussion/61014/macos-sierra-papers-protected#latest
    For Windows, I'd guess this is a some weird setting for reader. IIRC, the most recent Acrobat has something like that, too. Have you tried other software for annotations (Foxit, PDFXchange)?
  • Thank you about the Mac change!! And I can try Foxit to see if it still occurs.
  • Great, Foxit works perfectly! Thanks :)
  • My guess would be that you can get Windows Reader to save in the correct location, too (i.e. save rather than save as), but you'd have to figure out how yourself/via google.
  • Hi All,

    I'm having a little trouble with Zotfile, which has been working well.

    Now when I right click on a Zotero entry and choose Manage Attachments the first menu entry in each segment is 'Warning' and none of Zotfile's functions work.

    A search thorough recent system updates doesn't show anything that obvious that could cause this issue. I've also tried removing and reinstalling Zotfile to no effect.

    I'm using Ubuntu 16.04, Firefox 49 and Zotero

    Any ideas?
  • which ZotFile version?
  • edited October 23, 2016
    Zotfile 4.2.7 (which appears to be the most recent).

    That said, a few reboots and some time later the issue seems to have resolved itself.
  • I recently saw an idea for extracting annotations that would add a lot of functionality to ZotFile, but I don't know how much it would take to add it...

    The idea was to have different color highlights be categorized differently (Highlight, Disagree, Use, Look Up, etc), and extracted annotations would add a line with the category before the annotation.

    I'm throwing this out as an idea, as unfortunately I don't have the knowledge necessary to work on it myself.
  • edited October 31, 2016
    After update to Zotero 5.0-beta.r70+da7da74 (on Firefox 49.02 on Ubuntu 16.04 and update to ZotFile 5.0.0.b1) I am having problems with the Zotfile option 'Send to tablet'. I have defined a folder as destination, and before the upgrade to Zotero 5.0 I could simply send or retrieve files using Zotfile.

    However, now I am getting error messages when opening the search folder 'Tablet files' or 'Table files (modified)' and the function 'Get from tablet' doesn't work.

    Opening the search folders gives a string of error windows, with the message "The information stored in attachment notes is missing for an attachment on the tablet. Make sure that you do not delete information manually".

    Trying to get a file from the 'Tablet' folder gives the error message 'The file "" does not exist'. At the same time the usual download message "Zotfile: Attachments got from table" is shown.

    The same message appears when trying to extract annotations from the file.

    Any idea how to solve this?
  • I think the answer to my question is "No", but may be things have changed since I last checked.

    I use Zotero's "Link to File" to connect PDFs to my Zotero items. The PDFs themselves are stored in various research folder, but all under a base folder that I have defined in Zotero. What I want to do now is put all PDFs in one single folder. That is, no sub-folder. I think I can use Zotfile to move my PDFs and update the links to the PDFs, BUT that is possible only if I also tell Zotfile to rename those PDFs. And I do not wish to rename them.

    So, my question: Can I use Zotfile to move my PDFs without also having to rename them?
  • Zotfile does not currently support Zotero 5.0.
  • @gurdas I imagine you would need to be able to specify a wildcard in Zotfiles renaming options relating to 'file name' so that nothing changes (or possibly leave it blank?). I'm unaware of such a wildcard though.

    Can I ask why you do not wish to rename them? Is it because they are indexed elsewhere?
  • I am having problems - I set a custom location for files in the zotfile preferences to a folder I sync between computers. I chose the same folder on both computers but when I swap between computers, Zotero loses the link to the attachments even thought the files are synced.

    I read somewhere that I should make sure that i set the base folder for relative links in Zotfile but I can't seem to find this in the advanced preferences tab.
  • Zotero Preferences > Advanced > Files & Folders > Set base directory.

  • edited November 21, 2016
    @Tsau017 I will try with wildcard blank and see if it does nothing to the filename and yet moves the files (which is what I want). All my files are manually named to include keywords from the title. I don't think there are wildcards that are intelligent enough to know what *I* consider keywords in the article title :)
  • @gurdas Why name the file based on keywords? You can search in Zotero for keywords, or you can have Zotero index the entire pdf and search full-text right from inside Zotero.
  • @ben_a the Relative file links settings is in the Zotero preferences under Advanced --> Files and Folders
  • @Tsau017 I use Zotero's search features. I still keep my files organized because it's a habit and is a safe bet over long periods of time. The article PDF, in my mind, is a stand alone thing and should be named and organized for it's own sake. What Zotero does with it is beside the point. And what if 5 years down the line I am no longer using Zotero? I still want my PDFs organized the way I like them.

    Anyway, I think we are digressing from Zotfile and my question.
  • @gurdas I agree with you. Thats why I rename my files like this:

    Author et al (Year) Title.pdf

    Did you try the wildcard blank?
  • Hi there,

    I've just installed yesterday Zotero Stand Alone and Zotfile last versions on a windows 10 system.

    When i get notes generated by ZotFile from the Pdf Highlights : the hyperlinks in the note from within Zotero work just fine (i also set up the last version of pdf xchange).
    If I try to use those same urls from outside zotero, the zotero application will get maximised/bring to front/ and get the focus, but noting else will hapen. (Besides the item i left selected when minimized the zotero window is still selected).
    (this kind of links : zotero://open-pdf/0_BFN28QZS/8)

    Thanks for your advice
  • That's definitely not a ZotFile issue so anything else should go in a new thread. I believe this hasn't worked from outside Zotero ever, not sure how much can be done about that.
  • Thank you Adam

    Well It seemed to be ''kind of '' a zotFile issue from this : https://github.com/zotero/zotero/issues/498
    jlegewie commented on 24 Aug 2014
    "Just as a clarification: zotero://open-pdf are the links used by zotfile to open pdfs on certain pages. So it's not an official zotero protocol"

    But after a lot of going around there I understand it's more like a general issue : how to 'ask' zotero from say onenote to open an attachment when you know it's internal id (although I would obviously need more since there might be more than one attachment).

    I got lost into the questions of a local web server, whether a protocol like zotero: is only for internal use or can get parameters when called from windows (onenote). It doesn't seem impossible to code something that will use the java api of zotero upon external request, but certainly beyond my abilities (limited to very basic VB within the limited context of ms office applications with at most an extra library registered).

    I also befell on a comment it seems you made there : https://github.com/zotero/zotero/issues/992 From @adam3smith on zotero-dev:
    "is there any reason why (for an attachment) zotero://select/library/items?itemKey=4IRKVFFX" works..."
    But I don't understand in which context you're using this... (I still dumbly tried at least to open zotero onto a given item using such a link...) but it would still be too far from simply calling the zotero protocol and ask him (open_pdf) to launch the default pdf viewer with the (1st ? only ?) pdf attached to the item.

    Again within issue 498 pashtetGP on 8 Apr 2015 wrote :
    "I set up everything so that now can open zotero:// links from OneNote - the only problem is with empty window..."
    It seems that he was about to something…
    I'm now following that lead through something he posted there : https://pashtetgp.wordpress.com/ and titled : Zotero Links.
    I'm not sure wheter I'll be able to do something out of it for my own use. But that lead might help someone reading trough this thread later on.

  • Hi,

    This is just an other lead for someone who would be more lucky and techie than me and would want to use the zotFile get annotations through Zotero to link from a zettelkasten / index card system...

    Andus is talking of some work done by Brian Lennon in this post : https://drandus.wordpress.com/tag/zotero/
    "who discusses ConnectedText in the context of academic note-taking. I would warn people who are new to wikis and ConnectedText to keep in mind that Brian is dealing with fairly advanced features in CT, such as using Python scripts [...] Brian’s use of CT is a good example of its versatility and expandability with scripts and plugins, which can lead to integration with other tools, such as Zotero"

    But the blog and wiki are gone and I haven't been lucky with searches like : "Brian Lennon" zotero python or "connected text" zotero python.

  • Hi there,

    I'm having trouble attaching .epub files to items. Other file types, such as .pdfs, are fine and create a moved and renamed file attachment as expected, but when I drag-and-drop an .epub file onto an item, nothing happens. If I try to manually link an attachment, the macOS file picker opens up, but the .epub file twirls open, and when it's selected, its package contents are opened instead of the entire file being attached.

    Attempting a drag-and-drop results in debug output D120508812.

    I'm running macOS 10.12.1, Zotero Standalone and Zotfile 4.2.7.

  • In Zotfile preferences > Advanced Settings - make sure epub is added to the list of files that Zotfile is told to work with. Or just untick that option to make it work with all file types.

    If this option is already set I'm not sure what the problem would be.
This discussion has been closed.