RTF/ODF Scan for Zotero

  • Great, thanks for the quick fix!
  • Thank you so much, @fbennett - saved me, too!
  • I really love this plugin, because it allows me to use Zotero with Apple's Pages word processor. But I've run into trouble with a large document, a chapter from my dissertation. Here are a few links:

    Word version

    ODT version:

    RTF/ODF scan version:

    All goes well up to this point. I then open the rtf/odf scanned version in LibreOffice, click the 'Set Document Preferences' button, and then change the citation style to Chicago. But LibreOffice always crashes at this point.

    One important detail is that I can run individual sections of the rtf/odf scan back through LibreOffice, click 'Set Document Preferences', and then switch to Chicago, with no crash and the correct citations added. I've even been able to narrow down the problem to maybe 10 pages in the document. But I can't seem to find exactly which citations are causing the crash.

    Any thoughts?

    I'm using:
    OS 10.11.4
    Zotero standalone version
    RTF/ODF scan dated December 15, 2015
    LibreOffice (more recent versions don't seem to interface well with Zotero because of Apple's java problems)
    Java 6 (1.6.0_29-b11-402)

  • if I understand correctly, you can narrow this down to a 10 page document that always crashes with Set document preferences?
    Could we get that?

    Also, does LO fail with any particular message? Anything else notable about the crash?
  • Sorry, I should have been clearer:

    There's no single 10 page document, it's more like there are a number of separate pages throughout the document that seem to be causing the crash. I had a deadline for this a few weeks ago and so had to go through and basically run five page sections of the text through the RTF/ODF process until I could find track down which parts seem to be buggy and just delete the footnotes. But I didn't keep track of which parts were causing problems, because I was doing this at five in the morning. Sorry about this. My memory is that there were at least five distinct places that seemed to be causing problems.

    As for the crash, LO basically just freezes. I thought maybe the program simply needed a long time to process the whole document. But I let it run for over an hour and it never recovered. No specific messages or anything else otherwise. The only solution seems to be to force quit LO.

    Thanks! Let me know if there's anything else I can clarify. Really appreciate your guys's work on this!
  • I'll see what we can do, but this is going to be incredibly hard for us to troubleshoot, because "Set Document Preferences" is the step that connects the document to your Zotero library, so it's the one step that's effectively impossible for us to retrace.
  • Ah, I see — well, maybe it just can't be fixed then.

    Maybe I could send you my Zotero library somehow? Or give you the login?
  • @charlespeterson: The documents you posted above were enough. The cause is clear, and I'll post an update to the plugin soon.

    There are two bad references in the scanned document, with these citations (generated by the plugin):
    anon. President's interest list beginning "Lawrence Richard Adams", 1946
    anon. Notes on Selected Tables "Freshman Admissions and Financial Aid, 1973-74", 1974
    The quotes in the item title are not being escaped, which corrupts the JSON when the item is unescaped and parsed—it’s an obvious source of trouble, and I’m surprised that we haven’t been forced to confront it before.

    The plugin-generated citations are just ephemeral placeholders, so the simple solution will be to strip quote characters from the elements of the “cite” items before they are composed.

    Thanks for reporting this!
  • (thanks for checking Frank)
  • As a followup, it looks like we did account for this, but with the JavaScript upgrade in the latest Firefox, the code for it is no longer recognized. Fix up soon ...
  • edited May 13, 2016
    An update is now ready, you can fetch it here. I was able to reproduce the error in a simple document, and the revised version processes it without corruption issues.

    (Although there was code in there to transform quotation marks in various ways, it rather amazingly was not relevant to this simple case.)
  • Awesome, thanks so much guys! Will try the new version now. Can't say how much I appreciate this!

    Is there somewhere I can donate to the project?
  • Just tried with the new update and got the following error:

    "Zotero experienced an error updating your document. A field code in this document is corrupted."

  • Less certain this time, but try the latest release on Juris-M and see if it does better on your test document.
  • Okay, I installed JurisM and the RTF/ODF plugin.

    Now LibreOffice freezes when I run 'Set Document Preferences', no error message, although it does manage to change the names of all the citations to '{Citation}' before freezing.

    One other thing is that after I run 'Set Document Preferences' and force quit LO, JurisM then won't quite gracefully. There's no sign in JurisM that there are any problems, but when I try to quit JurisM, the program becomes non-responsive and eventually crashes. Also, after LO freezes, if I try to reopen the document in LO and run 'Set Document Preferences', I've also found that I need to restart JurisM — otherwise, when I click 'Set Document Preferences', nothing happens.

    One unusual thing I'm trying to do in this document is that I have most of the scannable cites also set as links so I can easily look at what they refer to. Another is that in some scannable cites, instead of page numbers, I have text such as 'Table 4'. Could either of these be causing the problems?

    Thank you again for all your help!
  • Sorry, I didn't mean to suggest that Juris-M itself was part of a solution; the RTF/ODF plugin is just hosted there. You can disable or remove Juris-M and go back to Zotero.

    I haven't looked in the document, but if there are link wrappers around the scannable text, that could indeed be source of trouble. If I find some time during the week, I'll look into stripping them out. (If you don't hear anything back on this thread by Friday, feel free to ping a reminder so it doesn't get forgotten.)
  • Awesome, thank you! I'd strip things out myself but I don't even know what's causing the problems — I've been able to use links with the scannable cites in the past…
  • Yeah, I'm not confident on the cause of the trouble. If you can reproduce the failure with a smaller document, it will be helpful.
  • I went through the document to try to localize the source of the trouble. It seems to be a citation that I had deleted from my Zotero library but that I had forgotten to change in the document. Here's what the scannable cite looks like:

    { | Roper, & American Council on Education. Committee on a Study of Discriminiations in College Admissions, 1949 | | |zu:871534:9RRCJZ3P}

    When this is first run through RTF/ODF, it appears in the subsequent scanned document as:

    Roper, & American Council on Education. Committee on a Study of Discriminiations in College Admissions, 1949

    But when I try to switch to Chicago style citations, LO crashes when it reaches this citation.

    I replaced this citation with a scannable cite that links to a new citation and now the whole document can be run through ODF/RTF and changed to Chicago citations with no problem. Hooray!

    A few questions:
    1. Might there be some way to get RTF/ODF to fail a little more gracefully when it encounters a citation that has been deleted? Or is this a problem with the Zotero-LO integration? Or I have a missed something?
    2. Is there a way to set the standard citation format for the initial RTF/ODF scan? Could I switch the standard format, for instance, to Chicago?
    3. Is there a way to make it possible to use the identifier at the end of the scannable cites to search through my Zotero library? I'm a historian, and I'm often using placeholders for documents, where I then go back at the end and change the title and author, which makes the information in the scannable cite very hard to connect through human means in Zotero. But if I could somehow search Zotero using the identifier — the part that reads "zu:871534:9RRCJZ3P" — I'd then be able to find the original document, even if I've changed the author and title.

    In any case, thanks again for your help!
  • Thanks so much for putting in time on this. It helps a lot to have specific information on the failure.

    First thought is that we could embed skeleton metadata in the document, but I'll do a more careful inspection first - expected behavior would be for Zotero to issue a specific warning in that case.

    For searches, I think you can drop the final key into the Zotero search box and get the item.
  • Awesome, thanks!

    Using the final key for searches does work — that's a big help.

    Really appreciate your work on this.
  • On the initial format, if you mean the formal in the placeholder, we're not set up to do full citation formatting there, sorry.
  • Ah, cool, just thought I'd see if there were a setting hidden away somewhere.
  • for the "can I use the ID to search" on the other hand, the answer is yes:
    9RRCJZ3P (from your example, i.e. the last bit of the ID) pasted into the quick search bar in "All Fields and Tags" mode will find the item in question.
  • First of all thanks so much for taking the time and effort to develop this plugin, I'm really looking forward to being able to integrate zotero and scrivener.

    Sorry for the complete newbie question. I'm trying to use the plugin in zotero for firefox (Linux mint 17.2). When I open it, the input and output files are clickable, but nothing happens. I've tried reinstalling the plugin, and disabling other zotero plugins to no avail. Any ideas? I've followed the installation instructions to the letter. Thanks for your consideration.
  • I'm having the same problem described by ceiba in the previous post. In my case I'm using Firefox 46.0.1 on OS X 10.8.5 (yes, I know it is going to become unsupported soon - I don't want to upgrade OS versions in the middle of writing a thesis!). A friend gave me some help to track down some of these technical details...

    Symptoms are exactly the same: the RTF Scan window appears, but most of the buttons don't work: the File type selector (RTF, ODF to citations, ODF to markers) doesn't change the text which describes the citation format, the Choose File buttons highlight but don't bring up a file selection window, and the Continue button appears to be available despite no files chosen, but it also does nothing.

    A little poking around with Tools > Web Developer > Browser Console reveals that clicking most of the buttons in the RTF Scan window is logging an error: "ReferenceError: Zotero_RTFScan is not defined".

    I also have the Zotero standalone installed, and the RTF/ODF Scan plugin works fine in that. It is just not working inside Firefox, which is where I prefer to use Zotero.

    Any help on this would be greatly appreciated.
  • Can you check the version of the plugin in Firefox? Should be able to get that from the 3-bars menu (upper-right), then "Add-ons," "Extensions," and then the "More" link for RTF/ODF Scan.
  • Hi,
    the version is 1.0.23
  • For everyone having problems with RTF/ODF Scan recently, installing the latest version from here will fix things: https://juris-m.github.io/downloads/#auxiliary-plugins

    You will need to install manually the first time;after that upgrades will be automatic again. Sorry for the inconvenience:the move makes things much easier for us to maintain.
  • A quick question, only kind of RTF/ODF related:

    Might there be a way to set a special keyboard shortcut to copy scannable cites? What I want to do is copy over the scannable cite to my document, and then separately copy the Item URI so I can turn the scannable cite into a clickable link. The problem is that as far as I can tell Zotero will only allow you to set one keyboard shortcut in Quick Copy for the 'Default Output Format'.

    I realize this is a rather hyper-specific request, one that most people wouldn't use. But is there any chance there might be a super easy way to add this functionality?

Sign In or Register to comment.