New thread on the MS word plugin VB runtime error 91

Having sought a solution to this problem from both the developers and this forum without luck, I thought starting a new thread might prompt anyone who has solved it to come forward with their solutions. In a nutshell, when any of the plugin buttons are pressed, the following error pops up:

Microsoft Visual Basic
Run-time error '91':
Object variable or With block variable not set

Fixes that have been proposed so far are unsatisfactory. To recap:

Fix 1: unplug your internet/disconnect from your network -- This works, believe it or not, though why remains a mystery. It is entirely impractical to have to write a paper/thesis offline or to disconnect every time some bibliographical information needs to be added to a work.

Fix 2: disable your proxy settings -- This solution is nothing of the kind, since I am not connected via a proxy. I am on a wireless network with a standard d-link router, using only windows vista firewall. For the record, turning the firewall off does nothing.

Fix 3: reinstall your visual basic -- I cannot speak for this fix as I don't know how to go about doing it. If anyone could provide any feedback on how to reinstall VB, as well as whether it definitively fixed their problem, please let me know.

Fix 4: reinstall the plugin -- No change.

Any ideas?
  • I just got this error too. It appeared to be generated by some combination of manually editing and using the edit bibliography window. I tried deleting the bibliography and re adding it but that only got the same error so I used "undo" in Word to restore it. Then I switched off the document and shut Zotero and Firefox. On reopening I got a new error (also MS visual basic) that said the object had been deleted. After that I opened the Set Doc Prefs dialogue and just clicked ok and then hit the refresh bibliography button and lo, everything worked again. I can't say whether any of that was random or not. I have no idea what actually corrected it. If anyone can figure out from this sequence what actually happened - well done! Not a proxy problem though as I did not alter them, and no reinstall, and I only shut down Firefox, did not disconnect from the internet in any other way.
    I note there are now 4 forums on this topic. I have replied to this one as it seems the most recent.
  • edited June 19, 2008
    I've closed the following threads and pointed them here:

    If this problem is limited to existing documents and doesn't occur in new documents, see Debugging Broken Documents.

    If the problem occurs in new documents as well, the steps described above by potyondi and in the other threads are currently your best shot.
  • Thanks.
    I guess my point was it stopped and started again without any major troubleshooting. Thus finding the actual software problem might be difficult even though instances of it are sometimes not. Seems others have had the same experience from the forums I have read.
    But thanks again for the prompt response. Good support is another strong reason to use Zotero.
  • I have another case of the same problem. Going back to potyondi's original post, could someone explain "Fix 3;" 1 and 2 don't work when doing Internet research in a large office.
  • I should add that I'm having this problem in Word 2007 on a PC whereas it I'm fine working in Word 2004 on my Mac at home.
  • I've installed Word 2003 on the PC, and the plug-in is not working with it either.
  • edited June 19, 2008
    Hi, I am having similar trouble.

    Fix 1 described by poytondi does not work.

    Have not tried Fix 2; however even if it works it's only a quick fix and does not solve the problem as it is similar in consequence to unplugging your network.
    [update: tried fix 2; Bypassing proxy for local hosts does not work; nor does disabling proxy. Still can't use Zotero with MS Word ]

    As for Fix 3, don't know how to go about it.

    It is clear that it's a bug in the plugin that needs a solution as many are facing problems. Someone please help.
  • It is clear that it's a bug in the plugin that needs a solution as many are facing problems.
    No, sorry, but that's not clear. As explained on one of the other threads, Error 91 is a very generic message which may have nothing to do with Zotero.
    As for Fix 3, don't know how to go about it.
    Visual Basic is part of the Office installation. If you have your original Office installation disks, I believe there's a Repair option as part of the setup program that you could try.
  • Repairing the office installation does not fix the problem (tested with Office Enterprise 2007 on Vista Home Premium 32bit).
  • Running Windows Vista Ultimate 32 bit SP1 and MS Word 2007.

    I was in the situation where #1 would fix my problem but is a pain when I want to look something up online while writing. #2/3 were not relevant/helpful to me.

    What I found is if I open IE, go Tools > Internet Options > Connections Tab > LAN Settings Button and disable "Automatically detect settings" that the plugin starts working in MS Word and I'm still able to be connected to the internet.

  • edited July 19, 2008
    Well I'll be damned. That worked for me, too. I can't comment on whether it's a long-term fix since I've only just tried it, but I'm extremely happy for the moment. Thanks a lot, caleb.

    Any ideas on why this would fix the problem, developers?
  • Any ideas on why this would fix the problem, developers?
    According to this page, "Automatically detect settings" can prevent the "loopback address" from functioning properly. It also suggests that the hostname version of the loopback address, "localhost", works even with that option checked.

    This is certainly incorrect behavior, but I'm not sure whether this is due to a Windows bug or misconfigured ISP servers. If unchecking that setting fixed the problem for you, we'd appreciate if you could try the following steps:

    1) Make sure Firefox is running.

    2) In Internet Explorer, try loading both http://localhost:50001 and with that setting both checked and unchecked.

    In all cases, you should get a blank page but no error message, and the address in the URL bar shouldn't change to another host name or IP address. If enabling the setting breaks but not localhost, we may be able to fix this for everyone by using localhost in the plugin instead of
  • 1) Firefox running...
    2a) in IE, with option unchecked, I get a HTTP 501/505 error on both pages
    2b) in IE, with option checked, I get HTTP 500 error on both pages
  • OK, thanks. So I guess in IE you actually need to disable IE's "friendly error messages" setting under Tools->Internet Options->Advanced Browsing.

    With that disabled, when the connection is working properly you should see a blank page with "HTTP 501 Not Implemented" in the title bar.

    When it's not working, I'd be curious what you see on the page, in the title bar, and in the address bar (if it changes after you hit Enter), and whether there's any difference between localhost and It sounds like, at least in your case, there won't be.
  • OK, so after reviewing some error reports and doing some searches, this appears to be a common issue with Shaw Cable in Canada. Users on other ISPs should try disabling "Automatically detect settings" as well, but Shaw users should definitely turn it off.
  • 1. Firefox running.
    2a. With option unchecked, both pages come up blank, no error messages, no changing of the URL
    2b. With option checked, localhost is same as above but produces the following error:

    Server Error
    The following error occurred:
    [code=CANT_CONNECT_LOOPBACK] Cannot connect due to potential loopback problems

    Please contact the administrator.

    N.B. I use Shaw. Damn Shaw.
  • OK, thanks. That's pretty remarkably bad, but we'll switch to using localhost in the next version of the plugins, at least until we find out that some other ISP breaks localhost but not
  • Anybody using MS-Word (w/Wine) in Linux successfully with Zotero-Firefox?
  • Error 91 fixed (for me).

    I had the 'error 91 Object variable or With block variable not set'
    message when inserting the bibliography in a document. Copying and pasting part of the document into a new file suggested that the problem was with particular references. I could insert any reference, but some weren't generating reference list entries and were throwing an error. Looking at these entires in Zotero I saw that for some reason their titles or page numbers ended with unprintable characters (they come out as squares on my Win XP machine). Removing those characters fixed the problem.

    Still don't know how they got there. I imported most of my refs from Reference Manager.
  • I use Shaw at home and have the same problem - at home only.

    with both "friendly errors" and "automatically detect settings" UNCHECKED

    I get a blank page with localhost URL (no change in address bar)

    but 127... I get the same server error as potyondi above ...[code=CANT_CONNECT_LOOPBACK]... URL in address bar stayed the same and title bar, "500 Server Error"

    with the options checked I get 501 Error for localhost address and 500 Error for 127 address.
  • edited October 4, 2008
    Ok, I'm getting this when I edit my bibliography.

    1. Insert citation. Results in the following reference:
    The Innocence Project. (2008). Understand the causes: Eyewitness misidentification. The Innocence Project.

    2. Edit reference list to add the following text to this item which results in the error 91 error message:
    Retrieved October 5, 2008, from

    3. Can't insert or edit zotero references in Word any more.

    4. Remove reference field AND citation and all is back to normal.

    Report id#: 355001045
  • I have more than 700 entries in the bibliography of my WORD document. When I tried to generate the bibliography for all references, I get runtime error 91. But when I split the document into two and generate bibliography for each (approx. 350+), I could do without any problem. Is there a limit on the number of entries?
  • when i disable my proxy setting, zotero can work.
  • I had the same problem (runtime error 91): so I followed all your suggestions posted here. But non of them solved the problem. Then I started to copy/paste page for page into an new document and after each page I generated the bibliography. Like this I could identify strange signs in the title of some references. They are generated (possibly by Firefox) when a word is written in italic. So you have to delete all this signs in your zotero library and then you should not have any problems.

    Also, I used a German version of Firefox, but my document is in English. Whenever I cited references in the document Firefox translated 'et al.' into 'u. a.' (for: und andere = and others) and 'and' was translated to German 'und'... this is a bit silly, because even in German scientific papers 'et al. is used. So I had to change to the English version of Firefox.
  • mobi:

    1) What kind of "strange signs" are you referring to? Do you know of a website from which downloaded references have these "signs"?

    2) You can use the German build—just set extensions.zotero.export.bibliographyLocale to en-US in about:config. (Instructions at the top of the page.)
  • I have been considering leaving EndNote and NVIVO and switching to Zotero, as I love the ideas here, especially the notion of accessing my library at any computer via the web! However as I tested it out, I came across the "error 91" problem when I tried to inset a reference in word.

    After reading the contents of this post over and over, and trying everything, and I decided that working without the internet on simultaneously was no good. I work in a University, and we are on a proxy server.

    I thought I would have one more fiddle this morning, and unchecked all the LAN check boxes, so I have no automatic configurations and also, I unchecked proxy server.

    I thought for some reason this would mean I would have no internet connection, but for some reason, I still do, and Zotero is now happily putting references into word.

    This isn't a question, it's just a comment. It would be nice if Zotero worked without me having to play in my LAN box, I don't really like having to change the settings in my work computer.

    Otherwise, TOP WORK! Good on you! Keep it up!
  • I am having this problem as well. It seems to come up whenever the manual editor is used, especially in the bibliography. Error 91 pops up whenever you try to refresh the document, or edit a citation footnote. However, it does not prevent you from editing the bibliography, but it will not make changes, since error 91 pops up after you click done.

    The problem seems to go away when the bibliography is deleted.

    However, I need rich text editing, because it is the only way I know of to cite one work in another (i.e. ABC, quoted in DEF).
  • mod
    edited June 8, 2009
    Same problem here.
    My document today reached 500+ references and zotero started complaining about this runtime error: '91'

    I tried all the aforementioned solutions and non worked for me.

    Is there a limit somewhere?
  • I can't claim to have a FIX, but I have found one thing that will cause an "Object variable or With block variable not set" error every single time.

    If the title of a manuscript in the database contains italics or "fancy quotes", they show up as illegal characters in Zotero (at least if they were ported over from RM10, as I did). If you attempt to reference one of these, you get the error. Editing the manuscript title to remove the offending characters, which show up as the traditional little blocks with 1s and 0s in them, fixes the error immediately.

    FYI, for those who believe it has something to do with the number of references in the database, I have 1000+ references. Deleting illegal characters has eliminated all my issues.

    This should be a simple fix in Zotero to check for these and repair, no?
  • mod
    edited June 24, 2009
    drbill thx for replying.

    Well, yes I have cross-checked all references and I can say that there are no "illegal" characters.
    Actually I have more than 1500 references in my database. As I stated above, the problem started when I approached 500+ references in a document not in the database.

    I also tried to split my document in half (~250 + 280 refs) and then both new documents worked perfectly...
This discussion has been closed.