how to use bookmarklet on mobile browser

I am using the Chrome browser on my Android tablet. I am looking at the webpage of a journal article. I can not find a way to add it to zotero. I can not use the bookmarklet because chrome on mobile does not have a bookmark bar. To access bookmarks one needs to access the bookmark page and of course then the bookmarklet can no longer access the URL of the page I want to add to zotero. Does anyone know a workaround?
  • You can give the bookmarklet a convenient name, then while on a page you want to save, start entering that name in the url bar until chrome suggests the bookmarklet.

    This should probably be in the instructions on the bookmarklet download page, but Google kept changing the way bookmarks were loaded in different versions. I'll have to check but it might be consistent enough to highlight this workaround now.
  • +fcheslack, thank you very much, that works!

    I'll also submit a feature request to add a button to the web interface that allows adding an item by its identifier. That feature exists in the desktop version and would remove the need to install a bookmarklet.
  • edited June 7, 2013
    I also got fcheslack method to work with Chrome on my Android tablet (thanks) but I am completely baffled as to how this data from my mobile browser session will makes its way into my Zotero library (how does this work?). Does this work with Zotero for Firefox or only the Zotero standalone? Does this somehow sync to the desktop browser and then into the Zotero library? I am so desperate for a way to capture files from Android browser sessions into my Zotero library (in the cloud or on my desktop). Not having Zotero functionality on these mobile devices really limits their utility. Finally, I am always a bit shocked at how terse (incomplete) the documentation for Zotero features often is. Not having a better explanation both makes it harder to learn to use the functionality and to implement/install it.
  • The bookmarklet saves the data to your account on the Zotero server. It will make its way to your local Zotero library via sync:
    Whether you use Standalone or the Firefox-add on is irrelevant, both sync the same way.
  • edited June 7, 2013
    adamsmith How does my android browser device know where to point to upload to my Zotero library in the cloud?
  • edited June 7, 2013
    the general where (i.e. the Zotero server API) is in the bookmarklet code. If you're not logged into your Zotero account (i.e. on when using the bookmarklet, it will prompt you to log in.

    edit: I'm a little confused about where you're going with these questions - does this work or not?
  • edited June 7, 2013
    Using the method described by fcheslack above with either Chrome or Android Browser on Android 4.1.2 tablet, I get nothing in my desktop Zotero library after syncing with library at Was at pubmed viewing a pubmed record for a journal article. Also, I do not get a prompt to login if I am not logged in (with the current browser - but I did say remember me for 2 weeks at
  • check whether the item shows up in your library at
  • adam, Nope. The several bookmarklet events are not on my library (wherareas several from yesterday synced from desktop zotero library are there). Did not know how to check the library until you suggested it. Thanks for you help now and always. I would love to figure out how to make this work.
  • so what happens when you use the bookmarklet? What do you see?
  • OK. I have achieved partial success and better understand what works and what doesn't. Recall I tried this with two browsers (the stock Android browser and Chrome for Android.

    I. With the stock Android browser, I am getting the bookmarklet to work (uploads to library at and syncs to my computer) only when a) I navigate to Save to Zotero (bookmarklet) bookmark from the icon (banner with a star at right of address box) but not b) when I type "Save ..." into the address box, seeing Save to Zotero from a dropdown list and and select it that way (as suggested by fcheslack Chrome browser above).

    II. Using the Chrome for Android browser, less success is achieved and the behavior is a bit different (but there may be a clue).
    Again, the two approaches to selecting the bookmarklet "bookmark" behave differently from each other (and differently between browsers). a) Navigating to Bookmarks via the icon at right of address (three vertical dots) erases the URL of interest and is kind of a show stopper (there is no bookmark bar visible when the page is interest is displayed). b) Typing "Save ..." into the address box, seeing Save to Zotero from a dropdown list and and select it that way (as suggested by fcheslack Chrome browser above) results in an error message: Looking for Translators. Saving Failed. No items could be saved because the website is not supported by any Zotero translators. If Zotero standalone is not open try opening i...

    Note that I was logged into in another tab of the Chrome browser (also logged in concurrently with the stock Android browser).

    So, to summarize, 1. the trick necessary to activate the bookmarklet "bookmark for Chrome does not work with the Android browser and 2. I am getting an error when I activate it using Chrome.
  • Ia) what exactly happens when you do that?

    as for IIb)
    on which page did this fail? As it says, the bookmarklet only works on supported sites, i.e. sites that would have a URL bar icon in the desktop version.
  • Ia:
    OK, it is not as simple as I described.

    With URL, 4 out of 4 times it says "Looking for translators....", then Saving... and saves the record to the (and after sync my local) libraries

    With URL it opens window "Looking for Translators...." and then fails 4 out of 6 times with a message about 'Known error & translator issues'.

    For IIb:
    OK, it is not as simple as I originally stated.

    I just tried using "method" IIb again on web site (most successful one above). It just now failed 2 time out of 4 attempts with the Known translator issue. The other 2 times it saved the download.

    These are NCBI Pubmed sites and use the NCBI Pubmed translator in Fiefox on a Windows machine.
  • edited June 21, 2013
    While I stand behind all my observations above (Bookmarklet was behaving oddly), I am getting the bookmarklet to work on my Android tablet - most of the time. Now that I KNOW it does work, if it fails I retry it. Maybe it was timing out due to variable conditions on my tablet (don't really know what I am talking about). @adamsmith, thanks for your help!!

    Also, it is working perfectly on various Windows machines in all browsers. It is a terrific feature. I like to hop browsers and devices and never want to be without upload access to my Zotero account - so I am so thrilled this is working.
  • Hello all.
    On chrome for Android the bookmarklet works using fcheslack's method, but only in Standard PubMed website (not the mobile version). Before saving the article you have to switch to standard website version.
  • that's generally the case - the bookmarklet will only rarely work on mobile versions of any site.
  • Hello all,

    Just started using the bookmarklet on my Android tablet and have had good results with the fcheslack method. I've come across a few sites without translators (notably, my university's library catalog:, but most sites work well so long as I go to the desktop versions and not mobile ones.

    However, Amazon's site gives me this error message: "Saving via server... á€| An error occurred while saving this item. Check Known Translator Issues for more information."

    Nothing posted about Amazon on the known translator issue page. I've just used Barnes and Noble as an alternative, but is this an issue that can be fixed?
  • Might not be possible, though there is a small chance a minor fix I just committed will get this to work. FWIW, we're just looking up ISBNs on for amazon, so you might as well use that.
  • Thanks, adamsmith.

    WorldCat slipped my mind. That will satisfy all my needs.

    BTW, I looked closer at my Zotero library and turns out Barnes and Noble is only saving the web page, not the book itself. Not much concern for my own workflow, but thought I would point it out.
  • Same for the UW catalog - good chance that will start working soon - I'm not sure how translator updates work server-side, so not sure how soon my updates will take effect, but can't see it taking longer than 24hs.

    B&N displays generic metadata on its page, which Zotero falls back to lacking a proper translator. Unfortunately, that metadata is lousy - that's what you're seeing.
  • On chrome for Android the bookmarklet works using fcheslack's method, but only in Standard PubMed website (not the mobile version). Before saving the article you have to switch to standard website version.
    I think this is fixed now. The support won't be as great as for desktop version, but it should work on individual article pages.

    The fix won't be that easy for other websites though.
  • Happy to say that it looks like both Amazon and the UW catalog should now work with the bookmarklet
  • Dear all,

    thanks for all the input here! I had the bookmarklet successfully running on my Android smartphone and tablet with the Android Chrome browser as described above.

    However, since a couple of weeks it doesn't work anymore. On every page that I want to save to Zotero the process gets stuck at "Looking for Translators...". On desktop and mobile pages. Also on pages that worked fine before.

    What I tried so far:

    1. Set up the Bookmarklet again. No success.
    2. Removed all API access keys. No success.
    3. Deleted all app data. No success.

    Any suggestions? What else can I try?

    Thanks in advance.
  • edited December 4, 2014
    I am encountering the same problem when using Chrome on my tablet, which is running Android Lollipop.
  • edited December 4, 2014
    ... Having input difficulties, please ignore this ( but not the previous!) comment.
  • Has this been resolved? looks like latest posts still say problems. I'm having problem, too (postered here:
  • Some news from my side:

    I tried the Android Browser again (v. 4.2.2-eng.jenkins.20130923.143352) and the bookmarklet works.

    The problem on Chrome for Android (v. 39.0.2171.59) persists. It seems as if Chrome does not allow to open the Login credentials Window of Zotero. I tried to deactivate the Popup blocker but still no success.

    So my conclusion: Something with the Android Chrome Browser does not seem to work properly.

    Any suggestions?
  • I am also getting stuck at the Looking for translators... message on Chrome for Android (Google nexus 7 running 4.4.4)
  • Hi all, I must be missing something. I'm trying ot use the bookmarklet as fcheslack's method, and when i type 'zotero connector' into the chrome android tablet url bar, there is no 'bookmarklet' suggested when I am on the page of a journal article I want to save.

    I have just 'signed in to chrome' on both computer and tablet browsers, closed boths browsers and opened them again, and waited a while, still not working. what am i missing?

  • In Chrome on Android, is "Zotero connector" listed as one of the bookmarks? (chrome menu -> bookmarks)
Sign In or Register to comment.