[Solved] Zotero crashes Firefox 10 on Linux

  • http://www.libre-software.net/how-to-install-firefox-on-ubuntu-linux-mint

    Follow the directions under A - _not_ those specifically for Ubuntu.
  • Thank you all for sorting this out. I was using the mozillateam ppa on 10.04 and encountered this issue in spades with Zotero 3.0. It looks like it is working better; I couldn't even add one item without a crash before.

    To make the workaround even easier, an easy solution for installing the Mozilla build is to use the Ubuntuzilla PPA, which provides binaries of the mozilla builds. Instructions are here: http://sourceforge.net/apps/mediawiki/ubuntuzilla/index.php?title=Main_Page#Installation

    If you aren't comfortable installing a binary package manually, this is probably a better option.
  • The corresponding bug report for Ubuntu is https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/931637 . Perhaps, if I got it right, the binaries will be added to the official Ubuntu Mozilla ppa (for Ubuntu 10.04 and 10.10) soon -- after regression tests are done.
  • I had the same problem, thank you people ! :)
  • I just updated two Ubuntu 10.4 machines with the »Firefox 11.0 Mozila Firefox for Ubuntu canonical – 1.0« coming as official update. I will continue testing but untill now – no more crashes!

  • As msellhoff above, the latest Ubuntu Firefox has fixed the problem. Ubuntu updated GCC as well as Firefox.

    (The official Mozilla build still works without a problem, but I'm going to dump it soon.)
  • I also confirm that no crashes occur with Firefox 11.0 installed
    through Synaptic. I went back to Firefox 9.0 until 11.0 has become available.
  • Still getting pretty frequent crashes with ubuntu's version of firefox 12 (ubuntu 12.04)... is this the same bug?
  • no, please start a new thread.
  • Hi, same problem here... and same solution too :)
    Maybe you should tag this as a Linux issue (not only Ubuntu) as I use Mandriva, and solved it the same way.

  • edited May 19, 2012
    Yep, Mandriva with 10.0.2-10.0.4 crashes in the same way, so it seems to be a general Linux issue. However, font rendering in the official build is terrible for me (I hate antialiasing and use freetype with 'byte code interpreter' enabled). So waiting for fixing the bug.
  • mwyczes: this has been fixed upstream for several months. If it's still broken for you, you should report it to Mandriva and ask them to recompile Firefox with a build of gcc that isn't broken (4.4.7 or later), or you should do that yourself. See my post above for the relevant Bugzilla page describing the issue.
  • I had a problem with zotero this am. The ID of the report was 837519182
    Thank you
  • edited May 24, 2012
    tenimil: Unclear what problem exactly you're referring to, but given that you're on Windows, yours would be a different issue from the one this thread is about (which has been fixed anyway). If you're still having trouble, you should start a new thread and provide more details.
Sign In or Register to comment.