[Solved] Zotero crashes Firefox 10 on Linux

  • No, I do not seem to be able to reproduce the crashes I experienced.

    I extracted the FF 10 to my personal directory, ran it, and -- although it seems to use my old profile (bookmarks and addons are there as usual, addons except zotero deactivated, of course) I encountered none of the former difficulties: Several items of differant kind saved from different sites -- no crash.

    What's next, shpould I do any more (different) testing?
  • msellhoff: And can you reproduce the crashes if you switch back to the Ubuntu build?
  • Gitty K: That crash report appears to be from the same build you were using before. That's definitely not from the official Mozilla English Linux build, which has a different Build ID.
  • Dan,

    Thank you for your immediate response.

    Yes, at first try, here's the report:

  • edited February 7, 2012
    Gitty K: To be clear, if you're at the command line within the extracted directory, you should run './firefox'. If you're in the GUI, just double-click on 'firefox'.

    msellhoff: OK, that's promising. Best-case scenario this is just a problem in the Ubuntu build. I'd recommend continuing to use the Mozilla build, and let us know if you run into any crashes with that.
  • I'm quite sure that's what I did except that I downloaded the German build. Will try it again with the English version.
  • I'll do that, continue with the Mozilla build, do some research. Maybe try to activate some of the other addons, hm? I will post any news.
  • edited February 7, 2012
    Gitty K: Then you provided the wrong crash report, at least. That crash report is from the same build you were using before (and it's not from the Mozilla German build). You can verify what version you're running when you open it by checking the About window—it will say if it's the Ubuntu build.

    msellhoff: Yes, try enabling your other add-ons. Most add-ons shouldn't really be able to crash Firefox anyway.
  • edited February 7, 2012
    ok, can't figure out what I did wrong the first time, just downloaded the English built and saved about 20 items without crash so far. double checked the about window and it doesn't say anything about Ubuntu. All my add-ons are activated, by the way.
    (edit: "re-"tried it with the German Mozilla build and it works fine as well)
  • edited February 7, 2012
    OK, that's great.

    We'll look into filing a Ubuntu bug, but for now the fix here is to use the official Mozilla Linux Firefox build.

    Thanks for everyone's help in debugging this.

    We'll update with any further news.
  • You're right, Dan, all addons enabled, no problems with the Mozilla build, although I saved a lot of different items from different sources now. No crashes.
  • For the record, your solution worked for me too. Many thanks to everyone.
  • I have the same problem. I was using the FF plugin as a connector, running standalone. I'm running FF 10.0 on Linux Mint 10

    After the latest restart of Firefox, I cannot start the standalone, and I get the message "zotero is running but not responding".

    My crashes have happened while saving items by clicking the icon, the latest one on Google Books http://books.google.com/books?id=8oeXQAAACAAJ&dq=ranabir+samaddar+political+subject&hl=en&sa=X&ei=Fw8yT761KqXlsQKX_cnhBg&ved=0CDcQ6AEwAQ
    and the previous ones on various journal websites, sage and taylor & francis

    The mozilla urls of the the last 3 crashes are




    Incidentally, on opening an amazon link http://www.amazon.com/Emergence-Political-Subject-Ranabir-Samaddar/dp/8132102908/ref=sr_1_1?ie=UTF8&qid=1328681854&sr=8-1 the zotero icon is missing and the page has the loading arrow endlessly circling. Though this is possibly due to the non-responsive zotero process
  • edited February 8, 2012
    joatmon: See above. Everyone in this thread fixed their crashes by using the official Mozilla Linux Firefox build.
  • Thanks for finding a solution.
    Could you please post the exact url of the firefox build that has to be
    installed by ubuntu users?
    Also, I think this problem has to be mentioned in the zotero download page. Note that most new users will just conclude that "zotero does not work" without even looking at this discussion.
  • edited February 8, 2012
    Could you please post the exact url of the firefox build that has to be installed by ubuntu users?
    Just get the official Firefox build for Linux from mozilla.org. It should serve you the right one automatically.
    Also, I think this problem has to be mentioned in the zotero download page.
    It already is.
  • sorry Dan, i just saw your message, my build is from the official firefox stable ppa. I'll try getting it from their website, if that's got something different
  • worked for me as well, from mozilla site
  • Works me too now. Thanks a lot!
  • Let us know if you can still reproduce the crashes in Ubuntu's Firefox 10.0.1 build.
  • it updated this morning and I just tried it, but it still crashes
  • In case anyone is interested, this is caused by a compiler bug in gcc 4.4.x. Only 10.04 and 10.10 are affected, since newer versions of Ubuntu use a newer gcc. Official Firefox releases are compiled with an unaffected version of gcc.
  • The one we are supposed to use is this right?

  • edited February 17, 2012
    Rick: No. This is a bug with the Ubuntu build of Firefox. You need the official Mozilla version of Firefox until this is fixed. Nothing to do with the Zotero version.

    (As a side note, though, addons.mozilla.org will never have a better version of Zotero than zotero.org. Usually the opposite.)
  • You need the official Mozilla version of Firefox until this is fixed.
    or you can upgrade to the most recent version of Ubuntu - i.e. 11.10 - which isn't affected.
  • I have the latest Firefox according to mozilla.org but Zotero is still crashing me. Do I need to reinstall Firefox?
  • ajnaram: What matters is the build you're running, not the version. If you're running a Ubuntu build, you need to install the official Mozilla build or upgrade your system.
  • I really confused.

    I just downloaded from mozilla 10.0.2.
    unzip it, and replace the one inside my home directory .firefox

    And still crash everytime I saved from zotero icon ...
    what should I do ?

    I use ubuntu 10.10

    anybody can help me ?
  • wsetyonugroho: Nothing to do with the .firefox directory—that's data, not program files. You just need to run the downloaded Firefox version until Ubuntu rolls out a fixed version. Or just upgrade to a newer version of Ubuntu, where this doesn't occur.
  • how do I run it ?
Sign In or Register to comment.