[Solved] Zotero crashes Firefox 10 on Linux

[UPDATE: Solved. — D.S.]

I've just updated to Firefox 10.0 and Zotero 3.0 on Ubuntu 10.04 and
I'm experiencing many crashes of firefox when I click the Save As Zotero icon. After the crash I can recover my session, but
the LibreOffice (3.3.2) plugin (3.5.1) does not work: I click to add a reference and
nothing happens. The plugin works again after rebooting, but as the crashes are quite frequent, this has made the plugin unusable.

Any fix to this?
  • I have the same problem. Zotero 3.0.1 worked fine before Firefox updated to 10.0 today. I run Ubuntu 10.10 with LibreOffice 3.4.3
  • As a complement to my previous question,
    is there any way to at least not having to reboot the computer to
    regain plugin functionality? I've tried exiting bot firefox and LibreOffice and this is not enough.

  • edited February 4, 2012
    We're seeing if we can reproduce this, but if you're getting actual Firefox crashes, can you load about:crashes in the Firefox address bar, click through on a relevant crash (check the timestamps), and provide the Mozilla URL?
  • This is one (I made sure by introducing a comment)

    Thanks for your help

  • What site are you saving from when this occurs? Provide an example URL if possible. (And, to be clear, this is from saving via the address bar icon?)
  • Also, can you confirm that this occurs with all other extensions disabled?
  • I tried to reproduce it this morning but first got a different error when trying to save from http://scholar.google.de/scholar?q=flam+emotional+man&hl=de&btnG=Suche&lr=
    It gave me the error message: "article couldn't be saved
    you cannot make changes to the currently selected collection"

    Only after clicking the Zotero-tab in FF and trying again to save from the same link it crashed. To be clear, error message and crash occurred right after I clicked the address bar icon. This is the crash-url: https://crash-stats.mozilla.com/report/index/bp-58be1470-cb1e-414e-b0f0-c33b62120205
  • yes, I was able to reproduce it with all other extensions disabled.
  • Regarding the site, the error occurs at saving a reference to Zotero from any site. For example:

    Regarding plugins, it seems more stable using zotero 3.01 and the LibreOffice plugin only, but I need further testing. I'll report back

    Also: in case the error keeps on, is there any way to regain the communication between LibreOffice and zotero not having to reboot? Is not there any command I could run to restart that communication?

  • The problem is still there even with all other plugins disabled.
    (zotero and zotero libreoffice activated)
    I'd appreciate if you could let me know
    how to go back to firefox 9. under ubuntu.

  • I think you can do that in Synaptic:
    For the time being you could also add items manually or using identifiers (isbn, doi), both options still seem to work in my case.
  • Unfortunately the only alternative would be going back to 3.6
    What I've done is disabling the zotero plugin for LibreOffice, which seems to be the culprit, and inser the references using zotero standalone. At least a workable solution.
    I think the zotero web page should warn against using firefox 10.

  • What I've done is disabling the zotero plugin for LibreOffice, which seems to be the culprit
    OK—when I said to disable all, I meant all except for Zotero itself. The point is to figure out what's causing this.

    Gitty K: Did you disable the LibreOffice plugin too? Can you reproduce with it disabled?
    I think the zotero web page should warn against using firefox 10.
    We have no reason to think this is a widespread issue yet. We have yet to reproduce it ourselves. That's why we need your help to debug it.
  • Obviously I do have zotero 3.0 in firefox activated. What I've tried is disabling the LibreOffice plugin as well, but still have crashes, even not having LibreOffice open.
    I'm giving up, cannot work like this. I'll try to downgrade to firefox 9 or, 3.6, which is the version suported by ubuntu.
  • Obviously I do have zotero 3.0 in firefox activated.
    No, I mean that disabling "all" included disabling the LibreOffice plugin—anything that wasn't the main Zotero extension. If the LibreOffice plugin was causing this, that would be essential information. But now you're saying the LibreOffice plugin is not, in fact, to blame.
    I'll try to downgrade to firefox 9 or, 3.6, which is the version suported by ubuntu.
    Can you not just keep Zotero Standalone open? Zotero for Firefox shifts into connector mode automatically when Standalone is open.

    I understand this is frustrating for you, but a little patience is in order. This thread is a day old. As soon as we can reproduce this, we'll fix it.
  • I do not blame you at all, I'm actually thankful for your work and support, zotero is a wonderful tool and I'm actually paying for extra space in your cloud. I think this is a firefox 10 problem and prefer going back to a previous version, cannot really afford more time wasted on crashes.
    If I keep zotero standalone open, at least I do not lose the functionality within LibreOffice (I can insert references in the text)
    after the firefox crashes, do not have to reboot any more. But crashes do occur.
  • alobo: Wait, so you're saying you still get Firefox crashes saving in connector mode (i.e., saving from Firefox with Standalone open)? If you haven't yet downgraded, can you provide another crash URL for one of those crashes?
  • Dan, this is the url of a crash having zotero 10. only and having zotero standalone open. It does not crash every time, this time I saved several times until crashed:


    The page I was saving from was:
    (using the save to zotero icon in the right end of the url firefox window)
  • I hadn't also disabled the LibreOffice plugin before. But I have just now disabled everything (incl. LibO plugin) except for Zotero itself and it crashed again saving again from a google scholar search. Here's a crash-url:
  • OK, thanks. How easily after a Firefox restart are you able to get it to crash? Does it require performing certain actions first? Does, say, disabling snapshot and file saving in the General pane of the Zotero preferences help? Gitty K, does disabling auto-sync and not syncing manually help?

    Any patterns you can find would be helpful information, since we're still unable to reproduce this ourselves (and so far you two are the only ones reporting it). Most of these crashes are actually different from each other, so there's not even much we can report to Mozilla yet.
  • like I said, after a fresh boot and start of FF I first have to open the Zotero tab in order to get a crash. If haven't first opened it, I get the error message (see above). Other than alobo, crashes have always occurred for me when trying to save.

    I had already disabled automatic snapshots and pdf-saving. Additionally disabling auto-sync didn't seem to change much. Enabling snapshots seemed to improve things a little, I was able to save a couple of items before it crashed. The same with singularly enabling pdf-saving. With both snapshots and pdf-saving enabled, it crashed immediately again.
  • oh, one more thing, other than I wrote above, saving by identifier does crash it too, but not every time.
  • Hi erveryone,

    I have the same problems: Ubuntu 10.4, FF 10, Zotero 3.0.1.

    My latest report:

    I have all add-ons except Zotero disabled, i tried to save an item from

    I did nothing before trying to save from this library catalogue, I do not have to restart my computer in order to regain functionality (of course, FF-restart necessary), the item I saved is in Zotero after I restarted FF.

    Thank you very much for your work on this issue!

  • Dan,

    I've tried all sorts of combinations. I get firefox 10 to crash
    just by saving references with the Save as zotero icon just after
    starting firefox, except when I have the zotero standalone open. In
    that case, it takes a little while, let's say 3 or 4 times (and not doing anything else with firefox).
    I've been working several hours with firefox 9 on another machine with ubuntu 10.04 as well, no problem at all.
    I will try again in the afternoon from the other machine. Yesterday evening I installed firefox 9 in addition to firefox 10 and did not experience any problem with firefox 9 on that machine either, but did not test too much: I'll do it today.
    I'll keep firefox 10 on that computer for testing, but will be using firefox 9 most of the time.
    Thanks a lot for your work. I wish I could be of more help.
  • edit:

    I managed to save an item from GoogleBooks without a FF-crash.

    Right before I had another of my already dozens of crashes, here is the report:

    And just after I started typing this post, FF crashed -- a late reaction of the last saved item?

  • Same issue, Ubuntu 10.10, FF 10, Zotero 3.0.1.

    Crashes using 'Save to Zotero' icon in address bar. No other FF plugins, nor is LibreOffice plugin for Zotero installed. I believe this has happened only after the recent FF upgrade from Ubuntu, FF9 and 10 followed in quick succession.

  • A bit more information.
    On updating Firefox to 10.0 via the normal Ubuntu (10.10) updates and restarting Firefox, the message "current version 2.1.10 is not compatible with Firefox 10.0" appears. So, no choice but to install 3.0.1. Firefox now routinely crashes when trying to save via the icons in the Firefox address bar: there is also no text in the small pop-up box, which precedes the crash. I've just re-installed Zotero 3.0.1, the problem remains. No other plugins active.

    The GLX meesage in the crash report looks suspicious.
    A typical crash report is:

    Add-ons: zotero@chnm.gmu.edu:3.0.1,{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}:2.0.3,ubufox@ubuntu.com:0.9.3,langpack-en-ZA@firefox.mozilla.org:10.0,langpack-en-GB@firefox.mozilla.org:10.0,{972ce4c6-7e08-4474-a285-3208198ce6fd}:10.0
    BuildID: 20120129142413
    CrashTime: 1328545924
    EMCheckCompatibility: true
    FramePoisonBase: 00000000f0dea000
    FramePoisonSize: 4096
    InstallTime: 1328376079
    Notes: GLXtest process failed (exited with status 1): GLX version older than the required 1.3

    ProductName: Firefox
    SecondsSinceLastCrash: 19630
    StartupTime: 1328538773
    Theme: classic/1.0
    Throttleable: 1
    URL: http://www.ncbi.nlm.nih.gov/pubmed/22301388?dopt=Abstract
    Vendor: Mozilla
    Version: 10.0

    This report also contains technical information about the state of the application when it crashed.
  • edited February 6, 2012
    Walter, I stress the first part of your post: The problems startet with the FF update, and I also had like you wrote to manually install the newer zotero version.

    I have the normal text in the notification pop-up box while zotero saves the item. And: Since I deactivated all the other extensions, FF does not crash immediately while saving, but a small time afterwards, maybe 30 sec, I will try to find out.

    Latest report:

    The second point was an error, there is no regularity to it: Sometimes it takes a while, sometimes it crashes immediately while saving.

    Another latest report:
  • edited February 7, 2012
    If you're experiencing this, please download the official Firefox 10 build from Mozilla (if that's not what you're already using), extract it, run the 'firefox' file in that directory, and let us know if you can reproduce the problem using that build.
  • just tried that, but no luck, it crashed immediately
Sign In or Register to comment.