Problem Updating Citations while the Find and Replace Box Is Open

I'm using Zotero 5.0.97-beta.50+5f61ac23a and Word for Windows 16.0.14527.20168.

I was needing to change footnote citations from something like "123 n. 5" to "123n5". So, in searching Word for "n. ^#", I was trying to then edit the corresponding Zotero citations in the default citation dialog.

When I finished editing and pressed enter to save the citation, however, Zotero would crash, act like I'd deleted the contents of the whole citation manually, and ask me if I wanted to visit the debugging broken documents page. On reopening the document, I'd then need to refresh the citation, say I didn't want to save it as empty, and let Zotero recompose the citation.

If I closed the find box before editing the citation, however, that process went as expected. If this issue is reproduceable, it would be helpful if (a) Zotero could insert or modify citations with the find box open or (b) raise a warning box that the find box needed to be closed before inserting a citation.

Thanks so much!
  • Ideally you should edit the citation style that you are using to adjust the output to your needs. If that is impossible then you can edit your citations in-text. You don't need to use the edit dialog. Next time you refresh your document make sure you agree to keep your changes. This is not a recommended workflow however, because if you later insert citations that should cause disambiguation changes or a need for ibid, manually edited citations won't get updated.
  • @adomasven I agree the best method of handling this kind of change would be via the citation style. But it's my understanding that it's not possible to do so at present. Though, if that's incorrect, I'd be more than happy for any guidance about implementing that adjustment.

    You do make a good point about the possibility of manually adjusting the text.—For me, it's really just a personal workflow preference to do the adjustment via the citation dialog so that the note references don't end up static and will update if I swap styles (e.g., to another one that might require the same formatting for citation of notes as the previous).
  • edited October 26, 2021
    Zotero logic-wise there is no difference between citations edited in-text and via the classic citation dialog, so they will get reset if you change citation styles regardless of which way you edit them.
    EDIT: Sorry, this is wrong, and yet another reason why we are planning to remove the ability to edit citations in the citation editor since it will persist the edited text even across citations style changes or even citation item changes.

    Either way, editing the citation in the classic dialog should not crash Zotero, but I cannot reproduce it. Does it happen for other items? Does it matter which part of the citation you edit? Can you export the item and upload it somewhere to test?
  • Thanks, @adomasven, and my apologies for the ambiguity. I'm not using the classic citation dialog. I'm simply using the default dialog (red outlined box) to change " n. " to "n" and vice versa in the locator field so as to avoid custom edits both inside and outside the "classic" editor. And yes, it does happen for multiple items on multiple machines.

    I've even just tried in a brand new document, and I can't even insert the first citation.

    But all this is only with the (old-school) "Find and Replace" dialog box open (or "Advanced Find," the one with the find, replace, and go-to tabs). With the navigation pane open (with the heading, pages, and results tabs), the Search Document feature works fine, and Zotero can insert and modify citations as usual.

    With the empty new document, I get as far as selecting a citation style, but then I get the Zotero error I mentioned above before even getting the default (red outlined box) citation dialog to input a citation.
  • edited October 26, 2021
    Wait. I didn't realize this was with the Find and Replace dialog open. I missed it in the title (probably helps to put it in the main body of the post). We've had a report of this before, that I seem to have never responded to, although in my defense it *was* for Juris-M.

    I just tested with Word Version 2109 Build 16.0.14430.20154 32-bit, and setting the citing style did fail (with an error, no crash), but editing the citation worked. What citation style are you (trying to) use? Can you provide full steps to reproduce in a new document?
  • @adomasven, sure. Here's a short walkthrough first with updating an existing citation with a couple different styles (SBL and Chicago full note), then with creating a new citation in a completely new document.

    If I can provide anything else, please feel free to ask.

    Thank you so much.
  • Ok, to start, the word "crash" is usually reserved for a program closing unexpectedly, either with or without an error message. If you get an error message but the program continues to work, that is considered receiving an error, the program "failing with an error", etc. No big deal, but something to keep in mind when reporting errors to reduce miscommunication. I would have asked for you to submit a Report ID had I known it wasn't a crash.

    I've now tested again and managed to reproduce the issue. However Zotero is receiving an error from Word saying that "the function" is not available with the Find and Replace window open. I didn't check which function, but it's likely we won't be able to make citing work with the Find and Replace window open, although we will be able to show a better error. I've also created a ticket to track this. Thanks for reporting and helping debug.
Sign In or Register to comment.