Word cannot connect to Zotero. Please make sure Zotero is open and running.

13»
  • I have macOS Big Sur version 11.2.1 and Word version 16.46.

    when I navigate to Containers there is no com.microsoft.Word

    I only have the Zotero Beta version on my computer now. I didn't have issues before I downloaded the beta version.
  • I do have this in Containers com.microsoft.Office365ServiceV2
  • Would you mind taking a screenshot of the Containers folder that shows that not existing and emailing it to us at support@zotero.org with a link to this thread?

    Also, can you reinstall the non-beta version and confirm whether that works, before and after clicking the Word plugin reinstall button in the Cite → Word Processors pane of the Zotero preferences? We need to confirm whether this is a new problem in the beta for you as well.
  • I just sent the email, and reinstalled the non-beta version and that works fine.
  • To clarify, did the non-beta version work immediately, before you clicked the "(Re)install Microsoft Word Add-in" button in the prefs, or only after you did so?
  • The word plugin wasn't automatically installed so I only tried after clicking to install it.
  • Could we get a Debug ID for Zotero startup, using the "Restart with Logging Enabled…" option? From either version is fine.
  • I'm not sure if this helps, because with the non-beta version that problem no longer occurs, so I can't reproduce the issue. Here is the Debug ID I got D1127812584.
  • Either version is fine, but we need a Debug ID for Zotero startup using the "Restart with Logging Enabled…" option, not a Debug ID for getting the error.
  • edited 4 days ago
    Wait, is this a different computer from the one you were using previously?

    This shows your Zotero data directory as "/Users/Laura 1/Dropbox/Zotero".

    First of all, you absolutely shouldn't have you Zotero data directory in Dropbox — you'll corrupt your database, which is why Zotero explicitly warns you not to do that. You should move that out immediately.

    But more to the point, this shows your home directory as "/Users/Laura 1", not "/Users/LauraB", and it shows a file being created in "/Users/Laura 1/Library/Containers/com.microsoft.Word/Data/" at startup, which wouldn't be the case if "com.microsoft.Word" didn't exist within Containers. There may be an issue with home directories with spaces in them in the beta — the home directory of @wc3campo had a space as well — but I'm not understanding how this relates to the information you were providing above where "com.microsoft.Word" didn't exist.
  • It is the same computer. I'm confused as to how the users are different.
  • edited 4 days ago
    Hmm, OK. What's the output of echo $HOME in Terminal?

    How about the output of this, while Zotero is running?

    ls -la /Users/Laura\ 1/Library/Containers/com.microsoft.Word/Data/.zoteroIntegrationPipe
  • I also still don't see a com.microsoft.Word in /Users/Laura 1/Library/Containers/
  • OK, I think we're making progress:

    1) It looks like Finder in Big Sur shows the app name within Containers — so even though it's really ~/Library/Containers/com.microsoft.Word, if you go to that folder in Finder it shows "Microsoft Word". So that's one mystery solved.

    2) I suspect you'll find that echo $HOME displays "/Users/Laura 1", and echo $USER for some reason just displays a different name — one that you used previously or in some other context. So that's fine. The code uses $HOME.

    3) I suspect the problem in the beta is due to the spaces in the home directory. We weren't able to reproduce that in some testing today, but we'll try some more.
  • This is the output of echo $HOME /Users/Laura 1

    This for the second
    prw------- 1 LauraB staff 0 Feb 22 16:57 /Users/Laura 1/Library/Containers/com.microsoft.Word/Data/.zoteroIntegrationPipe
  • OK, yeah, that checks out. The file exists, and the username can just be different from the home directory. So it's likely a problem with the space. We'll investigate. Thanks for your help troubleshooting this.
  • Thank you! Do you recommend waiting on trying to use the beta version then?
  • For now, if you need to cite on this computer, you should use the non-beta version. If you're using the beta because of the Safari extension, note that you can keep the beta app named "Zotero Beta" in Applications and still run the regular Zotero app.

    We'll post here when there's an updated beta with a fix for the space issue.
  • Great, thank you!
  • @laura_bizzarri @wc3campo We've pushed an update to the Beta. Could you reinstall/update the Zotero Beta and see whether the integration works well?
  • It seems to work for me now. I'm just wondering why when citing from word, the search bar doesn't appear anymore? Instead it opens a window from zotero where I have to select the publication I want to cite. It's not a huge problem but having just the search bar appear was a convenient feature.
  • This is a setting under Zotero Preferences -> Cite -> Word Processors. Untick the checkbox for the classic dialog.
  • Great, thank you.
Sign In or Register to comment.