Word cannot connect to Zotero. Please make sure Zotero is open and running.

2
  • For example, I am in Word and want to cite something from Zotero. All I receive is a notification in Word saying: Word could not communicate with Zotero. Please ensure that Zotero is open and try again.

    That's all I see and nothing shows in Zotero under Debug ID when enabled
  • The instructions have nothing to do with Word.
  • Is there a number I can call you at? Maybe that would work better.
  • No, this is where support happens. But if you can't follow the instructions we provide, or explain what you don't understand about them, there's just no way we can help you.

    These are the steps. All you have to do is follow them.
    1. In the Help menu, go to Debug Output Logging and select Enable, or use “Restart with Logging Enabled…” to generate debug output from Zotero startup. (If you're not able to access the Help menu, see Reporting Startup Errors instead.)

    2. Immediately perform the relevant action (syncing, saving, importing, etc.) and reproduce the problem you're experiencing.

    3. Before doing anything else, return to Help → Debug Output Logging and click Submit Output, which will disable logging and submit the output to zotero.org. A window should pop up containing a Debug ID (e.g., “D12345678”). Click “Copy to Clipboard” and paste the Debug ID into your forum thread.
  • D404818277
  • I received this.
  • No, that's not what I asked for.
    Can you provide a Debug ID (different from a Report ID) for Zotero startup through getting the communication error, using the "Restart with Logging Enabled…" option?
  • D1991047798
  • Does this work?
  • or

    D2102605992
  • That's correct, and everything looks correct in it.

    Can you confirm that, at this point, with this version of Zotero running, you click the Add/Edit Citation button in Word and get "Word could not communicate with Zotero."? You haven't closed Zotero when you get that?

    And if you close this version and reinstall the standard version from the download page and run that, the same thing works?
  • Can confirm that Zotero is up and running when I see that notification from Word pop up.

    To the second sentence, yes. If I download the standard version, I can cite perfectly fine from Word and Zotero, but cannot use the extension.
  • the safari extension*
  • Any ideas?
  • You'll need to be more patient. Your previous post was 10 minutes earlier. We'll respond when we're able to respond.

    It looks like you're manually clicking the "Reinstall Microsoft Word Add-in" button in the Cite → Word Processors pane of the Zotero preferences after starting Zotero. I didn't say to do that, and while troubleshooting it's critical that you don't do extra things that we didn't ask you to do.

    When you reinstall the standard version of Zotero from the download page and just start it up, without clicking that button, does it work in Word at that point? Or do you get the same communication error, and it only starts working after you click "Reinstall Microsoft Word Add-in" from that version of Zotero?
  • I still get the communication error, and it only works when I Reinstall Microsoft Word Add-on
  • edited 7 days ago
    Could you open the Zotero Beta, an empty Microsoft Word document, run the below command in the Terminal.app and say what the result is?
    PIPE="$HOME/.zoteroIntegrationPipe"; if [ ! -e "$PIPE" ]; then PIPE="/Users/$USER/Library/Containers/com.microsoft.Word/Data/.zoteroIntegrationPipe"; fi; if [ -e "$PIPE" ]; then echo 'MacWord16 addEditCitation /Applications/Microsoft Word.app/' > "$PIPE"; else echo "No Pipe Found"; fi;
    You should either see the terminal say "No Pipe Found" or a Zotero citation operation should start.
  • I received a message that says "No Pipe Found"
  • I'm also having this same issues, I ran through all the steps above and it's not working. I also get the "No Pipe Found" message from the terminal.
  • It might be a bug that doesn't allow Word to connect to Zotero for citations. Hopefully there's a solution :)
  • If you don't mind disclosing your username on this computer, what is the result of
    ls -la "/Users/$USER/Library/Containers/com.microsoft.Word/Data/.zoteroIntegrationPipe"
    in the terminal?
  • I got a "No such file or directory" response.
  • edited 4 days ago
    Can you run this before and after starting the Zotero Beta and paste the output from each here?
    ls -la "/Users/$USER/Library/Containers/com.microsoft.Word/Data/
  • No such file or directory
    Is all I get.
  • Can you copy and paste the full line you're getting in Terminal? You can email it to support@zotero.org with a link to this thread if you don't want to post it publicly.
  • ls -la /Users/LauraB/Library/Containers/com.microsoft.Word/Data/: No such file or directory
  • edited 4 days ago
    If you go to System Preferences → Security & Privacy → Privacy → Full Disk Access, do you see Terminal.app, and is it unchecked? If so, click the lock in the bottom left to unlock the pane and then check that box and try these commands again.
  • I did that and still get this
    ls -la /Users/LauraB/Library/Containers/com.microsoft.Word/Data/: No such file or directory
  • What versions of macOS and Word do you have?

    If you go to Finder, Option-click the Go menu, and select Library, can you navigate to Containers/com.microsoft.Word/Data?
  • @laura_bizzarri: And to be clear, are you experiencing the same issue where this only happens with the Zotero Beta?
Sign In or Register to comment.