Word cannot connect to Zotero. Please make sure Zotero is open and running.

Hello. I am currently having an issue where Word is unable to connect with Zotero in citations or bibliographies and am not sure why. It was working prior to today.
  • I am using Mac OS.
  • It still is not working with the steps on the Mac link, unfortunately. I noticed that with the Zotero installer for Mac, it works, but I do not get the safari extension. With the beta installed, I get the safari extension, but citations/bibliographies do not work with Word. I would like both. It was working before, but doesn't seem to now.
  • edited February 19, 2021
    Can you say exactly what you've tried, in your own words, and what happened at each step?

    We'll also want a Report ID.
  • Thanks for responding. So what I did was to delete Zotero and re-install again. This is now allowing me to connect Zotero and Word, but I am unable to use the Safari extension for saving PDF's.
  • I do not see the extension listed under preferences, neither.
  • How would I get this to work? Thanks so much!
  • edited February 19, 2021
    You'll need to say more for us to be able to help you. I'm not clear on what exactly the problem is that you're currently experiencing. Just saying you're "unable to use" something isn't sufficient.

    The Safari extension is only available in the Zotero beta, due to a bug in macOS. If you're not comfortable using beta software, and potentially managing multiple versions, you should use the Zotero Connector for Chrome or Firefox for now.
  • Okay. I see two versions of Zotero. The first version is Zotero and the second is the Zotero Connector. I first downloaded Zotero and I was able to use the word citation/bibliogrpahy connection just fine. I had noticed that the Zotero Connector was not there anymore, so I downloaded the connector and received a notification from my Application folder stating Zotero is already downloaded and if I would like to duplicate, stop, or replace it. I replaced Zotero with the Zotero Connector and was able to see the extension on my Safari, but lost the ability to connect Word with Zotero. I then downloaded both, but had a Zotero 1 and 2.
  • I just deleted Zotero + Zotero Connector and redownloaded just Zotero 5.0 for Mac. I am able to connect Word with Zotero, but now I cannot see the extension for Safari to save PDF's.
  • Again, the Safari extension is only available in the Zotero beta — you need to be clear about what you're downloading. There's the release version of Zotero from the download page and the beta version from the dev builds page. If you install the version from the download page, you won't have the Safari extension.

    As I say, if you're not comfortable running beta software, we recommend using the Zotero Connector for Chrome or Firefox instead. If you're intent on running the beta version, we'll need the info I requested above to debug the Word problem.
  • Can you say exactly what you've tried, in your own words, and what happened at each step?
  • I just deleted Zotero 5.0 and downloaded the Zotero Connector. I can now use the Safari extension, but do not have Word connected with Zotero. When I try to use a citation, I am seeing this message: "Word could not communicate with Zotero. Please ensure that Zotero is open and try again."
  • Yes, and I linked to troubleshooting instructions for that. I'm asking you to explain what exactly you did from there, in your own words, and what happened at each step.
  • I understand that. Those instructions did not work for this circumstance. I just told you everything I did multiple times. I downloaded both Zotero 5.0 and the connector. With 5.0, Word and Zotero works, but I cannot use the safari extension because it is not there. With just the connector installed, I cannot use Word with Zotero for citations, only the safari extension. With both installed, I will have 2 versions of Zotero: Zotero 1 and 2. Is there a way to have only 1 Zotero installed and have the ability to use both the safari extension and Zotero with Word?
  • Or is the only way to use both is to have two Zotero's downloaded on my computer?
  • We're not going to be able to help you here.

    I've linked to specific troubleshooting instructions multiple times and asked you to explain what you did from there. For some reason you're unwilling to do that. Just saying the instructions don't work gives us absolutely no way to help you further.

    And you're still misunderstanding the basics of this. You didn't "download the Zotero Connector". The Zotero Connector for Safari is currently distributed as part of the beta version of the Zotero app. It's not something you download separately, as is explained on the support page.

    If you're having trouble understanding all of this, that's fine — it's complicated, and it's an unfortunate macOS bug that's preventing us from releasing the Safari extension with the standard version of Zotero. But then you should just use the standard version of Zotero with the Zotero Connector for Chrome or Firefox. Or you can use one of the other options for saving listed on the support page. But I would strongly recommend just using Chrome or Firefox.
  • "First, make sure the Zotero app is open and running on your computer. Note that this is the Zotero program, not the Zotero website or Zotero Connector in your browser.

    If Zotero is open and you're still receiving this error, the most likely causes are previously having started Zotero from a disk image instead of dragging it to Applications and starting from there or having two copies of the Zotero app in different locations on your computer (e.g., a “Zotero” and “Zotero 2” in Applications). Close Zotero, open the Zotero profile directory, and delete extensions.json. Then restart Zotero."

    I followed these steps, but there I do not have "extensions.json", because I did not download from a disk image. I dragged the application to the applications folder and opened it from my applications folder.
  • "If you continue to receive the error after deleting extensions.json, go to Tools → Add-ons in Zotero and make sure the Word and LibreOffice plugins are enabled. If they show as disabled, enable them. If they show as incompatible, you may have previously installed a very old version of the plugin, and you should uninstall it and restart Zotero. Current plugins are bundled with Zotero and don't need to be installed separately."

    I went to tools -> add-ons in Zotero and made sure Word is installed. I don't have LibreOffice plugin installed because to my knowledge, LibreOffice is another Word Processor, which I do not use. I can install it if necessary. Please let me know if that I required.
  • "If you get no response when you attempt to use the Word plugin, try the following steps:

    Restart Word and try again.
    Close Word and go to Tools → Add-ons → Extensions in Zotero. Make sure Zotero Word for Mac Integration is listed and enabled. If it is disabled, enable it. If it is missing entirely, see Zotero toolbar doesn't appear. After re-enabling/re-installing Zotero Word for Mac Integration, open the Cite → Word Processors pane of Zotero preferences and click “Reinstall Microsoft Word Add-in” on the “Word Processors” tab. Restart Word and try again."

    I did all this. Zotero Word for Mac integration is installed and enabled. I even disabled it, restarted Zotero, re-enabled it, then restarted Zotero and Word and still does not work.
  • "Visual Basic for Applications error"

    This is the next step for Office 2011. I have the most up-to-date version of Office due to the subscription service they provide.

    What do you think the next steps should be?
  • Also, I apologize if any of this seems to be rude. I am not aiming for that. I would just like further clarification.
  • I enjoy using Zotero and has been very helpful.
  • I know what's on the linked pages — you don't need to copy and paste it here. I'm asking you to say what you did, in your own words, and what happened at each step, to make sure you understood it and performed the steps correctly, and so we can understand what you're seeing on your screen, which we can't see.

    You're also pasting in other sections — "No response from plugin" and "Visual Basic for Applications error" — that have nothing to do with this problem. You shouldn't be doing anything from those.

    But let's try this another way.

    If you go to the Cite pane of the Zotero preferences, do you see the "Reinstall Microsoft Word Add-in" button?

    What is your full, exact version of Word?

    Can you provide a Debug ID (different from a Report ID) for Zotero startup through getting the communication error, using the "Restart with Logging Enabled…" option?
  • Yes, I see that button.

    Full Version of Word is: 16.46 (21021202)

    For Debug ID, I am not able to produce one from where the notification is showing in Word, unfortunately.
  • I will check the next option. One second
  • For Debug ID, I am not able to produce one from where the notification is showing in Word, unfortunately.
    I don't know what you mean by that. You provide the Debug ID from Zotero, according to the instructions there.
  • Yes, I am able to see that in Zotero, but when I do the action in Word, no output shows in Zotero.
  • Again:
    Can you provide a Debug ID (different from a Report ID) for Zotero startup through getting the communication error, using the "Restart with Logging Enabled…" option?
    You can absolutely do that.
Sign In or Register to comment.