Linux mint Zotero don't open anymore

edited 12 days ago
Hi
Similar to other linux users, I lost zotero icons last december but could still open zotero from the toolbare by clicking on the empty/missing icone space. Yesterday, zotero would not open anymore (I think (but not certain) since the mint system and/or dirvers update).
After some trial and error, I managed to bring back a nice icone (saved in the picture folder though) but impossible to open zotero despite a link to the zotero file!
If I go to the software manager, it offers me to install "Zotero" as if I don't have it (It does find my Standalone verion that I tried to used with office in a kennel though).
- I have tried ./zotero in the terminal, nothing happens.
- I have downloaded the last version 5.0.95 of zotero.tar file from zotero.org and extracted it:
~$ cd /home/mchastel/Downloads/Zotero_linux-x86_64
$ ./zotero
Nothing happen...

I am a very beginner in all this and would really appreciate a step by step help/explanation!
Thank a lot
best
Matthieu
  • ~$ cd /home/mchastel/Downloads/Zotero_linux-x86_64
    $ ./zotero
    Nothing happen...
    Can you say more? What exactly happens?
  • edited 11 days ago
    Hmm... hard to say more, the console returned "nothing" ($""). I couldn't see any changes anywhere, Zotero would not open.
    In the end, I found back Zotero with a lot of trial and error and many beginner mistakes I guess but I couldn't/didn't wanted to go back to all the learning tutorials etc yesterday...
    I try to summaries bellow what I did but I am afraid it will sound like gibberish, sorry:
    - I "installed" zotero from linux mint cinnamon software manager on top of my manually, long installed zotero. After charging for few seconds it said that Zotero was already installed yet the launch button wouldn't work and the other app button (in the menu and drop bar same).
    - I therefore clicked uninstalled in the software manager. the Sware manager said it was uninstalled but in reality, no success here. Zotero_linux-x86_64 folder was still in the opt directory as well as the short cuts... I used to sudo rm command to remove the folder with success. I think I rebooted and everything (including shortcuts from the menus) were gone (except my library /zoero/storage alleluia)!
    - Tried to re-install it via the tar I had downladed already (I copied the extracted "Zotero_linux-x86_64" in the "opt" folder by opening the folder "as root" (I have already forgotten all the basic commends to work from the console and didn't find them on the installation guiding page unfortunately). From there, I doubled click on the "set_launcher_icon", the icon appeared in the folder but no where else. I doubled clicked it, nothing opened. I doubled clicked zotero, no succeess neither. I closed the as root page. The zotero icon diseapeared again form the zotero document where it had just appear. I ran the "ln -s /opt/zotero/zotero.desktop ~/.local/share/applications/zotero.desktop" in the console as mentioned in the zotero installing page. I received an error I think (a folder non existing or something...). There I kind of quit... I deleted the Zotero_linux-x86_64. I took some time off..
    - I went back to the software manager, installed it from there (but version 5.0 94, not 95...). It worked: I had the app icon back in the menu, could launch it, pin it to my tool bar (although when Zotero is open, I have 1 icon for the open interface and 1 icone to open Zotero as if it was closed). All my library was there without the need to get it from the back up Hooray!!!

    Sorry for this boring and too long post and sorry for not having been able to identify the origin of the initial problem...
    Best
  • I went back to the software manager, installed it from there (but version 5.0 94, not 95...)
    You're likely using the snap or flathub package. Both of them currently seem to offer version 5.0.94 only.

    I would recommend installing the deb package instead:
    https://github.com/retorquere/zotero-deb

    (Linux Mint is based on Debian.)

    See also here:
    https://www.zotero.org/support/kb/linux_packaging
Sign In or Register to comment.