No author or journal information from Project Muse

This discussion was created from comments split from: Add/Remove Fields.
  • When citing items in Project Muse, the citation created when I capture the article or book often does not include the author, the journal information, etc. Is there any way to add these to the Zotero fields.
  • (generally better to start a new thread for new issues).
    We'd need sample URLs for problems on import.
  • edited November 28, 2020
    Many, perhaps most, book webpages with Project Muse no longer have headers with relevant metadata. Publisher, author, and chapter titles and pagination are "randomly" distributed throughout the webpage -- there isn't a standard book templet. Book chapter headers don't include chapter name. [At least, not in a format I recognize.] edit: Some time ago the book and book section metadata was exemplary. I've already written to complain and ask for them to revert to the old headers. You should too.

    For example:

    https://muse.jhu.edu/book/79294

    I still am able to get journal article metadata via Zotero but author names are *sometimes* single field or reversed. Sometimes some authors' names are omitted from page headers -- even the final author's name. DOI metadata is always complete. I've written to comment about that also.

  • I can replicate this for books, thanks, we'll take a look. Would still like to see example URLs for journal articles.
  • edited November 30, 2020
    @mattizelin may be able to find journal articles that reliably fail. I track about 35 Muse journals and generally get good article metadata. About one in ten articles have a problem author names in the page header. Just enough to cause me to routinely get Muse metadata and abstracts via Zotero and to also capture authors from the DOI via the Wand to be sure the authors are complete. DOI metadata always matches the PDF versions.

    I'll soon come across faulty journal examples and I'll list them here.
  • Project Muse translator is not working for journal articles for me, either.
    Example: https://muse.jhu.edu/article/433346

    gets saved as webpage with webpage title and url as only information
    looks like the page is only indicating metadata in the class of and
    tags
  • edited December 20, 2020
    @teo.w Curious. That item imports as a journal article for me with the title, author, vol/iss/pagination, DOI, and ISSN.

    I'm using the 5.0.76 Firefox connector and Zoero 5.0.94-beta.5+2b5a22c13 on Mac 10.15.7 (19H2)
  • Yeah, this was fixed more generally a couple of days ago, including for books (e.g. the link in DWL's post above now works).
    If it doesn't work for you on https://muse.jhu.edu/article/433346 please run through https://www.zotero.org/support/troubleshooting_translator_issues
  • wow very curious! thanks @DWL-SDCA and @adamsmith

    i went through the steps listed on the troubleshooting page and everything seems like it *should* work.
    i am on chrome (86.0.4240.198), mac os 10.15.6
    with current versions of zotero (5.0.93) and translator (5.0.76)

    here is what happens on https://muse.jhu.edu/article/433346 :
    - page loads normally
    - zotero translator icon shows journal article icon
    - hovering over translator says "save to zotero (project muse)"
    - (this is where it gets weird) clicking translator saves as web page, not as journal article
    - zotero saves as web page with only page title and url, plus downloads/attaches pdf

    i went ahead and did a debug log: D805600163
  • So you do have access to the article full text when you click Save to Zotero, right? (it should work either way, just making sure I understand what you should be looking at)

    What does the pop-up say when you're click the Save to Zotero icon?

    Did you try restarting your browser and trying the same thing again?
  • Parsing code for Project MUSE (c54d1932-73ce-dfd4-a943-109380e06574, 2020-03-09 20:00:00)
    @teo.w: It looks like you don't have the latest Project MUSE translator version for some reason. Go to the Advanced → Files and Folders pane of the Zotero preferences and click Reset Translators. Then go to the Advanced pane of the Zotero Connector preferences and click Reset Translators there as well.
Sign In or Register to comment.