Snapshot not saving (Zotero connector for Chrome)

Often, when I try to save a webpage using the Zotero connector, the metadata will save but the snapshot will not save. There is no error message, only a red "X" appears next to "Snapshot" in the overlay window (just below the web page name. Why does this happen and how can I get it to save?

Here is one example page where I am having the issue. (This happens often, on many different websites, but not on every website.)

My Zotero is up to date (5.0.88) on Mac OS Mojave (10.14.6). Zotero Connector (5.0.68) and Google Chrome (83.0.4103.61) are recently updated as well.

  • Snapshots are saved from Zotero, not the Zotero Connector. If those aren't working, there may be a problem with your network connection from Zotero.

    Is this a work computer? Are you connecting via a proxy server?

    Can you provide a Debug ID from Zotero for a save attempt for which the snapshot fails?
  • Thanks for getting back to me so quickly dstillman!

    I tried again with the same web page and it worked .. even though it didn't work after multiple reloads a few hours ago. Very strange. I will keep the debug logging active and send a Debug ID next time it happens!
  • hi dstillman, i found that turning off and on the debug logging usually fixes the problem. so i never got around to sending a report since there were always hundreds or thousands of lines in them!

    today i finally had an issue where turning off and on debug logging didn’t fix the problem - zotero connector simply won’t save anything, not even the metadata: D810228545
  • The debug logging almost certainly wasn't related — it was likely just the act of trying to save again.

    The report you sent doesn't show a save attempt, though. You just clicked the save button again, but that just reopens the popup so you can change the target collection — it won't attempt a fresh save unless you actually load the page. We'd need to see an actual save attempt to say more.
  • here's another one D1835973728
    trying to use Chrome zotero connector to save this page to zotero:
Sign In or Register to comment.