Always let Extra in Info section show "ABK"

In our research group we add references to a shared library. We add our initials to the "Extra" field in the Info section. That means that every time I add a reference to our group library in Zotero I need to write ABK in the Extra field. Is it a simple way to make this become added automatically, maybe by modifying a template?
  • No, sorry, Zotero doesn't have a template option.
  • If you need to edit multiple items, the Zutilo add-on might be useful, see here. For example, copy {"itemType": "book", "extra": "ABK"} to the clipboard and use Zutilo's "Paste into empty item fields". Note that the "itemType" value is irrelevant here and will not be modified. (Zutilo requires a dummy itemType entry to recognize the clipboard content as something it can paste.)

    You could also use "Paste non-empty item fields" if you are OK with overwriting existing entries in Extra. Note, however, that Zutilo cannot add new lines to existing entries in Extra. That should be possible with Zotero's JavaScript API or the Web API, but much more involved.

    BTW, working with collections and tags might be an easier way for making the item owner apparent in both the Zotero desktop client and the web library. If you select a collection or tag in the web library, you get an URL that reflects this choice, which might be useful. There's also an "Added By" column in the web library.
  • edited 13 days ago
    I am in a similar situation as the original poster, but need to add something in bulk to the "accessed" field. I tried "accessed" and "urldate" as the values in the line above, in replacement of "extra", but neither worked. Just to test if this was specific to "extra", I also tried it with other fields, such as "date" and "title", and it worked fine in those cases. So it appears that the name Zotero uses internally for the "accessed" field is neither the name it displays in the visual interface ("accessed") nor the name under which the field is exported to bibtex ("urldate").

    Does anyone happen to know what name I should use to paste a string to the "accessed" field using the method @qqbb describes above?
  • The name of the field is “accessed”, so if that’s not working there is something else wrong with your script. What exactly are you entering?

    Note that you can also type “today” in the field to auto fill today’s date, which might be just as fast for you.
  • edited 13 days ago
    Here are the steps to reproduce my problem:

    1. Assign "Command-D" to to the Zutilo command "Paste non-empty item fields" (under Tools > Zutilo Preferences > Shortcuts).
    2. Copy the following to the clipboard: {"itemType": "book", "accessed": " "}
    3. With focus on an item with a non-empty "accessed" field, press "Command-D".

    I expect this to blank the "accessed" field for the entry in question, but in fact nothing happens.

    To test that this is specific to the "accessed" field, I repeat the above steps with the following variant:

    2. Copy the following to the clipboard: {"itemType": "book", "extra": " "}
    3. With focus on an item with a non-empty "extra" field, press "Command-D".

    As expected, the content of the "extra" field is removed.
  • (In case there is another way to accomplish what I'm trying to do: my goal is to remove the content of the "accessed" field from multiple entries—too many to do it manually.)
  • Do I understand that you just want .bib export without urldate as an end result? That'd be much easier to do with a post-processing hook with BetterBibTex (https://retorque.re/zotero-better-bibtex/ )
    I haven't looked into this, but I'd guess that Zotero expects a valid date value (potentially even in database format) for accessed and otherwise rejects the input, which is why this isn't working for you with accessed.
  • edited 13 days ago
    Thanks for the anwer.

    What I want is to remove the "accessed" field from the database itself, not the export. The values for many of these fields are incorrect, so I would like to remove them before I start adding new entries.

    I again tried the process above using {"itemType": "book", "accessed": "2021-01-01"}, to check whether the problem was that Zotero required a date in the "accessed" field, but unfortunately it also didn't work.
  • What I want is to remove the "accessed" field
    @EA-Wiki: To clear the "Accessed" field, copy {"itemType": "book", "accessDate": ""} to the clipboard, then use Zutilo's "Paste all item fields".

    In general, you will get all the relevant field names if you select a Zotero item, use Zutilo's "Copy item fields", then paste to a text editor. See also this discussion for more details: https://forums.zotero.org/discussion/85593/editing-multiple-items-at-once.

    ("Accessed" is the localized field name of the "accessDate" field, see https://www.zotero.org/support/dev/web_api/v3/types_and_fields.)
  • @qqbb: Excellent, that did the trick. Thank you for your help.
Sign In or Register to comment.