Cannot add citations to Google Doc

Error ID: 800410007

I have added citations to a Google Docs text document before, but cannot any longer add them to the same document. There simply appears a message "Zotero fields cannot be inserted here."

The problem occurs with all Google Docs documents, old and new. Uninstalling and reinstalling Zotero did not help.

Thank you for assistance.
  • Where exactly are you trying to insert a citation (e.g., in a table, footnote, textbox)?
  • @KristjanOad: Are you saying this happens in a completely new, empty Google Doc?
  • I'm trying to insert the citation in the main text.

    Yes, it happens in a new, empty Google Doc. Alternatively, on some tries, it goes a step further: I get to choose the format of the citation and the progress bar appears... only to stay there forever.

    Thank you for your advice.
  • What browser and which version are you using? Could you submit a Report ID from the Zotero Connector?
  • I have this issue as well. I submitted a bug report (849450207) as suggested above.

    It looks like an extension conflict of some kind; when I turned off all other extensions, Zotero worked. I will trouble-shoot which one later. For the record, here's a list of the ones I have installed:

    1Password X
    Google Calendar
    Google Scholar Button
    Web Developer
    Google Docs Offline
    Full Page Screen Capture

    Here's the error text:

    [JavaScript Error: "maybePromise is undefined" {file: "chrome://zotero/content/xpcom/server.js" line: 486}]

    [JavaScript Error: "Zotero fields cannot be inserted here."]

    [JavaScript Error: "Zotero fields cannot be inserted here."]

    [JavaScript Error: "Zotero fields cannot be inserted here."]

    [JavaScript Error: "Zotero fields cannot be inserted here."]

    version => 5.0.69, platform => MacIntel, oscpu => Intel Mac OS X 10.14, locale => en-US, appName => Zotero, appVersion => 5.0.69, extensions => Zotero LibreOffice Integration (5.0.15.SA.5.0.69, extension), Zotero Word for Mac Integration (5.0.23.SA.5.0.69, extension), Shockwave Flash (, plugin)
  • I have the same issue. I format the document for APA 6ht, then click insert citation. A Task bar opens and then I get the error "Zotero fields cannot be inserted here."
  • The issue here is related to placing the cursor in non-Zotero-citation links in the document. If you can figure out which link in your document under what circumstances causes this, we will fix it.
  • thanks for getting back to me. I selected 10 different random spots in the the text of the document to try adding a citation, and got the error every time. First it says, "zotero is updating your document. Please wait." then says "Zotero fields cannot be inserted here."
  • Do you have hyperlinks in this document? Have you tried adding one to see whether it fixes it? Could you make a copy of a document and remove everything but the last page, then refresh the browser tab and see if it still produces the error? If so, could you share it with
Sign In or Register to comment.