New citations are underlined with a dotted line

Help, help, help! I just printed my document and saw that every new citation is underlined with a dotted line. From the forum entries I figured out that this is a new "feature" of zotero to remind us that those citations haven't been updated. However, I urgently need a way to keep zotero from underlining my new citations as I won't be updating them at all in the end, since I made some manual changes to the citations. Can somebody please help me to disable this feature???
  • https://www.zotero.org/blog/zotero-5-0-36/#faster-citing-in-large-documents

    Note that you can use this feature and still make manual edits — you just have to press Refresh first to update any unupdated citations, which removes the underline.

    But what kind of manual edits are you making? Whenever possible, you should avoid manual edits and either fix the data in Zotero or edit the citation using the citation interface.
  • Thanks for the quick reply.
    I'm writing a law dissertation and I have some issues citing a type of book (Gesetzeskommentar) as there always appears a comma in the end of the citation. I tried fixing the citation style but I wasn't able to find the problem.. so I will have to keep manual changes. Since I've already done so in a lot of footnotes it would be really annoying if I had to delete all those changes by pressing refresh just to make them again afterwards... Is there no other way to remove the underline?
  • edited March 5, 2019
    If you provide more details (citation style, metadata details) someone might be able to look at the style and tell you if your issue can be fixed, but it also sounds like you're misunderstanding a couple things:

    1) Just removing the underline doesn't make sense, and you should read the section I linked to so that you understand the purpose of it. The underline is telling you that the citation hasn't actually been updated to its final form, because doing that requires checking all other citations in the document. You don't want to edit it at that point because, depending on the citation style, it may not actually be formatted correctly, and that would somewhat defeat the purpose of using Zotero for citing. You can turn automatic citation updates back on (as it is by default), but that's similar to pressing Refresh after each insert.

    2) More importantly, refreshing doesn't wipe out your edits. If you manually edit a citation, the next time you refresh or Zotero needs to update the citation you'll get a prompt asking whether you want to keep your edit or allow Zotero to update it properly. If you choose to keep the edit, you won't be prompted about that citation again. However, Zotero then also won't be able to correct the citation if you change data in Zotero or if it needs to change based on other citations in your document due to a style requirement (ibid, author name disambiguation, etc.). That's why it's always better to find a proper fix rather than making manual edits.
  • I read the section and I do understand that this is not the way I am supposed to use Zotero. However, I think it should at least be possible to choose to use Zotero that way. So if your 2) comment works, that would be perfect. However, earlier when I pressed refreh and chose to keep the manual changes the underline somehow didn't disappear... But i will try again.

    With regard to the citation style: I am using Lavelli_Zotero but I didn't create this style myself so I can't figure out where the comma comes from that appears whenever I cite legal comments (Gesetzeskommentare)
  • edited March 5, 2019
    If you edit the underlined citations before refreshing and then choose not to update them, the underlines won't disappear (and, again, the citations may not even be formatted correctly yet).
  • So if I edited the underlined citations there is no way of removing the underline without losing the edits? And this is not supposed to be changed in future versions?
  • It might be possible to change that styling in Word itself, but no, this won't be changed — again, the underline is there to tell you that the citation isn't in its final form.

    And again, you can turn automatic citation updates back on so that new citations get fully formatted immediately. That setting is on by default and would only be off if you either turned it off in the document preferences or agreed to let Zotero do it when prompted after an update took more than 15 seconds.
  • The problem disappear if I hit refresh. However, the citation keeps the dashed underline if i modified the citation.

    For example, if the citation is (Black, 1986) and I press 'refresh', the dashed underline disappear. But if I want to modify the citation and use it somewhere as Black (1986), the dashed underline does not disappear even after refreshing.

    What should I do?
  • edited February 27, 2020
    @turki_rrm: We're planning to fix the issue of the underline not being removed if you choose to keep the edit, but note that you shouldn't be modifying citations in this case to begin with. Use Suppress Author for that and type the author name manually outside of the citation.
  • I'm still having this issue - the dotted underlines don't go away when I refresh if I choose to keep modifications. Is there any way around this?
  • I have the very same problem with a citation in my thesis. After adding a new source into my library, new citations started to be underlined. Although it went away when I refresh it, it was annoying. The problem seems to have disappeared when I copy the entire chapter into a fresh word document. I tested a couple of citations by adding new ones or amending the existing ones. No problem comes up yet. Hope it would be useful for those suffering from the same issue.
  • edited December 27, 2020
    @yusuf_ozkan: What you're describing is Zotero working correctly with "Automatically update citations" disabled. See Citations Underlined.

    The above thread is about an issue where manually modifying a citation with the dashed underline prevents the underline from being removed on Refresh as it normally is.
  • Would be good to get a fix for this issue. I occasionally need to include citations with text inside the brackets. For example:
    (e.g. Smith et al., 2015)
    (see works such as Black, 2016; Jones, 2010)
    It would be good to be able to print / pdf them without the underlining!
  • modifying citations has nothing to do with the underlining. That said, you should use the existing prefix/suffix options for that so those citations continue to update:
    https://www.zotero.org/support/word_processor_plugin_usage#customizing_cites
  • What?? "modifying citations has nothing to do with the underlining"
    That's at odds with the rest of the thread above, and with what I'm seeing in front of me right now.
    If I add new citations, they are all underlined before I click Refresh. When I click Refresh, the underlining disappears from unmodified citations. But modified citations remain underlined.
    But I take your point about using the prefix / suffix options.
  • Sorry, yes, I didn't re-read the beginning of the thread and had forgotten about the effect of modifying before refresh.
Sign In or Register to comment.