Importing EndNote files into Zotero

  • I already tried those things. Created new searches, edit existing ones. No luck.
  • Could you take a screenshot of the "Edit Saved Search" dialog, upload it to a free image hosting site like and link to it here? I want to make sure I'm looking at the exact same thing as you.
  • Try a different search:
    Item Type -- is -- Note
  • Oh well duh! That worked much better :). Sloppy reading on my part, just picked the first Note I found. Ah well.
  • I also used the Saved search to rename all the imported PDFs. It took a while and Firefox went non-responsive, but in the end, good result.
  • edited February 26, 2013

    I am having a problem transferring a 330 ref library from EndNote into Zotero. THese have no attached PDF. They are all books.
    The Endnote Version is X.2.02
    The Zotero version is I think the latest: I am using a Macbook Pro OS X.

    I followed the instructions ion the zotero documentation ( without reaching any other result than having a screen freezing soon after starting to import items. No error message appears.
    I saved the file as .txt file and as RIS export (having updated as advised the RIS format):

    What I find particularly frustrating is that I managed to transfer much larger files the previous year and am unable to do so.

    I am quite not sure what to do at the moment. Any help would be very welcome. I realise that these information are rather basic, it betrays my lack of knowledge of Zotero. I am of course ready to provide with further pieces of information or lead me to a post susceptible to provide me with an answer.

  • edited February 26, 2013
    Does this problem happen if you test by exporting/importing only one or two EndNote book records? If so, please post that short RIS file here. Zotero probably should not fail silently. Are you sure that the 'freezing' was not due to delayed completion of the import? I'll let the real experts ask you about debug issues.
  • I have successfully imported 8 references without problem and the freezing happened immediately when I had selected my entire batch of 330 references. It looks as if I can proceed by importing gradually such small installments. Still, I could transfer earlier and without problem a much bigger database.
  • My suspicion would be that this is hanging on one particular entry.
    I'd go at this in a binary fashion:
    cut the RIS in half and import 165 entries at a time. If I'm right, there's a good chance one of them will go through, the other won't.
    If that's the case, you can quickly identify the RIS entry that's breaking this and we'd be very curious to see that.
  • I have tried to do so, but it seems to freeze again, in the same way as when I select the entire file.I'll retry tomorrow when I'll have more time to see if it is a question of time or not.
  • Is there anything private in the RIS file? Otherwise I'd be happy to take a look if you can post/upload it somewhere.
  • I tried again with different small installments of entries without result, at one point, it seems to freeze. I'd be happy to send you the file. How do you prefer to proceed?
  • The easiest would be if you could just upload the file - to your dropbox or to a gist at
    If that's absolutely not possible, send it to my (Sebastian) e-mail at the bottom of this post: I may have to share it with one other person (aurimas above) for troubleshooting, so by sending it you'd give me an implicit OK for that.
  • In case anyone else has an idea:
    The RIS imports fine on my computer. I exported the items as Zotero RDF and sent it to Egochan, import of that failed in the same way. Importing from clipboard fails, too.
    He has 4GB of RAM, so that can't really be the problem.

    One more thought: Try disabling all extensions restart Zotero/Firefox and try again.
  • Real time debug output for an import attempt (immediately after starting Zotero) may be helpful.
  • I did try this Real time debug output following the instructions provided on the link - but apparently to no result.
    Just a question to Adamsmith: what did you meant by "try desabling all extensions" ? Did you meant all open programs on the computer ?
  • Thank you very much Gracile for this link.
    I have just tried, but it did not work.
  • if there is no real time debug output you're doing something wrong - there would always be some output.
  • Actually your are right. I just tried a Debug output logging. THe ID is D1519964495. Could it be useful to diagnose the problem?
    Otherwise, I sent to a colleague the ZoteroRDF file you sent me a few days ago, and he too could not transfer it to zotero ... Am I contagious?
  • Dan - Simon - could you see if there's something in the debug?
  • Cannot start a DB transaction from a different wait level
    It's #230, though I'm not sure exactly what's triggering it in this case. Simon might be able to say more.

    Egochan: If you have auto-sync enabled, you might try temporarily disabling that, though it shouldn't be necessary. Closing the tag selector first could also help, though, again, it certainly shouldn't be necessary. You should also make sure you've removed any stray items from previous import attempts and emptied your trash.
  • Dear Dan,
    Thanks for the advice, I did that as well. Unfortunately, no change.
  • Dear all,

    This is to inform you that, at the end,one of our university computer scientists managed to import these files on his computer, reinstalled zotero on mine and imported the database in question. So that problem is solved - although it is still quite frustrating since I do not know what went wrong.
    Now, by reinstalling zotero standalone on my computer, I cannot see anymore the two groups I am part of on this version, only my Library. Fortunately they are still visible on the firefox/web version; but not on the standalone. Can anybody give me tips on how to retrieve groups on standalone? Thanks in advance for any help: it would potentially save me from wasting time.
Sign In or Register to comment.