Importing EndNote files into Zotero

  • Well, it seems it is not where the file is, but the name of the file.

    It worked fine under Linux, and now I am running the database under windows and it seems fine.
  • Did you actually try it on the desktop on Windows? It wasn't an aimless question. I was able to reproduce the problem by creating a folder and file with the same name at the root of the filesystem. When the filename was more than 134 characters, I got the error. The length of the containing folder made no difference, which suggested that it was a filename length limitation rather than a path length limitation (even though the Windows filename length limit should be 255 characters). Yet, oddly, even though the folder name length made no difference, moving the file to the desktop fixed the problem. I can't explain that, and there's not much we could do to fix it anyway, but I'd be curious to know if someone else could reproduce it.
  • In the initial case, the files were in subfolder in another unit (a external hard drive) and it didn't work. Then I tried using the simple root directory and it also didn´t work.
    However I have just tried with the desktop file and it worked !!.. Besides, zotero never gave me the error message (not even when using a file in the root, but in this case it just didn´t find the file).
  • Hello. I am trying to import a 2200-reference endnote file into Zotero. I'm going reference type by reference type and have completed books and book sections. Now I'm trying journal article and am getting hung up on date. The year is output as a PY field with a 4-digit year and imports to Zotero fine. But the "date" field exports as an N1 field and imports to zotero as a note. The RIS spec says that dates should be YYYY/MM/DD/other information, so fall 2006 would be 2006//fall. I'm using the 2/2/2010 version of the RIS style.
    Does anyone have a good fix? I have 700 journal articles so don't want to do this manually.
  • I recently imported a library of 4000+ records from EndNote into Zotero. As part of the process, I had to modify EndNote's RIS filter so that information I had placed in one of EndNote's Custom fields would be included. (A more detailed description may be found here:

    Unfortunately, Zotero's RIS import filter does not map onto all the RIS fields available and, as far as I know, is not easily modified. I was still able to import my data, but not as smoothly as I'd like. It would be nice if users could modify import filters in the same way that they can create their own output styles (e.g.,
  • Zotero translators are javascript files that can be modified:
  • I know they can be modified, but the process is pretty intimidating for the newbie non-programmer. I am looking for something that can be modified more easily--something like the process described here:
  • Well, it isn't going to be as easy as the CSL editing interface. You can install Scaffold (, unofficial XPI of the 2.0 version available here: . It will let you at least open and edit Zotero translators without digging around in the Zotero data directory, although it is mainly designed for writing site translators, not import translators.

    Changing the mappings is actually fairly easy, as these things go. On line 212, change
    } else if(tag == "N1" || tag == "AB") {
    // notes
    if(value != item.title) {
    to: } else if(tag == "N1") {
    // notes
    if(value != item.title) {
    item.archiveLocation = value;
    } else if(tag == "AB") {
    // notes
    if(value != item.title) {
  • This sounds doable, ajlyon, except that I don't know where to find the file that contains the mapping for the RIS filter--the one that Zotero automatically recognizes when you open a text file.
  • You'll want to look in the translators directory of your Zotero data directory. Open the file named "RIS.js"; it handles RIS import and export.
  • Thanks for the help! I was able to import the fields I wanted. After a few additional changes to RIS.js, the translator imports "Edition", "Series Number", "Number of Volumes" and "Editors" fields correctly (for the most part). The relevant code is as follows:

    Linking the AB field to Zotero's call number field:
    } else if(tag == "AB") {
    // call number
    if(value != item.title) {
    item.callNumber = value;
    } else if(tag == "N1") {
    // notes
    if(value != item.title) {

    Linking the M1 and M2 RIS fields to Zotero's "Rights" and "Thesis Type" fields:
    } else if(tag == "M1") {
    // date read
    if(value != item.title) {
    item.rights = value;
    } else if(tag == "M2") {
    // thesis type
    if(value != item.title) {
    item.thesisType = value;

    Mapping the Unused U1, U2, and U3 RIS labels to Zotero's "Number of Volumes", "Series Volume" and "Edition" fields:

    } else if(tag == "U1") {
    // Number of volumes
    if(value != item.title) {
    item.numberOfVolumes = value;
    } else if(tag == "U2") {
    // Series volume
    if(value != item.title) {
    item.seriesNumber = value;
    } else if(tag == "U3") {
    // Edition
    if(value != item.title) {
    item.edition = value;

    To work properly, an RIS.js file with this code needs to be used with a revised RIS EndNote Output style. Mine is available here:
  • I'm glad to hear that this worked for you. I wish that it were a little easier to change these things, but as you found, it's not entirely impossible to modify the translator to move the relatively unstructured Endnote data into the structures of Zotero. Perhaps an enterprising person will create a utility that creates modified RIS.js files for people automatically... In the meantime, thanks for writing up your solution. I hope it helps future migrants.
  • Ok, so when I try to manipulate the txt file that I've exported from Endnote to make the fix, or when I import into Zotero, I get the message saying that it's not UTF-8. And I think that's creating problems, mainly that when I import the text, with the PDFs, it only imports the first half of my library, plus I get an error message.
  • Following directions provided by Zotero, I selected the output style "RefMan (RIS) export" under output styles in my Endnote program. I then went to file and export and selected text only and "RefMan (RIS)." However, I don't think endnote is actually saving in RIS format though because when I attempt to import into Zotero, a window announces that "the selected file is not in a supported format." Do you have any further directions on how to make sure my endnote library saves as RIS? I have also tried to save using the BibText format and other suggested formats, but with no luck. I have read and re-read the directions and followed step by step multiple times.

    Thanks in advance!
  • open the RIS with notepad or TextEdit and post the first item here.
    Also, make sure you follow the "text only" part of the description as ajlyon pointed out in the other thread.
  • Thanks, but I am afraid I don't know what you mean by "open the RIS with notepad or TextEdit." (Sorry, I am very new to this program). I followed this aspect of the "text only" instructions:
    Once RefMan (RIS) is set as the format, select “Export” from the File menu. In the Export window that pops up, choose “Text Only”, select the RIS output style immediately below “Text Only” in the dialog, and hit “Save.”
    I do that and then click "import" and select the saved copy of my endnote library.
    Still no luck. Zotero keeps telling me that "the selected file is not in a supported form"
  • Assuming you're on Windows:
    All of this happens entirely outside of Zotero:
    Right-Click the file "Endnoteexport.RIS" (or whatever you have called the file you exported from Endnote).
    Windows will display a range of options, including "Open With..."
    Pick that option and select the program "notepad" (your standard text editor).
  • edited June 14, 2010
    Ok. You need to find and open the program Notepad on your computer (if you're using Windows) or TextEdit (if you're using a Mac). From inside that program, open the file you exported using Endnote. Select the first section of the file, copy it and paste it here. The first section runs until the first line starting with an ER.

    If this still doesn't make sense, I think you'll have to ask your favorite computer person to help out a little.

    [Or just do what adamsmith said. We're suggesting two ways of doing exactly the same thing. Good luck!]
  • Hello, I'm trying to export my libraries from Endnote XI. I have tried exporting as RIS and BIBtex and with both styles I get the message 'No translator could be found for the given file' when I go to the gear in Zotero and click import.

    I am trying to follow the instructions carefully. The only difference I can see is that I'm not getting the option to save as 'text only' but as 'Text File' (.txt), and that's how I'm saving. The other options are .rtf, .xml, .html

    Can anyone help? Thanks.
  • OK, figured out what I did wrong--I had selected the correct style on the style manager, but then not in the save box. It's currently importing. Hopefully it won't take too long (900 items) and I won't have too many compatibility problems.
  • thanks for the post, diana. i was having the same problem. note to zotero: consider adding to your import instructions the fact that one needs to save the file after switching to the RIS output style, otherwise conversion won't work.
  • I'm importing a 1000+ reference library from Endnote X to Zotero 2.0.0 (Windows XP/Windows 7) and can’t figure out what went wrong. For exporting from EndNote I used the output style of RIS and followed the instructions posted. Here is my issue:

    1. I got this message upon importing: "An error occurred while trying to import the selected file. Please ensure that the file is valid and try again."
    2. Only 300 of my references imported and I can’t seem to figure out which are missing.

    I tried to go through the list and find the pattern, but can’t figure it out yet. It’s not necessarily references with websites or those with PDFs. I read through other posts but still can't solve my problems using methods suggested because they are more complicated than my level of knowledge. Is there a good way to figure out what is missing? I can deal with issues as long as I have enough explanation of the basics first.
  • My method from Endnote X into Zotero on Windonw Vista:

    Select BibTex as an output style in Endnote.
    Open MS Word and import your entire library (have to do 50 at a time unfortunately!), producing a document of just BiBTex style references.
    Convert to plain text.
    Copy into notepad and save as a .txt file.
    Import from Zotero.
    Bob was my uncle!

    A bit antediluvian I know but got me the results, can't find any errors so far.
  • Thanks pjcwhite! Your solution worked for me.
  • Hey I need to import my .pdf files from my endnote and can't figure out how. I've already imported all my citations but I don't know how to properly run or what to do with the 'script' that is offered on the Zotero website that is supposed to help.
    If anyone can assist me that would be awesome??
  • We're happy to help, but since Endnote exports attachments in such a silly way, you'll have to be willing to read&follow instructions even where they involve things such as "script".

    As a note, though - it's not possible to import the PDFs independently of the other items, so you're best of deleting everything and starting from scratch.

    Try to follow the instructions here:
    and let us know what you don't understand or what doesn't work.
  • Thanks for your help. I have tried to follow the directions on that page already, but I don't know what to do with the .vbs file after I create it? I'm not sure what is meant by "run" in the directions?
  • you should just be able to double-click it (like a .exe file) to run.
  • when i double click to run all it does is open the file, nothing happens.
  • sounds like you didn't actually change the file extension to .vbs - what does the icon for the file look like? Like any other text file, or does it have a scroll-type symbol on it?
    If the former, you need to show file extensions in Windows
    - you'll see that the file is actually .vbs.txt - remove the .txt - you may have to OK a warning that Windows gives you about changing file type and you should be good.
Sign In or Register to comment.