Importing EndNote files into Zotero

  • Addition: a 'How to import your EndNote library' tutorial would be helpful. But right now there is little point in having one, since it would say things like, 'If the import process fails for some reason, try importing all references starting with A first. Then go on to B. And so on.' If I am an academic with a library with thousands of items, that's not what I want to hear.
  • All great points, especially on informative error messages.
    And I think the increasing amount of RIS issues we get here is both heartening - because I believe it's a sign for an increasing movement from Endnote - and disheartening - because I think you're right that many people don't make it to the forum.

    I think the tutorial might still be a good idea. The documentation is a wiki - you can contribute easily. The tutorial would hopefully get less complicated as the feature improves...
  • edited August 5, 2009
    And I think the increasing amount of RIS issues we get here is both heartening - because I believe it's a sign for an increasing movement from Endnote - and disheartening - because I think you're right that many people don't make it to the forum.
    Yeah, but I fear you have to put 'disheartening' first there. Thing is, this is the time Zotero's building up momentum. People are starting to hear about Zotero, often for the very first time. This is the time to make a good impression on potential switchers, not to put them off by making it complicated to switch. We don't want Zotero to be that tool of which everyone says, 'Yeah, Zotero, you told me about that, right? I gave it a try, but it didn't really import my EndNote library.' I've had that happen several times now.


    I know things aren't simple and there are a lot of constraints, but I'd say: get this fixed before 2.0 goes out of beta. Zotero will make a huge splash then as the groups, sync, and sharing features will attract a huge number of people, many of them coming from EndNote. If switching is still such a hassle then, it will backfire. There will be a flurry of blog posts of people who don't get it and don't like it, detracting even more potential users. In any case, the thing to keep in mind is: first impressions are everything. Collections, tags and syncing may look nice and all, but if I can't get my 5000-item library in there without expert help or RIS hacking, it's not going to be worth the effort.
  • I think one who considers moving from Endnote has two options:
    1. keep paying for Endnote.
    2. hack his RIS file and save his money.

    The exported RIS file is full of small mistakes and the user needs to know where are they.

    i don't know if it is possible to process ALL the RIS mistakes in an automatic manner. a detailed output file will help the user to do the move easily and transfer ALL his entries (and fields) without any mistakes. In any case the user needs to be responsible for his information and check that everything is good.
  • I'm one of those people who is trying to switch over from Endnotex3 to Zotero 1.0.10 (Windows XP) before I start writing my dissertation. Adding new citations is going fairly well but importing my large number of EndNote citations is not going well. For exporting from EndNote I am using the output style of RefMan [RIS] export. I'm having two problems. I read about them in other posts but still can't solve my problems using methods suggested because they are more complicated than my level of knowledge. I don't know how to do anything past the basics when dealing with software issues.

    1) Imported files include two Zotero Notes. One has the abstract and the other has everything that was under the notes field in the exported file. My research notes are in the exported file but are not imported anywhere in Zotero. I tried what I saw in a different post- search and replace in the export file to move the research notes into another field (I think it was N1) but if that refers to the "Notes" field, that field is not empty in the exported file.
    2) The hundreds of pdf's that I have on my hard drive and have included in endnote as a file attachment are not imported.

    (I have tried to import this file as both an .ris file and a .txt file with the same results.)

    Any help is appreciated but if possible please explain using terms for someone who does not know how to program etc.
  • 1. Beyond any and all forms of reason the N2 field is actually mapped to abstract in the RIS spec so if you do a find and replace for whatever tag is attached to your abstracts Zotero will import them properly.

    2. Importing attached PDFs also works. It just takes a bit of finess. See this article in the knowledge base.
  • Please give an example of a record that failed to import after you changed the research notes line to use N1.

    For 2, have you changed your links to use the file:// syntax? e.g.
  • In response to noksagt's question regarding N1: I think the problem was something on my part but I can't remember and I don't have a record anymore.
    Regarding my current problems:
    1. I successfully moved the abstract from N2 into AB field! Thanks for the help.
    2. I've gotten partway on importing PDF's with my EndNote files.
    Here's what L1 looked like in the original file exported from EndNote in the RefMan (ris) export. format.
    L1 - internal-pdf://Am J of Pschiatry v152p1804-2194281778/Am J of Pschiatry v152p1804.pdf
    Here's what it looks like after doing the search and replace as suggested
    L1 - file://C:\Jan\Full Text Articles\Am J of Pschiatry v152p1804-2194281778/Am J of Pschiatry v152p1804.pdf
    The files import into Zotero but of course, I get an error message when I try to open the pdf.
    If I remove by hand the redundant part of the file (e.g. Am J of Pschiatry v152p1804-2194281778/ for this example) then I can import as a .txt file and access the pdf (but not if I use a .ris format, see below for what happens if I try to import as a .ris, I don't think I need a solution to this but I am providing the information). So, how can I get rid of the redundant part of the file path name?

    If I try to import a very small file (2 citations) as a .ris the importing items progress box opens and appears to be importing but the dialog box also opens that says "you have chosen to open (gives file name and path). What should Firefox do with this file? Open with (several choices) or save to file. If I cancel this box the importing items progress box continues indefinitely and I have to close firefox to get it to stop. If I chose open with Mozilla Firefox I get a dialog box that says file (name of file) could not be opened, because an unknown error occurred. Try saving to disk first...
    If I chose open with Research helper (the default) I am asked to choose destination of Endnote or Ref Manager. Again I have to close firefox to stop the importing. If I chose save file and try to import from that location I get the same problem of hung up importing and the box asking me to open or save the file etc.
  • edited August 13, 2009
    Preliminary comments:

    1. Your slashes are mixed (forward and backward) in these examples — are they also like that in your RIS file? I think FF can handle either, but they need to be used consistently.

    2. Are you saying that the link to the PDF in the file as exported by Endnote contains redundant stuff? So if you change internal-pdf:// into the reaql file system path you don't get to the PDF unless you remove some more stuff?

    3. Try to report the problem to EndNote and to your IT department. They may not be very eager to fix it, but it is definitely a bug and if their users don't complain about it they'll certainly be very happy to leave their export mechanism in this sorry state. Meanwhile we'll try to help you find a workaround.
  • edited August 13, 2009
    Your slashes are mixed (forward and backward) in these examples — are they also like that in your RIS file? I think FF can handle either, but they need to be used consistently.
    file:///C:\Documents%20and%20Settings is perfectly valid in FF on Windows
    (edited URI to what I intended, rather than the re-written version)

    Re. 2: where are the files actually located on your disk?

    Re 3: It may not really be a bug, just a somewhat poor design of Endnote: they made up a (pseudo-)uri scheme that is not used for anything else & gave it a deceptively common name so that relative links to files would work. It'd be nice if they used 'file://', of course.
  • edited August 13, 2009
    Indeed, Firefox is very tolerant of inconsistant slashes. Even this works:
    Though note that it is automatically corrected by FF to your version. But I just thought it's never a terribly good idea to be inconsistent just because it's tolerated by some piece of software in the chain.

    (I see your point re bug vs. feature. My point is just that if no-one complains about bad user experiences, there are no bad user experiences from a corporate point of view, so the issue would not even be actionable. If, however, people actually do lodge their complaints in visible places (like the EndNote forums), the issue becomes (1) actionable and (2) a potential PR problem (and hence more actionable).)
  • I figured out the inconsistent slashes. Microsoft uses backward slashes C:\Jan\Full Text Articles and I just cut and pasted the file name.

    noksagt, Re: 2. The files that are attached to the EndNote citation are on my hard drive in a folder (full text articles) that I created.
  • Right, but what is the full path to those files?
  • C:\Jan\Full Text Articles
    for example: C:\Jan\Full Text Articles\A_J_Pathologyv158p1793.pdf
  • So, how can I get rid of the redundant part of the file path name?
    Copy the following and paste it into notepad. Save as "ris-fix.vbs" or similar & run it.' RIS link fixer for windows
    ' transforms Endnote internal-pdf:// links into file:// links

    Dim FileName, objDialog, boolResult
    Dim regEx, FileContents, modFileContents
    Dim objShell, pdfFolder

    'choose RIS file
    Set objDialog = CreateObject("UserAccounts.CommonDialog")
    objDialog.Filter = "RIS (*.ris)|*.ris|All Files (*.*)|*.*"
    objDialog.FilterIndex = 1
    boolResult = objDialog.ShowOpen
    If boolResult = 0 Then
    FileName = objDialog.FileName
    End If

    Set regEx = New RegExp
    regEx.Pattern = "internal-pdf://.*/"
    FileContents = GetFile(FileName)

    'choose folder containing PDFs
    set objShell = CreateObject("Shell.Application")
    set pdfFolder = objShell.BrowseForFolder(0, "Where are your PDFs?", 0)
    If (not pdfFolder is nothing) then
    ReplaceWith = "file://" + pdfFolder.self.Path
    modFileContents = regEx.replace(FileContents, ReplaceWith)
    If modFileContents <> FileContents Then
    WriteFile FileName, modFileContents
    Wscript.Echo "Finished chaning internal-pdf:// links to file:// links."
    Wscript.Echo "nope"
    End If
    End If

    function GetFile(FileName)
    If FileName<>"" Then
    Dim FS, FileStream
    Set FS = CreateObject("Scripting.FileSystemObject")
    on error resume Next
    Set FileStream = FS.OpenTextFile(FileName)
    GetFile = FileStream.ReadAll
    End If
    End Function

    function WriteFile(FileName, Contents)
    Dim OutStream, FS
    on error resume Next
    Set FS = CreateObject("Scripting.FileSystemObject")
    Set OutStream = FS.OpenTextFile(FileName, 2, True)
    OutStream.Write Contents
    End Function
    Non windows users or users willing to install third-party tools have it much easier, as they can just use 'sed' ;-)
  • Noksagt, that is absolutely beautiful.
  • Thanks for this discussion! It helped me get started with Zostero - I finally managed to import my EndNote library :)
  • High Everyone!

    Here is my problem. When importing from endnote I managed to change the RIS file to give the complete path, but It didn't actually attach the file, it just just added a the link (BTW it works when I click in "view"). Then, I tried to upload my database to my webdav and it worked, but it doesn't upload the files (I guess this is because they are not attached but only linked in the datebase. If I attach manually a file it works).

    So, how can I automatically attach a file from the URL in the database?

  • What kind of URL (file://, http://, etc.) and what RIS field?
  • URL file://c://.... and RIS field L1 (thats the default provided by endnote)
  • Try it with three slashes, if you're not. file:///c:\foo\...

    Does copying and pasting the URL into the Firefox address bar display the file?

    What version of Zotero are you using?
  • Thank for you suggestions!

    The three slashes worked, but I still have another problem. Besides, when pasting the URL I see the file, and I'm using Zotero 2.0b7.4

    Here is the complete procedure I did:

    When exporting from endnote, I had problems with some files (zotero showed "An error occurred while trying to import the selected file. Please ensure that the file is valid and try again.")
    Apparently, the problem was due to the name of some files (for instance one was named name.pdf.pdf and when I changed to name.pdf it worked). However I noticed that if I did not change the original path (internal-pdf://), I could successfully import the data base. Then, I exported the database form zotero, and modified the path in this file.

    If I add the 3 slashes to the original endnote RIS file, it works, but I think I would still have the problem I mentioned. If I add the slashes to the exported file from Zotero, nothing changes.

    Any suggestion?
  • If you don't change the path, Zotero doesn't import the file, and filename problems wouldn't show up.

    I can't think of any reason name.pdf.pdf should fail, though, and it works for me on OS X. Provide a Report ID from after generating the error, and we'll take a look.
  • Thanks again!

    What I don't understand is that Zotero cannot open the "problematic" files when importing, but it can open the files if the path is written as a URL.

    I generated Report ID 1346116461 trying to import the following reference from clipboard :

    TY - JOUR
    AU - Zhou, D.
    L1 - file:///C:/2006_IJP_Zho-3947815169/2006_IJP_Zhou_Finite element simulation of PSB macroband nucleation and propagation in single crystal nickel cycled at low plastic strain amplitudes.pdf
    ER -

    PD: I couldn't find the .pdf.pdf file, so I just used another case that it doens't work.
  • Well, as I noted above, Zotero is only importing the file if you adjust the field. Otherwise it's just a text string and Zotero doesn't have anything to do with the file. (If that doesn't make sense, don't worry about it. It's expected.)

    The spaces in the filename may be the issue, though I can't reproduce it on OS X. Does it work if you replace each space in the field with "%20" (without quotes)?

    If not, can you view the PDF if you copy and paste the file:// URL into the Firefox address bar? Does it work if you use backslashes instead of forward slashes for everything after C:?
  • I tried that and got mixed results.

    If I replace the space with "%20" Zotero attaches the link (I see the small pdf icon), but when I try to access the file, it cannot find it. The same happens if I paste the file://URL into firefox (again, using "%20" it doesn´t work), but if I copy the original path and pasted it into Firefox, and I can see the pdf. Forward or back slashes did not make any difference.

    So, it seems that I can see the file with the original path, but I cannot import it. Its weird that I can import other files that seems to have comparable names. Besides, most of my database seems to be OK, but when it fails to import one file, it just stops importing everything and cannot continue.

  • Do other files with spaces work?
  • Yes, for instance this works OK.

    TY - JOUR
    AU - Budrovic, Z.
    TI - Plastic deformation with reversible peak broadening in nanocrystalline nickel
    L1 - file:///C:/2004_Science_Budrovic_Plastic deformation with reversible Pea-2006934272/2004_Science_Budrovic_Plastic deformation with reversible Peack Broadenin in Nanocrystelline Nickel.pdf
    ER -
  • New Update:

    I was able to import my endnote library without problem in linux version. I am closer to have everything set up, but the problem in windows is still there. Shall I do any other test to try to find the problem?
  • So...try using a folder on your desktop instead of at the root of the C: drive.
Sign In or Register to comment.