ZotDroid - A Zotero Client for Android

  • Hello all
    1.1.8 BETA is now out. You can access it here:


    Basically, any new features and bug fixes will appear as BETA versions first. I figure that keeps other users from not having to upgrade all the time.

    @piom @zhanghuan05 I suspect this will fix your issue, as it attempts to select the best directory upon initialisation, complaining only if it can't find one.
  • @OniDaito I am using a personal webdav.

    Thanks for your inputs. My phone is running android 4.4.23
    Looking forward to seeing the beta release.

  • @zhanguan05 then please try the beta release. It should work for you, fingers crossed. Rather than push out a new version for everyone, I want to fix bugs in a separate branch before continuing. That way, we don't inconvenience users who don't have this problem
  • @OniDaito I am using a personal webdav.

    Thanks for your inputs. My phone is running android 4.4.23

    I hate to say the beta version still has the problem.

    Webdav test passed. Grey button. After clicking, showing error msg:
    "Error: Could not find file to download. Please check your webdav settings and make sure the download directory exists.: /storage/emulated/0/Documents/ZotDroid/attachments/Aujlxxx.pdf"

    Maybe we should wait for @piom to see if the beta version works for her/him.
  • edited April 13, 2018
    @zhangyuan05 this must be impossible now. There has to be a factor I've not seen. Ultimately, if the directory fails on initialisation, it will choose one from a selection. On my 4.4 emulated device, it chooses /data/data/computer.benjamin.zotdr0id/ZotDroid which, although different, works fine.

    Can you try removing the path completely, seeing what the application chooses, then closing zotdroid, restarting zotdroid and seeing what it chooses then? On startup it will check the chosen directory and choose one it thinks is correct.

    Also, please verify the about box says 1.1.8 BETA
  • edited April 13, 2018
    @OniDaito I checked the about box, it says 1.1.8 beta.

    And actually I have tried the following operations.
    1) In the beginning, after upgrading to beta, ZotDroid shows an error msg that saying the downloading directory (it pointed to an SD card) does not exist.
    2) So I remove the path, and close it and restart it. It chooses the /storage/emulated/0/Documents/ZotDroid. But After I reset and sync, and click the grey button, the error msg i input in my previous comment shows.
    3) And I uninstall the app and reinstall it back. The same problem still is there. :(

    I did check the download directory, it does exist. (ZotDroid successfully created two directories: attachments and temp there. But the two directories contains no file at all)

    I doubt if there's anything wrong on my webdav side's setting.

    Anyway, maybe we should wait for more test cases to know whether this is just my unique problem only or not.
  • @OniDaito I found the problem.

    The WebDav Server Address I input is:
    But actually it should be

    After modification, it works. :)
    Thanks for all your help. And I do apologize for wasting your time due to my setting mistake.

  • I was just about to comment on the WebDav :) The problem is that the exception is an IOException which can be thrown for BOTH local errors like files not being written OR when the WebDav fails. It can be misleading which is why I changed the error message.

    No need to worry about wasting my time, though I appreciate the thought. It's good to iron out these things, even if it's just error messages :)

    Glad to know it works!
  • This simple issue with the correct webdav directory path was the culprit in my case as well... ;-)
    Zotdroid 1.18
    Android 7.0
    OwnCloud based WebDav.
    Thanks for all the effort!!!
  • Thanks! I think I'll add the change in the beta to the mainline, once I've tested out the addition of abstracts and full downloads.
  • Hey there everyone.

    The next BETA version is out: 1.1.9


    This version has support for abstracts in the main listing (I believe a few of you were after that). In addition, there is a menu option for downloading ALL attachments. It can take a while depending on the size and number of your attachments, and the speed of your connection, but it seems to work here.

    If there are no problems in the beta, I'll roll this out to the mainline for all users

    I should point out that users who want to see their abstracts will need to perform a sync after upgrade. This will download all the records from zotero and insert the abstract. There is no way around this sadly, but it does work.


  • hi @OniDaito
    i'm still having the same problems with acccessing webdav.
    if i 'test webdav' i get connection failed error
    if i try to open a pdf i get 'coud not find file to download etc.'
    i'm wondering if this is a problem with the webdav storage i'm using?
    i use CloudMe, the webdav address is https://webdav.cloudme.com/username/xios/zotero
    as recommend here: https://www.cloudme.com/en/webdav/help (which works fine with the desktop zotero)
    wondering if it's worth switching webdav storage provider....
    (using zotdroid beta on a oreo pixel c and an honor 6x, same errors on both)
  • Hello @henge - thanks for the feedback. Are you using the latest beta or 1.1.8?

    If it works for Zotero Desktop it should work for Zotdroid. The test function sends an OPTIONS request which perhaps cloudme doesn't respond to, but the download should still work.
  • i'm actually using beta 1.1.9 (at least that's what it says...)
    it must be down to some sort of wiedness with cloudme, i've been thinking of switching to thebox for a while (10gb of free space!) so this is giving me a push. i'll report back when i've had chance to switch
  • Yep, there's something not quite right at CloudMe.
    Switched to Box.com, and all is working beautifully, it's very satisfying to see and will be a real help to my research/work!
    Thanks again @OniDaito
  • @henge glad to hear it's all working for you. I'm suprised that cloudme doesn't work. Oh well! It seems that WebDav isn't always implemented in the same way.

    I'll be going through some more bugs in the beta then moving the changes into the mainline this week. I'm hoping to get additions from the browser working as the next step, though it'll take a while no doubt ;)
  • @OniDaito one weird thing i did notice tho, (and it may just be me...) is that on my phone i can only download papers to the internal storage; when i point the settings to my external sd card i get the error message for the webdav. it seems to have permission, so it's a bit odd.
    on another note, i love the download all attachments option. And additions from the browser would be amazing.
    Are there plans for two-way sync of pdfs etc. (thus allowing any notes/highlighting to be saved)?
  • @henge thanks again. Not sure why your external card would not have permissions granted. It could be a UX thing I've not gotten right yet perhaps?

    I'm entering a busy time at the moment with a lot of stuff on, both other freelance projects and research so aside from bug fixes, I won't be doing too much on Zotdroid for the next few months.

    However, I think the next steps will involve:

    - Major UX overhaul including simple additions such as reverse sort and more fields
    - The option to delete from your Zotero Collection
    - Some form of addition from the browser through the *share* option. I'd need to speak with the Zotero developers about this because it involves their 'fancy magic' to auto-fill in fields.

    I'd love to do pdf change and sync back if thats possible? It may be that I can check the last modified date on the PDF and sync back but it's an advanced topic, especially with the intermediate ZIP file for these webdav folks. I think I'll need to be very careful with that - it sounds simple as an idea but it could go horribly wrong if not carefully thought out. But I can see why folks would want that.

    So yes, plenty to do in the future. First thing though, get the changes from beta into mainline.
  • Hello all
    1.1.9 is now out on the main android store.

    I've added abstracts and the ability to download all the attachments.

    There was a minor bug in the upgrade code (something I never knew I needed to write) which I've fixed. I've also improved the error messages a little to avoid the webdav nightmare that has been plaguing people.

    I'm at crucial point in writing up my thesis so I wont be putting out any major changes to the codebase yet, but I've some ideas of what to do next thanks to you all here.

    If anyone spots any bugs, do let me know and I'll fix as many as I can.

  • just updated to current version and resetted everything, but still not luck.

    "Error: Could not find file to write to. Please check your webdav settings and make sure the download directory exists: /storage/emulated/0/Documents/ZotDroid/attachments/[mypdffile].pdf"
  • Thanks @piom - I'm out in the middle of the desert at the moment and away from my workstation. However, can you confirm the following for me - are you using a real SD card, mounted at /storage/emulated/0
    Also, can you confirm your webdav settings please?
  • - no real SD card, just internal storage
    - personal webdav and seems to be working. in fact, when I use the download all attachments functions, it starts to download, but is still not accessible.
  • Thanks @piom - Can you tell me the URL you are using for the webdav please? just want to verify it's correct. Your device is running Android 7 correct?
  • Thanks @piom - just a thought. Is this the URL you enter into the normal Zotero program? Does it work there? If so, in zotdroid try the following:


  • finally it works! yes, it was the same URL as in the desktop client, but I needed to add the .../zotero.

  • Awesome! Thanks @piom . This is one of these pesky UX issues that can get people caught in knots. I don't like the fact that zotero insists on adding zotero to the end of the webdav, so I left it out of Zotdroid but then again, this is confusing and leads to problems like this so perhaps I need to add a hint or something?
  • I’d suggest that using the same setup for WebDAV as Zotero (automatically adding the /zotero to the end) is important.
  • Annoyingly, there are limits to that particular android widget, so the only way to do it is add a warning dialog if the user does not add /zotero at the end. But that might be good enough.
  • That would probably be sufficient, yes.
Sign In or Register to comment.