ZotDroid - A Zotero Client for Android

167891012»
  • Hi,
    I would like to install ZotDroid on my tablet. However, I don't want to use Google Play Store. Is there a way to download it without the play store? I am happy to pay for the app, that's not the problem. It's just that I don't want to use Google on my tablet. thanks for the answer in advance!
  • Hi Ben - I wondered if you were successful in getting your MRes submitted on time and are thinking of getting back into ZotDroid development again soon...?
    Many thanks,
    Richard
  • Hello everyone!
    Yes, I'm now back at my desk after having been a few thousand miles away from it, submitting my thesis! Now I've gone and started a PhD but fear not - I'm back on board with Zotdroid! I've been using it already for my own research and there are many changes I already want to make.

    I'm getting a full list together this weekend so I can start adding new features little by little. My plan is to focus on the UX niggles and extra settings people have asked for. Eventually, when I get a larger block of time, I'll look at a version 2.0 with full support for adding new records, saving from the device etc, but this year, it will be getting these easy wins out of the way first.

    As for an alternative to the Google store - I'd love one! Not sure there is one out there right? I do remember an opensource store I believe? I suppose there might be something like itch.io right?

    Get your requests in now! :)
    B
  • Welcome back Ben! Good to know you're back on the case - ZotDroid is now an indispensable part of my everyday life.
    Congratulations on starting the PhD!
  • Hi Ben,
    I would love to be able to sync the annotated pdf back to the zotero servers.
    F
  • F-droid is good for an free software repo:
    https://f-droid.org/en/
  • Good to hear that development will continue in any case. Thank you!

    My requests:
    i) left hand browse menu to take up only 2/3 or so of screen, so you can always see entries update as you browse. Also, 'back' command at the top so can tap-tap-tap in same place to climb down from highly branched trees.
    ii) search function give some indication that it's working. I have a large database (5000+ items) and the UI just freezes while searching for 5 seconds or so. Not a biggie, but perhaps a spinner pr progress bar to let me know it's working (and not actually frozen) would be nice.
    iii) more robust WebDav error messaging. Got it working after a little trial and error like some others earlier in this thread, but e.g. current 'check my webdav' settings doesn't check that you've also entered the /zotero/ part of the path, and error message asks us to either check that or dig into whether a folder exists, so in combination it can be a bit misleading.
    iv) options to view more information than just title in entry list. E.g. entry type icon, or perhaps customization of the text string: from fields like author, title, year, publication etc.
    v) smoother sorting. I'm getting crashes when asking to sort by author.
    vi) The big one is add entries, obviously. Most valuable would be add by identifier and a book scanner function (perhaps using the old Scanner for Zotero as a resource, https://forums.zotero.org/discussion/62552/what-happened-to-scanner-for-zotero). Actually what I probably want is just for someone to fix that app.

    Anyway thanks again for your work!
  • Hello,

    I've just started using the ZotDroid client and I'm having some troubles with the WebDav connection. I use cloudme to store the attachments, and I'm getting the know and documented error:

    "Connection failed: Failed to access: https://webdav.cloudme.com/"username"/xios/zotero/. 2131623980"

    while setting this server address as
    https://webdav.cloudme.com/"username"/xios/zotero/

    Has anyone found what the cause of the error?
    I have checked serveral times, testing both with and without the ending slash, with the webdav test and trying to directly download attachments.

    I use the same setup (webdav provider, server address, user, pwd) that I've been using for the last 5 years across multiple machines. The error is under a Samsung Galaxy Tab Pro (SM-T900) with android 5.1.1.

    Anyone can throw some light?

    Thanks for your time,
    Ed



  • Hi Ed ( @ysgard )

    I could not get CloudMe to work at all. I would like to have used them but in the end I switched over to pCloud and that has worked flawlessly.

    With pCloud you get 10GB free, which is good, and 500GB costs £43 p.a. (or £160 for 'lifetime'!)

    I'd really like to use OneDrive as I get 1TB as part of my Office365 subscription but that always prove challenging for developers to use!

    Richard
  • Hello everyone! Long time no see!

    I've started a PhD having passed my MRes (yaaaaay.... I think :/ ). More low paid programming and research work ;) But anyway...

    v1.1.10 is now out. It's only a minor release but it fixes a few bugs, adds the experimental "unzip all attachments" and adds some warnings to make sure folks don't get the dreaded "cannot find x to download" error.

    I'm getting back into the swing of things and should have time to keep adding improvements alongside my main job, with a bit of luck.

    Cheers
    Ben
  • Hi Richards,

    in the end I switched to pCloud as you suggested and everything went smooth, thanks for your input.

    I also want to thank you, Ben, the app works great even in old tablets (mine is 4 years), good luck with your PhD!

    Ed
  • Hi @ysgard - thanks! I'm glad it works right for you. Thank-you for the kind words.

    I have a real problem with planned obsolescence; there is nothing at all stopping the majority of older machines running this stuff. I mean, many additional features these days aren't game changers in terms of what we can do with machines and how we program for them. I mean, a screen, internet connection and some databasing is all you need for a Zotero app (that's not to downplay the effort - sync is the hardest thing) but theres really only arbitrary code standing in the way of things working on older devices. So I'm going to continue support for these older models for as long as I can.

    I think the next addition will be adding extra fields and improving the search. That should make things a little nicer for most folks.
    Cheers
    B
  • Hello,

    I've just downloaded and installed ZotDroid on my phone, and have successfully synced my Zotero library. However, I use Zotfile to store my PDF attachments on Sync cloud storage.

    I am wondering if it's possible to get ZotDroid to recognize this and open the PDFs. I have Sync installed on my phone, although I do not download the attachments because I have about 4000 of them.

    Thanks!
    Steve

  • The big thing for me is being able to save PDFs and other files to my SD card. I have more than 6GB of files in my Zotero library (more than 4k files total) and I'd like to go ahead and save them all to my SD card so I have them on the go even without a network connection.
  • @dmhowcroft that is already possible for the PDFs and the database. You can select a different location in the settings under general options.

    @stephen_chignell that should already be possible too, but at the moment, I need to consider how to consolidate the differences between personal webdav and zotero storage. One looks for zip files, the other for the actual PDF/DOC/Etc.

    In the future version I may do away with the zip files altogether, dealing only in the PDFs. That would be a major change that means everyone has to re-download all their PDFs so it's not one I'll take lightly.
  • Hi Ben,

    I am realy new to ZotDroid and Android. I want to do the same as @dmhowcroft : sync my zotero library on the zotero webserver to my tablet (Samsung Galaxy Tab S3, Android 8.0.0) on the SD card.
    In settings I found

    "Download Location"
    /storage/emulated/0/Documents/ZotDroid

    and "Database Location"
    /data/user/0/computer.benjamin.zotdr0id/databases

    My questions:
    1.
    I wonder which data goes to what directory: attachments like pdf to Download Location and the Zotero-Entries themself to "Database"?

    2.
    When I click on the location to change it, I found no selection option like I am used from desktop file browsers in Linux/Mac/Windows. I do not know what would be the path to the SD card under Android. Should I change the "0" to "1" as a device number? (As I said, I am totally novice to Android)

    Thanks in advance for your advice and for your dedication to the ZotDroid App
    Olaf
  • Hello for my question 2 I found a solution:
    1. download the free app Amaze (file manager)
    2. go to the folder you want to store your zotero files
    3. look at the top right of the app: it shows you the path to the file
  • edited November 29, 2018
    Hi Ben (@OniDaito),

    I run into the same problem as @paulvdh on May,25 and @nspiller on June, 11 2018 and can not store/download attachments to my external sd-card (Galaxy Tab S3, Android 8.0.0) from my Zotero Storage account. I would like to stick to the Zotero Web Storage, it works fine and paying Zotero for it supports the overall development of Zotero.
    Did you found a testing device and solution meanwhile?
    Thanks in advance
    Olaf

    Update:
    I just played around a little bit with folder names and got one step further:
    1. using a filemanager app (Amaze) I added the folder "/storage/0000-0000/Android/data/computer.benjamin.zotdr0id" taking the same name as in the default "database location" path for the "yyyyyy.yyyyy" in the path suggested by @smatthie on June,15

    2. change the Download Location path in ZotDroid Settings to the path created in step 1 (just entering the path in the first place ended up with an error-message like "can not acces the path")

    The result:
    Attachments now download to the external SD-card when clicking on an attachment in the list.
    BUT: ZotDroid throws an error message that says "no app aviable to open attachment". So I can not open/read the pdf-file from ZotDroid. However, when I open the folder with my filemanager (Amaze) I can see the attached file and open it with e.g. Adobe Acrobat for pdf. Acrobat asks the first time for permission to access Mediadata and than opens the file. With an html attachment I tried to open in Firefox I had less luck. As Acrobat with pdf Firefox first asks to allow the app access to data what I allowed but than it still says "no access". Maybe it is because Zotero stores the linked content of an html page (images,...) in a separate sub-folder?
  • Hello there
    Using the default preference widgets in Android is quite un-userfriendly for this. Ideally a tree like directory structure should appear but such a widget doesn't exist in the standard Android toolkit which is a damn shame, and a bit of an oversight I think.

    HTML attachments are a real pain - I've tried to open snapshots before and it doesn't work. Sadly, I don't think there is a way to make them work on Android. I've not found an answer to that which sucks as I use Zotero as an alternative to instapaper these days.

    The path you mention doesn't seem right to me. Typically the sdcard is mounted somewhere like /external or /sdcard or similar. In simulation it appears to work but again, the only device I have is a Nexus 10.

    Zotdroid hands over to Android when opening a PDF so the PDF must be associated with an application. However, I suspect this is not the problem.

    Zotero storage seems to be the common factor here, along with the external SD card (which is a real card and not a simulated one). When you browse the attachment in Amaze, what precisely is the path in question?

    B
  • HI Ben,

    thanks for looking into my problem!

    the path zotdroid stores attachments after I did what I explicated in my post above is:

    /storage/0000-0000/Android/data/computer.benjamin.zotdr0id/attachments

    The program "my own files" (in German version "Eigene Dateien") that was preinstalled shows the path as

    SD-Karte/Android/data/computer.benjamin.zotdr0id/attachments

    but the first part seems to me a "user friendly" translation of the real path that is what Amaze shows.


    I also tried to find out in the users instructions of my Galaxy Tab S3 about the use of my SDcard as "external" (formatted by Android) and "removable" mentioned by @smatthie. I did not found any information on that and I also can not remember that I was asked by the system at the first insert of the SDcard. So I can not test, if the problem can be solved by reformatting and integrating the SDcard as "external" card. Maybe Google dropped that function in Android 8.0?
  • Ben,
    New to Zotero, ZotDroid &c.
    I'm using ZotDroid on a recent Kindle Fire (side-loaded from the Play Store) with copious storage. It all seems to work as intended.
    Reading through this thread, you seem to be saying that reading a .pdf on the KF, taking notes, and pushing them back to Zotero via ZotDroid has vas technical hurdles.
    But I was able to create a note for an entry in Zotero and have the note sync down to ZotDroid, which is better than nought.
    Thanks for doing the Droid coding so that we don't have to!
    Cheers,
    Chris
  • Hi,
    My current workflow on PC works with linked PDF files to a Onedrive folder, using the base folder path. This work flawless to sync between PC's. I also can syn the same folder to the SD with no issues. The file path can be seen even in the Zotero web in my library, as attachment:Relative_path_to_the_file, as also is done in zotero.sqlite

    I know that this has been asked months ago, but several updates have come afterwards. It is expected to support this workflow anytime? It seems to me that this workflow should be even easier to support, with no attachment sync to worry about, only adding a setting for the base path in the Android device.

    I know that is not the workflow of the developer, but that workflow has also being asked for in this forum (and for other previous Android apps), so I don't think is a niche case. Since the app it's not longer open source, no help can be provided.

    If not, is there any workaround? I tried putting the path of my synchronised folder in "Download location" and ask for sync of attachments, but it kept syncing forever with no message. After trying to change the database folder, the app couldn't start again, so I uninstalled it, but since I was still in the first hours, reimbursed me the cost, and if I buy and install again, I won't be able to ask for another reimbursement if I'm not able to make it work for me.

    I would pay even more money if linked files with base folder are supported, even if adding it from the app wouldn't be supported ever. I only would like to be able to search into my zotero database and open the pdf's to read and annotate from my tablet.
  • Hi @OniDaito,
    Small niggle (might just be me...) but clicking 'Sync with zotero' doesn't work for me, only way to update library is to 'Reset and sync' each time. Not a major issue, but thought you might like to know.
    Cheers
  • edited today at 1:13am
    I followed the instructions of Olaf and created the same path on the sd card, which is entered in zotdroid downloads location as:

    /storage/0000-0000/Android/data/computer.benjamin.zotdr0id/

    I used ES File Explorer rather than Amaze. The specific program probably doesn't matter so long as you can create files and see the path.

    This worked. Zotdroid now saves attachments to the sd card and the Download all attachments function seems to operate smoothly. Granted I have not let it download all 11gbs of attachments in my library. This is because I have run into the same problem as olaf. Zotdroid cannot unzip and open the files. One gets the error: No program available to open this attachment. I can go through ES file to unzip and open them, but obviously this isn't helpful since I cannot search and open them through Zotdroid.

    Regarding Javinp's comment, my library is saved through Pcloud. Currently they do not provide the option of placing offline files on the sd card, but a representative tells me it is in the works.
Sign In or Register to comment.