Systematic crash of libreOffice


I've got libreOffice under Ubuntu installed with Firefox 50.1.0 and the Zotero-firefox Plugin installed.

Unfortunately LibreOffice systematically crashes when I a add more than a few words to a citation (in "prefix" for example) or sometimes adding more than one source to a citation..normally working lasts only a few minutes until it crashes.

Tried Solutions:
1) I already played with JRE-Versions, but it seems my libreOffice recognizes only the normal "Oracle 1.8.0_111" (=OpenJDK 8), a test with OpenJDK 9 was not recognized by libreOffice

2) I also tried the Zotero StandAlone, but it didn't change anything.

Error messages:
Started in a shell libreOffice gave me the following output (/stdout):
1) "Gtk-CRITICAL **: gtk_grid_attach: assertion 'GTK_IS_GRID (grid)' failed" (this was at starting libreOffice, not yet doing anything with zoter)
2) "Gtk-CRITICAL **: gtk_container_foreach: assertion 'GTK_IS_CONTAINER (container)' failed" (this was when libreOffice crashed)

I would really appreciate your help since I wanted to begin writing my PhD :-(

  • Which Ubuntu version is this and is this the Ubuntu-packaged LO or an install from LO-proper?
  • edited January 19, 2017
    And anything unusual in your system? Some GTK configuration or the like? This error appears to occasionally pop up for LibreOffice (unrelated to Zotero in previous cases, afaik), never with a very clear solution/explanation
  • Its ubuntu 16.10 and I forgot to mention that I updated LibreOffice in order to avoid these crashes, so I added the "" packet source.

    However nothing unusual, I didn't do anything with GTK
  • Also experiencing this. It's making it nearly unusable for me. I am on ubuntu 16.04, ubuntu packaged libreoffice and firefox.

    I am using the zotero firefox plugin. I also have zotfile and zutilo installed. Disabling zotfile seems to help, but the problem still happens. I get it when inserting citations with more than one or two items, but not always.

    I will post back when I can get a reproducible one that I can get an error message from.
  • Oh, actually. Mine doesn't crash. It locks up at a particular point (about 75%) of the inserting citation progress bar. I need to kill both firefox and LO manually before I can continue.
  • Is that in a large document or any document?
  • I've been getting it since I've been working on a particular document, which is quite large, yes. 35 Pages long ~150k text only. I hadn't really had it before much if at all. Wasn't sure if its the document or an update that's come through in the meantime.
  • I have the same problem but with Mac OS 10.11.5. I run LibreOffice and Zotero (stand alone). Very often, when inserting one or several references, the insertion progress bar freezes at about 75%; and both Zotero and LibreOffice freeze. I have to force-quit them. Also happens (sometimes) when editing an existing reference. Makes it totally impossible to work on that paper.
  • Same problem, LibreOffice freezes when I add a citation. Mac OS 10.12.3, LibreOffice, Zotero The insertion progress bar freezes at about 75%. Didn't do that for the first several citations, now it does it every time. Have to force-quit LibreOffice. Document is only 56k, text only, kept in dropbox. Does it have to do with updating the bibliography?
  • Hello!

    I guess this ( is something similar. Libreoffice 5.2 crashes continuously, even on empty document, no crash at all with With new version of Libreoffice 5.3, if openGL is on, crashes are not so regular, but still they happens always at some point. So, this is not a solution.
  • There's a fix out for the crashing in Zotero 5.0 Beta. Read the forum post as there might be some caveats to the upgrade.
  • That's quite strange. I tried to install today Zotero 5.0 beta stand alone with Libreoffice 5.3 RC1. I was able to reproduce crash of Libreoffice when I tried to insert new entry after inserting Bibliography index, but I was not able to reproduce crash on inserting new entries before inserting bibliography. I had to kill Firefox and Libreoffice to be able to work again with Zotero standalone.

    The strangest thing is that I was not able to reproduce Libreoffice 5.2 (used in production) crash after above mentioned procedure. Probably it's because I updated Zotero extension in Libreoffice to 5.0.0 beta ( In Firefox it shows 3.5.12.r10160 updated today. At the moment everything works, no crash. I can insert, change entries and update bibliographies.

    So, it seems the solution is to install this libreoffice plugin
  • For the record, we have not updated the .xpi that you are linking to, so it may be by luck that you are not getting the crash in some other environment. Also, this only affects Linux.
  • I'll try on other computers in our office. Installation of newer plug-in solved for me problem reported here

    Anyway, I'm happy and thanks to developers! Really, there is no alternatives for Zotero :)
  • I am encountering the same problems as stated here and there:

    Installing Zotero 5 Beta and its Libre Office Plugin did not solve the issue. Libre Office still freezes when e.g. Zotero is not running or when I try to create a bibliography in a master document.

    Libre Office is
    Zotero is 5.0-beta.202+ddc9989
    OSX 10.11.6

  • @lorenzguitar You are likely experiencing a known Zotero bug with OSX and LO where it fails to display warning dialogues. There's little we can do about this as it's a LibreOffice bug, although there might be a workaround eventually.
  • @adomasven That seems to be it, yes. If I hit enter first a new window will appear (completely white). If I hit enter then I can continue editing the document and after a few seconds a complete Warning Window will appear telling me that LO cannot communicate with Zotero. I can not get rid of this window though but I can get several of them if I continue to use the Zotero Plugin.

    Thank you!
  • Hi,

    I can reproduce a freeze of LibreOffice ( + Zotero Standalone + MacOSX 10.11.6) when I change the citation style of an existing document in the Zotero preferences.
  • Zotero Standalone with LO on Windows 10 LTSB. No issues whatsoever. I noticed somewhat weird/inconsistent behavior on my colleague machine, and he's using Libre Office from the "fresh" branch, whereas I stick to the stable "still" builds. Probably this might be a case, give it a try on older/stable version of LO.
  • @andselisk
    following your advice I downgraded to the stable version of LO (on Mac OSX) but I observe the same freeze-problem when changing the citation style.

  • @azautne
    I wish I had more experience with macOS, but I'm afraid I won't be that helpful for you as I've never dealt with macOS for production (shame on me).

    Just a lame idea though: if I would have some free time, I probably try to run Zotero in a virtual machine environment, say, some Linux flavor, connected with your current Data Directory, and see how LO will behave on a different rig. At least you can tell then whether it's your OS fault or not.
  • edited June 9, 2017
    adomasven explains this immediately above — there's a known issue on macOS where alerts aren't properly shown, which makes it look like it's freezing. You may be able to press Enter or Esc to close the hidden dialog.
  • @andselisk

    I have a notebook running Linux Mint 17.3. here I observe the same bug.
    As mentioned above the system does not freeze but it gives out an error message:

    An error occurred communicating with Zotero: End of content node doesn't have the proper start node
    at Method)
    at com.sun.proxy.$Proxy52.createTextCursorByRange(Unknown Source)
    'An error occurred communicating with Zotero: End of content node doesn't have the proper start node
    at Method)
    at com.sun.proxy.$Proxy52.createTextCursorByRange(Unknown Source)

    Pressing ESC closes the error message and LO is still running stable.
    I have installed Zotero standalone V4.0.29.10 and LO on my Linux Laptop.
    I hope this help to solve the problem.
  • edited June 9, 2017
    *.sun.* and *.java.* strings are kinda suggesting there might be something wrong with JRE installation, or its version, which can confuse LO. Just for the record, I use JDK8 (8.0.131 to be precise) installed from chocolatey repo on my Windows 10 laptop, and I've never seen the related error. I'm not a programmer by any means, I'm just guessing, so don't quote me on that:)
  • @andselisk

    On my Linux notebook the most recent java version JDK8 was installed.
    I tried reproduce the bug in a new odt document and... it works (!)... no error.
    Thus the must be something special with the particular odt file.
    Maybe I can upload my file somewere for some deeper bug research.

    On my MacBook Java 8 Update 131 is also installed due to the system settings. But LO still uses version JDK 1.7.0_45. So far I am unable to locate jdk1.8.0_131.jdk.
    Due to some "startpaging" it should be there:
    but it is not.
  • @azautne
    How interesting. My LO uses 1.8.0_131 JRE exclusively. Probably you could try to get rid of all installed java versions (`sudo apt-get purge openjdk*` for Linux Mint, I think), and explicitly install the latest one, and then check whether LO catches up.

    Regarding older *.odt -- I've seen some pretty messed-up heavily-formatted Writer documents, but Zotero always manages to work nicely with them (just sharing my experience).
  • Hi there, Ubuntu 16.04, LOffice, zotero Same here, crash problem when i select "insert citation". It happens the last week. Is a stable solution possible (future update) or is it better to choose another edition of libre office (or go for mic office)?
Sign In or Register to comment.