Libreoffice 5.2.5 Writer crashes on inserting Zotero citations

edited February 5, 2017
I'm using latest Zotero extension ( for Firefox (51.0.1) with Libreoffice extension (3.5.12) in Libreoffice 5.3.0 and 5.2.5. The system is Ubuntu 16.04, 64 bit with openjdk-8-jre from Ubuntu repositories.
Recently I realized that it is nearly impossible to use Zotero, it randomly crash Libreoffice on inserting of single reference and nearly constantly crashes, when inserting several references.

I have this problem on all computers in office having Ubuntu 16.04 64 bit and Libreoffice 5.2.x.

I tried to install Oracle java, but it didn't change anything. I tried stand alone Zotero and there is no difference from Firefox extension. But there are no problems with 4.1.3. I tried to go back to Libreoffice 5.1.6, but it also crashes on inserting citations. No problems with windows 7 with the same set of programs

Steps to Reproduce:
1.Install Zotero add-on for Libreoffice
2.Start new Writer document
3.Press Insert citation in Zotero toolbar.
4.Select any Citation Style and press ok
5.Select 2 or more citations
6.Press enter or OK in clasic dialogue to insert citation
7.If Libreoffice do not crash try one more time with more citations

After pressing OK or enter to insert citation Libreoffice usually crashes and it can be recovered only by kill command. Firefox also can be restarted only by kill command.

I tried to reset user profile and reinstall extensions, but it doesn't change the situation.

Any help would be welcome.

I posted this also in Libreoffice bug tracker
  • We are aware of instabilities with recent versions of LibreOffice on Linux and MacOS. There have been no Zotero LibreOffice plugin changes for a couple of years, so this is something on LO end of things.

    Thanks for posting the bug to LibreOffice tracker.
  • Unfortunately there are no progress in Libreoffice bug tracker. Can anybody provide a recommendation on how to identify the source of the problem?
  • This might sound ridiculous, but have you tried pressing [Esc] when LibreOffice appears to be frozen with the window in focus? There is a bug with MacOS version of LibreOffice which fails to display prompts, but they still freeze the process until dismissed, which can be done with [Esc]. There is a bug registered for this on LibreOffice bug tracker, but it hasn't seen much attention either.
  • These issues might have the same origin, but in my case Libreoffice process just disappears,leaving inactive recovery window and quickstarter with the message "futex_wait_queue_me" in system monitor. /the process can be only closed by kill command.
  • Oh right, sorry, you're on Ubuntu. This might be different then. My machine seems to work very reliably with Ubuntu 16.10 and LO and openjdk-8-jre.

    I don't think Debug Output will contain a lot of useful information, but if you can produce a Debug ID for an operation that breaks LO we will take a look. If Firefox/Zotero is unresponsive after you get the LO issue, you could instead perform Real-Time Debug Output logging, paste it in a secret gist and email the gist url along with a link to this thread to

    Another thing that might be worth investigating is adding tables and figures with captions in LO, using those captions in-text and seeing if you get any crashing. If you did it would indicate that the problem is with LO and/or JRE.
  • Regarding the last comment, writer crashes even with empty document. At the moment it is 100% or close to that crash on any attempt to insert Zotero citation in any document. It happens on all installations with Ubuntu 16.04 64 bit and default jre.

    I would be thankful for more detailed instructions on how to do Real-Time Debug Output logging.
  • I activated Debug Output Logging in Zotero preferences and sent report to Zotero server. The Debug ID is D1581961993
  • I am afraid that there is little that we will be able to offer on our end. From the debug output it seems that everything works fine and without serious hiccups or slowdowns up until the point, where libreoffice simply crashes. What's worse is that it isn't consistently reproducible.

    I am currently investigating a different bug with libreoffice that seems to consistently crash it, which is related to unicode characters in citation text and field codes. I will ping this thread once I have got to the bottom of that, as it might fix this too, or at least give me a better idea about why this could be happening.
  • edited April 28, 2017
    Beta.185 will be out shortly with a bugfix for the crashing. Let us know if it's still happening.

    Edit: This is with Zotero 5.0 Beta, which you will have to upgrade to to see the fix. Read the forum post as there might be some caveats to the upgrade.
  • Thank you for great news!
  • @andisl, have you tried Zotero 5.0, and has it prevented the LibreOffice crashes?
  • Hi, Zotero 5 doesn't change result. However, everything works with dev version of libreoffice plugin.
  • What version of Zotero 5 are you running? If you look in LibreOffice under Tools -> Extension Manager, what version of Zotero Integration is listed?
  • I used stand alone version 5.0-beta.185+32b1769
  • Update to the last beta.
  • Hello!
    For the reported issue it doesn't matter, which version of Zotero is used. Libreoffice plugin makes sense. I do not have crashes with plugiv version 3.5.12.r101160.
  • For the reported issue it doesn't matter, which version of Zotero is used.
    Yes it does. The plugin is bundled with Zotero, and you're on a very outdated version of the beta with an older plugin version.
  • With 5.0-beta.215+2f9306598 I was not able to repeat crash with Libreoffice 5.4 beta 2, 64 bit Ubuntu 16.04. However, I'm not able to do full check, because I can't insert bibliography in the document. It returns error message: "Zotero experienced an error updating your document. (new Zotero.Integration.Document(...))[command] is not a function"
  • It would be much easier if somebody could share direct download links for recent versions of zotero development builds.
  • I'm not sure what you're referring to. 215 is the latest 5.0 Beta build and has the latest LibreOffice plugin version.
    Zotero experienced an error updating your document
    Since — as I understand it — you're no longer seeing the crashing, you'd want to just start here for further document errors: Debugging Broken Documents
  • Sorry for misleading comments!
    I just wanted to say that I can't fully check if the error still persist in 215 built, because it do not insert bibliography in any document (returns above-mentioned error message) and I can't check if crashes returns after inserting bibliography.

    To be able to work we are now using in our team Zotero Firefox add-on and 3.5.12.r10160 Libreoffice plug-in (Libreoffice 5.2.7). In Libreoffice plug-in version is marked as 5.0.0. I don't know if it is good or bad, but it works fine.
  • @andisl the combination of Zotero 4.0 and the LibreOffice plugin 5.0.0 should work fine, but we'd appreciate it if you could generate a Report ID with Zotero 5.0 for the error you were seeing when trying to insert the bibliography.
  • I switched to the (currently beta) 5.0 version of the LibreOffice integration plugin, and LibreOffice stopped crashing when I insert a citation. Using latest Zotero 4.0.x and LibreOffice 5.3.x on Linux.
  • Unfortunately, I have the same kind of trouble. today, whatever I am trying to do with Zotero when in LibreOffice, libreoffice crashes : simply disappears! I generated a Report ID here : 410798327

    I will try to install Zotero beta 5.0.
  • I updated libreoffice to version and installed Zotero 5.0-beta.217+38652f936
    At this time, it seems to work - at least, libreoffice does not crash whenever I try to do something with Zotero.
  • To summarize workaround that we are using in our office to get Zotero to work. The most of the systems are Ubuntu 16.04 64 bit with Libreoffice 5.2.7 and the recent updated Firefox version.
    We install recent version of Zotero (now it is, then we install Zotero LibreOffice Integration development built (it shows 3.5.12.r10160, I don't know is it important, which version of the plugin is installed, probably it doesn't matter at all), then we take Zotero plugin .oxt installation file from development branch in git (version 5.0.0, later versions for some reasons are not able to insert bibliographies in our case) and install it directly in Libreoffice addon manager.
    Now we have fully working Zotero and benefits from having it as extension in Firefox.
  • I kept having the same crashing problem, I think ever since i move to Ubuntu 16.04. So now I just updated to Libreoffice 5.4.62 and I am on Zotero 5.0.44. Still crashes everytime I try and use zotero in Libreoffice.
  • It is probably another issue. We moved our office to Libreoffice 5.4.x and 6.0.x + Zotero 5.0.x and up to now it works very well. We have Ubuntu Mate 16.04.4 64 bit. However I regenerated all Zotero and Libreoffice profiles at the end.
  • Oh, I just installed Libreoffice and zotero seems to work again !
  • No, it only worked for a day, now Libreoffice crashes again everytime I try to use the zotero plugin
Sign In or Register to comment.