Zotero overrides styles of citations in Word (always Times New Roman)

  • rontiveros, I cannot make your solution work. In particular, I am using a style sheet for a conference paper, and every time I do "Zotero Refresh", the indentation reverts from the desired 0.14" (I suspect the style sheet specifies that in mm) to 0.5".

    I tried editing both the 'Endnote' and the 'Endnote Text' styles. I can select my bibliography and manually choose either of these styles, but the moment I refresh, it reverts.

    So here's another vote for Rubos' suggestion:
    "I still think a better way would be to have an option to use the current style of the paragraph where the bibliography is to be inserted." Modern word processors use styles, why shouldn't Zotero?

    Details: I'm using Word 2003 (I loathe Word 2007) in Windows Vista. Zotero 2.0.2.
  • Hi,

    I have a similar problem: Most in text citations appear in the right format/font (Arial, set as default), but the bibliography and some citations appear in a different font (Times New Roman). As far as I can tell, the wrong formatting affects only those citations with Chinese characters (since multiple language versions of a field have not been implemented into Zotero yet, I have to use Chinese characters and the Latin letters together in one field; eg. author: "鲁迅 Lu Xun"). Therefore, if the Chinese characters are the root of evil, this might also be the reason for the wrong format in the bibliography, because it logically also includes Chinese characters.

    Since this is not affecting all citations: Could this have something to do with the different Asian font which each default style defines separately (usually SimSun)? But why are the Non-Asian characters changed, too? Can anyone offer a solution?

    Is this maybe a hint at why the problem occurs for the others Zotero users as well?

    BTW: I’m using Word 2007, WinXP, Zotero 2.0.2.
  • I just realized that the problem only occurs on bibliographic entries with more than one author or editor. In-text citations on sources with only one Chinese author are still in the right format. This is also the case for citations with multiple sources (if none of them has multiple authors/editors).
  • Mac 10.6.4
    Word 2008
    Latest version of Firefox and Zotero.

    I report the same issue:

    The bibliography is in Times New Roman, even though the style for normal text is Garamond. I can manually change it, but the typeface changes to Times New Roman when I do a refresh in the Zotero menu. Other format options seem to be correct.
  • ulrich, can you reproduce this in a new document?
  • Good point, I only managed to reproduce the error for double line formatting (not mentioned above). Typeface was correct.
  • Non-persistence of line formatting is a known issue. On each update, the bibliography format is replaced with the format specified by the style. There are a couple of outstanding tickets that should take care of this (current target is Zotero 2.1). Any font issues are separate—at this point, all plug-ins ought to handle fonts properly. If you are seeing font issues in your existing document, you can email it (or an excerpt sufficient to reproduce the issue) to support@zot...org and we'll try to track down the bug.
  • I would like to add that in regards to the Times New Roman problem I have noticed some inconsistent behavior (WinWord 2007).

    New document. Insert a single citation. Set the font at the end of the document to e.g. Arial. Insert bibliography there. The resulting bibliography is in Arial as expected.

    Insert addiditional 60-80 (?) citations. Resulting bibliography stays in Arial. Press Zotero Refresh. Bibliography reverts to Times New Roman.

    Maybe it has something to do with the amount of actions in the Undo stack in Word.
  • Hi ALL,

    as I have the same problem with switching from Arial to TNR after refreshing (Windows XP and Office 2007), I had also the feeling that it might be connected with the number of included references. And so today I tested this by inserting blocks of 10 references with separate saving the files and permanent refreshing and checking.
    With 20 references everything is fine.
    But with 30 references after refreshing the bibliography turned from Arial to TNR!
    Than I refined bedween 20 and 30 references:
    Exactly after inserting the 26th reference, the problem occurs!!! With 25 references everything is fine anyway.
    I could reproduce this 3 times so it looks to be reproducible.

    I hope this will help to solve the problem!!!

    Any feedback if others are also able to reproduce this is appreciated!
  • Just curious: does the 26th reference cause the bibliography to span more than 1 page?
  • No. The 25th reference just let start the 3rd bibliography page. So the 26th is next on the already existing 3rd bib. page.
    Did you try to reproduce?
  • I've got the same problem of losing formatting on refresh.

    Windows 7
    Word 2010
    Firefox 3.6.12
    Zotero 2.0.9
  • See my post above. We have changed the way bibliography styling works for Zotero 2.1, currently in beta, but we do not plan on making any further revisions for 2.0.
  • I have encountered this problem using Word 2007, Firefox 3.6.9. I changed the default font in Word but this only works now for new footnotes that I'm inserting, even if I refresh the old ones. But there is an easy fix which I thought I'd share: in Word, you can find and replace the font.
  • I have been having the same problem and think I have discovered a work-around (Zotero 2.1.8, Word 2010, Firefox 5.0). Select the paragraph mark at the end of an offending citation, right-click and select style. Change the font or select modify to alter other formatting problems.
    Tp preserve the change in new in subsequent documents based on the same template, select "new documents based on this document" in the 'modify' pane.
  • Hello there,

    I am still having the same problem and it is quite boring...All the text is in font size 11 and then the bibliography is in 12!!
    Is this so difficult to fix? Please help...
  • No, it's not. Change the bibliography style in your word processor.
  • For instructions see here: http://www.zotero.org/support/kb/word_default_font
  • Thanks
    However, I cannot see any bibliography style in my word processor...
    If I change the format as suggested in the link above and then hit refresh in zotero, things go back to font size 12!

    Thank you
  • The style is almost certainly there - did you find the other formatting styles in Word?
  • Hi,

    well I guess I did. I am quite experienced in word and when I write I always use styles. The style should be called "bibliography"? May that be because my MS Office is in Italian?
  • edited October 15, 2011
    Then the style is likely called something equivalent in Italian - just check which style is applied to the bibliography and modify it.
  • It seems to work right now.
    I have actually created a style called bibliography (in English) and applied to the reference list. If I refresh zotero now, things remain like I set them

    Thank everybody!

  • Hello there,
    things are still pretty wrong here.
    I have closed the document, reopened and the former "bibliography" style is not applied to the reference list anymore.
    Actually, if I modify the style and refresh with zotero, it creates and applies a new style to the reference list, discarding the one I have modified. The new style is called in an odd manner, kind of "12pt, After: 0 pt...."
    This is annoying... :(
  • My workaround:

    Windows 7
    Zotero 3.0b3.2

    First, regardless of citation style, use Zotero fields instead of bookmarks. Bookmarks ignore all Word styles and default to Word default paragraph fonts.

    Using Zotero fields uses footnote text and Bibliography styles which you can edit.

    But here is the confusion. Let's use footnote as an example. Changing the footnote style will not change the Zotero footnote on the page. Here is how you do it.

    1. Highlight all footnotes and click on the new 'footnote text' style you have designed. It will get rid of your italics and other citation formatting. Don't worry; we'll get them back in a second.

    2. Now refresh from the Zotero add-in section. It should remember the new style and add the citation formatting.

    3. All new citations should now be in your style. Just remember, if you change the style, Zotero will not notice; you would have to change the style, then individually highlight all footnotes and click on the Word style button again.

    Hope that helps, especially any programmers who might spot where in the code Zotero is missing the update.
  • This last one by jvleis. Nice. Saved me hours of heartache.
  • I found a solution! The following instructions will allow you to format your citations differently from the main text in Word. Even after Zotero (re)inserts the citation. It will prevent Zotero from overriding or resetting the styles applied to your citations.

    To do this you will have to create two new Word styles. One for the citations, and one for the main text. In our example we will have black text and grey citations.

    Making two new styles:

    • The Citation Style

      1. Press Alt + Ctrl + Shift + S to open the Styles window

      2. In the bottom left corner select the "Create a Style"-button

      3. Name the citations style, like Grey Citations Paragraph

      4. Now you'll have to select Paragraph from the drop down menu as your Style Type

      5. The style can be based on any you like, but you probably want to go with Standard

      6. As the Style for following paragraph, you want to select the Grey Citations Paragraph (or your alternative & cooler name)

      7. Underneath you can format the text whatever you'd like your citations to look like. I will simply change the automatic colour to something grey

      8. After changing the formatting to your liking, press OK

      9. Keep the Styles window open

    • The Normal Text Style

      1. Again: In the bottom left corner select the "Create a Style"-button

      2. Give this one a plain name, like John or Inline Black

      3. No you'll have to select Character

      4. This will grey out the last drop-down menu (Style for following paragraph) making your life easier!

      5. In the one but last Style based on field, you will probably want to stick to Standard

      6. Underneath you can format the text whatever you'd like your normal text to look like. I only change the automatic colour to black

    • These two newly created styles are the foundation of this work around. Creating them was the most difficult part.

    • How to use these styles

      1. Whenever you start a new paragraph after a heading -- or text that had a different style -- or in a new document, go to the Start tab in Word

      2. Before you start typing, you have to select your Citations Paragraph style from the Styles frame on the left side of the ribbon

      3. Type a few words and select the whole paragraph with your mouse

      4. Once that is selected, return to the Styles frame and select the Inline Black style

      5. If you selected the whole paragraph earlier -- that happens when the highlight of the selection goes beyond the last character -- whatever you type now will come out in black

      6. Whenever you click on the Add/Edit citation button in the Zotero tab and insert a Citation, the citation will be formatted in the Citations Paragraph style instead of the Inline Black one.

      7. Repeat this after every heading or text element that has a different style.

    This should fix it. All the new citations you insert, all of them will automatically -- until you add a new heading -- be styled accourding to your predefined Grey Citations Paragraph style. This style can be always modified later on.
Sign In or Register to comment.