Zotero overrides styles of citations in Word (always Times New Roman)

I'm using Zotero 1.5 Beta and the Word for Mac 2008 alpha plugin (I'm running the most recent versions of Leopard, Word, and Zotero; all just freshly installed). When I add citations, they do not take on the formatting style of the surrounding text. This is true in footnotes and bibliography. When I block the text and then change the style to match the surrounding text, that works only temporarily. As soon as I use Zotero's "refresh", it all reverts back to Time Roman. In the footnotes, this is even worse, because changing the style eliminates all italics.

This seems such a fundamental problem, that I spent quite a bit of time searching the documentation and forum for an answer to this, but I've not seen others with this problem.
  • http://forums.zotero.org/discussion/4814/
  • Thanks for the quick reply, but neither of those posts solves my problem. I'm using styles already, with Arial 11 pt as the setting for the default font in the "Normal" template and style. When I insert either a footnote or bibliography, Zotero overrides -- "manually", as it were -- the style with Times New Roman. When I click on the text, it shows up as have the correct style (with Arial font) but font is indicated to be Arial. When I apply my intended style to the text, it changes to Arial, but everything reverts to Times New Roman when I press refresh.
  • I have the same problem.
  • Perhaps someone could clarify whether this is a Mac problem? I'm amazed that more people aren't complaining about it.
  • I'm on Mac 10.5.6; could be
  • edited April 8, 2009
    You may want to double check. I don't author on the mac, but documents authored on Linux/Windows work fine on the Mac for me if I modify the "default" style. The plugin seems to have nothing to re-write the default style.
  • My "normal" font is Garamond. However, when inserting citations, the text in the footnotes turn to Times New Roman instead.
  • I can't reproduce this in Word 2004 with the alpha plugin for 1.5b2 on OS X.5.2.

    I add a reference and generate a bibliography. If I click on the bibliography, the style in the formatting palette is 'Norma l+ Left: 0", Hanging: 0.27"'. If I click on the dropdown & select "modify style," I am able to change the font & select "automatically update." The font changes in the bibliography; the style name stays the same. If I insert another reference or regenerate the bibliography, the style name stays the same & so does the font.

    Again, I see no way in the code for Zotero to modify styles. So, please make sure you're changing styles in the correct way in your Word document.
  • I'm on Word 2008.

    I add a reference. The citation in the footnoteis in Times New Roman, even though the style for footnote text is Garamond. If I write text outside of the citation in the footnote, that text comes out as it should in Garamond.

    If I do a "edit/select all" on the footnotes and then manually change type to Garamond in all the notes, the typeface changes to Times New Roman when I do a refresh in the Zotero menu.

    Another thing: while citations in the notes are overriding the style for footnote text in the manner described above (Times N.R. instead of Garamond), "ibid" comes out according to style (i.e., Garamond). Strange, innit?
  • This problem seems to be persisting, even with Zotero 2.0. I've just updated everything now, and the problem repeats:

    In Word 2008 for Mac, I use a style for text and footnote with Verdana as the font. If I use author:date, the text of the citations matches the rest of the text (Verdana). If I modify document preferences to a citation format that uses a footnote, the text changes to Times New Roman -- except, as noted, the "ibid". The bibliography is then also in Times New Roman. If I manually change it to Verdana, the Zotero citation text reverts to Times New Roman when I "refresh".

    It seems like the specificity of the problem -- especially the clues about "ibid" and footnote/main text -- would make this solvable. Any ideas?

    Mac OS 10.5.7
    Zotero 2.0
    Word 2008 (12.1.7)
    Firefox 3.0.10
  • I use microsoft word 2007 on windows vista and have the same problem. Any advice would be greatly appreciated!
  • edited June 16, 2009
    I have the same problem. The text inserted by zotero is somehow using the default style (according to the format bar), and not the style applied to the current section. I have custom styles mandated by a journal, so changing "default" won't work... I _have_ to use the journal style (including the name - "References_WIREs").

    If I re-apply the journal's style, I lose hanging indents. These indents work, along with fonts, etc. using this style in OpenOffice / NeoOffice on the same machine. But since I'm collaborating with someone, using fields saves a lot of headaches - so I'd rather use word (at least for now).

    Note also that the zotero plugin on mac word 2008 uses applescript, not the VB stuff. Don't know if that matters (or even how to look at that code - where is it?).
  • I'm using Word 2007 on Windows Vista and have the same problem. Every time I add a new annotation or refresh the current ones my formatting reverts to 12 point Times New Roman. Very frustrating.
  • alevisohn - note that you can get around this by changing the "default" style to whatever you want it to be - unfortunately not a solution for davclark - but for most people this should do.
    Which isn't to say that this is desirable behavior. Note that the plugins are mostly beta, some even alpha or experimental, so a lot of things will improve still. I've seen Dan mention updated plugins here a number of times, so those will be coming reasonably soon - I don't know, though, if they'll address this issue.
  • He everybody,

    are there any news on that problem? Just for information. I had that problem also with Plugin 1.0.xx. But after a while it work fine. Unfortunately with version 2.xx the problem came back

    Greets zotomat
  • any reason the typical solution - changing the default style - doesn't work for you?
  • It doesn't work for me either. I'm using word2007
  • What citation style are you using?
  • it doesn't seem to be dependent on citation style.

    I've tried
    Journal of Ecology

    to name a few
  • I am using "Water Research". Does that matter?
  • once again - are you trying to modify the default style in Word?
  • Yes the default style in Word is "Standard" and the font is Charter and not Times. The Bibliography arrives in Times. Change of the "Standard" Format doesn't help. When I change the default style to another then "Standard" and click in "update bibliography" then Word crashes.

    Any Ideas?

  • Changing the default style doesn't help for me either.
  • this is rather puzzling. Zotero needs to take that information from somewhere - and "Times New Roman" is afaik nowhere in the Zotero code and it most certainly isn't in either csl or the styles.
    So my best guess is still that somewhere TNR is defined as a default - but obviously I can't say for sure. It's been a while since I've worked with Word, so I can't easily give you detailed instructions, but maybe someone else can think of something.
  • I am having a related problem with this behaviour of the plugin between Word 2003 and Word 2007 on WinXP where the "default" override of the style is being applied inconsistently:

    I believe that adding support for a new parameter in CSL files to "keep-current-style" would help resolve this bug for all.

    Currently on 2.0b7.4.
  • I looked at the source codes quickly and found that the way Zotero does the integration with MS Word is by using an RTF-formatted bibliography string. In the content/zotero/xpcom/csl.js the Zotero.CSL.prototype.formatBibliography function uses TNR within the preamble string.

    Anyway, it appears to me that Word 2003 and Word 2007 differ from each other. In my case Word 2007 applies the TNR from the given RTF with the before- and after- paragraph spacing overwritten to 0 whereas Word 2003 uses the default paragraph style.

    BTW, for the font itself there is a way to specify a desired font through the font-family attribute that you can put for example in a group element in the CSL file. I still think a better way would be to have an option to use the current style of the paragraph where the bibliography is to be inserted.
  • Ultimately I would like to set the font style and size (and line spacing) in for instance the edit bibliography menu. These things are not at all CSL-dependent. I am currently writing on two documents with the same style but with different font sizes in the document.
  • edited October 21, 2009
    I still think a better way would be to have an option to use the current style of the paragraph where the bibliography is to be inserted.
    +1. I think it would make sense to do this by default.
  • I have the same problem in Word 2003 on Windows. And changing the "Normal" font is not a nice option when preparing a manuscript, since many other styles (defined by publisher) depend on it.
  • I figured out a solution!

    You can find it here:

    Look for the post by "Jay Freedman" on 8/16/2008 at 8:44am. If you're working with Endnote you'll need to do what he says but to the "Endnote" style rather than the "Footnote." It works!
Sign In or Register to comment.