ZotFile - Advanced PDF management for Zotero

  • Another tablet question. My zotero folder is ~10K items, 666MB sql file and ~20GB for the zotero folder (lots of pdfs). I can install zotero standalone on the windows 8 tablet but don't have enough space to move the whole zotero folder there. How can I work it so I have some of the pdfs (~5gb) on the tablet for annotation and the rest of the zotero folder stays my laptop?
  • edited September 28, 2013
    depends on your set-up. How are you planning to get the PDFs onto the tablet in the first place?
  • Not sure, whatever works. 'Til now I've been using an ipad and pdfexpert. Zotfile sends them to pdfexpert and fetches them after annotation. Now with a windows tablet I'm not sure what app/program equivalent to pdfexpert I would use instead, or the most zotero-friendly way to get them to the tablet. Or do I just copy them independently of zotero? Questions would help me clarify.
  • You can obviously just keep working with the send-to-tablet feature of Zotfile - though as noted by you above, you wouldn't have the connection to Zotero on the tablet.
    The only alternative I can think of is to to sync your PDFs to Zotero from your regular computer and use download as needed in Zotero on the tablet as mronkko and I discuss here
    Obviously that requires ~20GB storage, either on a webDAV or on Zotero file storage give the amount of files you have. With Zotero this is US$240/year, even with a 3rd party webDAV you're unlikely to get that much storage for very cheap.
  • thanks, will experiment with the setup when the tablet arrives
  • I'm having the same problem as lplummer with the zotfile changelog opening on each startup, but with Chrome: 29.0.1547.76, Zotero Standalone, Mac OS 10.8.5. I'm not sure where to look for preferences or somesuch in Chrome as worked to solve the problem in Firefox.

    It's been going on for several weeks, but I haven't had a chance to post until now.
    A minor hassle, really. Otherwise, this tool is really helpful!
  • edited September 30, 2013
    er, nevermind, I found them. Thought they were firefox preferences, not zotero, but got it straightened out. For the record, I had the same values: version 2.3.5 and version 3.0 update false. Changing the version to 3.0 seems to have done the trick in Chrome as well. Hope it helps for future updates.
  • what do you see when you paste
    into the about:config filter?
    (For future reference, your Zotero version is 4.0.11, the is the Zotero Chrome extension)
  • Thanks, I did indeed get confused amongst all the zotero, chrome extension, and zotfile versions. Really, what worked was changing (in zotero advanced preferences, about:config) the value of extensions.zotfile.version to 3.0.2 (from 2.3.5) as others did before. Now I realize that it was a zotero [zotfile] extension issue, not a firefox/chrome [zotero] extension issue.
  • I have put a new version on mozilla that should fix this issue (now under review). It's not really satisfying though because I still don't know the reason and there might be a slightly more serious bug that creates the problem. So if anyone still has the problem before (or after) the update, please let me know if there are any error messages after start-up.
  • Dear Joscha,

    I'm using zotfile 3.0.2 with zotero 4.0.11 (windows 7).

    The renaming rule of zotfile is very useful but I want to set the wildcards options as only first pages.

    Here is the example..

    Is there any method to rename only first page like this?
  • edited October 8, 2013
    Zot file is really fantastic. I have been meaning to install it for about a year and am so glad I did.

    I am using it with Zotero Standalone 4.0.11 (on Widows 8) and on my Samsung Note 10.1 Android tablet with Repligo Reader via DropBox in the cloud. FANTASTIC!!

    Working are send to & get from table (brilliant features), color-coded tags for _tablet and tablet_modified, renaming attachments and extracting annotations (amazing feature).

    Edited: Please note that the following "error message" was the result of my not setting up ZotFile preference correctly and seems to have been resolved (see my next message below): I do get an intermittent error message (I am probably not alone): Zotfile Error. The source folder is not valid.... But, it seems to be a moot point because all above features ARE WORKING.
  • Glad that you like it! Can you send the error message from the console? Here are instructions: http://www.jlegewie.com/zotfile.html#bug
  • Joscha, thanks for creating such a wonderful tool! My collaborators and I rely on it every day, across platforms and contexts. The central virtue for us is the auto-extraction of annotations from PDFs.

    I have a feature request/question: Have you explored the possibility of automating HTML > PDF conversion for saved web pages? (As suggested here https://forums.zotero.org/discussion/23704/create-and-attach-pdf-from-snapshot/ )

    Given how quickly web pages change -- and also how useful PDF snapshots are thank to Zotfile -- it would almost always be preferable to retain a PDF instead of a snapshot. My current process is to capture a snapshot with Zotero's chrome extension (so that it will auto-generate a Zotero item, with appropriate metadata), then to print the web page to PDF, attach the PDF to the zotero item (using Zotfile's attach-to-currently-selected-item trick), and manually discard the snapshot. It's doable but I wonder if a combination of feasibility and user demand might make a more elegant solution worthwhile.

    In any case, many thanks for all your work on this excellent tool.
  • edited October 8, 2013
    My bad.

    The error message (pasted below) that I was getting, and mentioned two messages above, appears to have been caused by my not setting up ZotFile (General tab) preferences adequately or completely. I had not defined the source folder. This was a new installation for me, or more accurately, I was just starting to use ZotFile. I have corrected my misinformation above (and in my review of ZotFile on the Mozilla download page).

    (ZotFile Error
    The source folder is not valid. Please change the the source folder under Zotero-Actions-Zotfile Preferences. You might have to use a custom folder.)
  • edited October 8, 2013
    (edit: nevermind, glad you found a solution).
  • hey there,

    my question is about how to best change the directory of the stored pdf files.

    Because I recently got access to our universiy's web afs, I'm trying to use a folder on web afs (with 5GB) as new pdf storage. Until now I used dropbox. However, I am not quite sure how to change the storage directory: When I copy an article to the new directory, delete it in the old directory, then change the preferences in zotfile to the new directory and finally try to access it from zotero, I receive an error message.

    Zotero then searches for the article in the zotero storage place (though I never stored the articles in zotero).

    Might there be any clever way to automate this process or did I oversee a feature of zotfile?

    Thanks a lot!

  • you can specify the new folder as the target folder in Zotfile and then just use right-click --> Manage Attachments --> Rename Attachments (you can do this for multiple items at once). Rename will also move the attachment to where you need them to be.
  • Sorry, I should give more context:

    Zotero searches for the file in the firefox library folders, where the zotero data is stored.

    One solution I found so far is to create a new link to the stored filed. This would however mean that I must link all pdfs by hand... OR import the pdfs anew...
  • Just saw your answer now. Thanks!

    So, I should do this before I delete them in the old directory, correct?
  • correct, else you have to do everything manually.
  • This is a fantastic add-on, and seems like the outcome of much hard work. Thanks!
    I'm having some weird issues with it though, alas, when I try to use annotations from my iPad. It's a pdf.js problem, I think. Anyone else having similar issues, and any suggestions to resolve?
    With all of the apps I've tried, the annotations seem to show up in desktop Acrobat no problem. The issue is when I use iAnnotate PDF, the annotations extract fine, but the text is corrupted. This is in digitally created PDFs that should have no problem, and from which I can copy clean text without any similar issues. And when I try using Adobe Reader on iOS, the annotations just don't extract at all. The progress bar doesn't move, and if I try to open the file in the pdf.js viewer, there is just no text and a progress wheel at every annotated location in the PDF.
    Any advice? For those of you who are able to successfully extract annotations made on an iPad, what app are you using to create them?
  • I'm seeing now that the issue I posted about is the same one that some others are having on previous pages. It occurs in a wide range of different kinds of PDFs annotated with iAnnotate, and looks like scottcampbell described it above, using a different annotation app. Mainly these are PDF journal articles.

    e.g. here's the text copied out by selecting in Acro Pro:

    "We suggest that drug regulatory decision-making may be understood partly as the deployment of a permissive principle, as well as the oftmentioned precautionary principle.We define the permissive principle as a tendency to permit a technology on the market even if it does not meet established standards of efficacy (and/or safety). Unlike the precautionary principle, the permissive principle is not explicitly invoked in policy and public rhetoric for obvious reasons of public legitimacy."

    and here's the extracted annotation:

    "Ce suggest that drug regulatory decision-making may be understood partly as the deployment of a permissive principle, as &ell as the oftmentioned precautionary principle" Ce define the permissive principle as a tendency to permit a technology on the market even if it does not meet established standards of efficacy (and%or safety)" 4nlike the precautionary principle, the permissive principle is not e?plicitly invoked in policy and public rhetoric for obvious reasons of public legitimacy"

    If I try making the annotations in Acrobat for iOS, they look just the same when viewed on desktop, but pdf.js just won't extract them at all. progress bar doesn't move, but dialog can be ended with ESC.
  • amcmillan, can you upload an example pdf somewhere? I won't have much time to look at it but maybe it's something easy. You can also open an issue on github with a concrete example (like in you post with copied text, extracted text, and 1-page pdf that contains the annotation).
  • Hi there,

    I have been using ZotFile for quite some time for my university work and it currently helps my an aweful lot organizing all the papers and books I use for my master's thesis.

    So, first and foremost: thank you so much for all of your great work, Joscha!

    Unfortunately, since updating to OS X Mavericks, I have been experiencing quite some trouble renaming and thus, relocating my attached files. A lot of times when I either try to attach a file
    - by dragging and dropping it on an entry,
    - by importing entry and file via the safari plugin or
    - by using the dialog asking to attach the last downloaded file in the source folder
    Zotero/Zotfile will get hung up, then show the following error message (i.e. a dialog for copying the error message to the clipboard):
    "NS_ERROR_FILE_ACCESS_DENIED: Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFileInputStream.init]
    (undefined, 124)"

    The file will be shown as attached to the entry without being renamed, but when clicking on it a "data not found" message appears asking to locate the file.

    Is there any workaround I could use and are you working on a fix for these issues respectively?!

    Thanks again for your great work and I hope you can help me out.

  • Sorry, I forgot to mention:

    I am running Zotero 4.0.11 and ZotFile 3.0.3 on a MacBook Pro with OS X Mavericks!

  • that doesn't really sound like a Zotero or Zotfile problem. File access denied means what it says - the system isn't allowing Zotero/Zotfile to access the file in question.
    I'd try poking around in the permissions, starting with the Zotero data directory - most likely the 10.9 upgrade messed up something with that.
  • ok, thanks! i'll look into that!
  • ok, thanks! i'll look into that!
  • Hi,

    Just pointing to another thread, in which it was realized that Zotfile isn't able to rename considering author (sponsor) from "bill" reference item.


    Hope Zotfile can do this in the future.

This discussion has been closed.