there was an error starting zotero (at browser startup)

Three days ago on Win7 Pro x64 I got the "there was an error starting zotero" problem, but in a more serious way than apparently anyone else yet has: on my system, the message popped up immediately upon browser startup and it wouldn't go away--if I kept Enter pressed, it was like using a game cheat for an unlimited-ammo machine gun: the message continued rapidly winking on and off forever. As a result, access to the browser was blocked unless I deleted the extensions.XXX files (per I.e. as long as the Zotero extension was enabled, not only was Zotero itself out of commission, but the browser itself (Waterfox, as Firefox isn't 64-bit) was unusable.

Over three days, this took me ca. six hours of very precious non-spare time to resolve (with Christmas plus various end-of-semester deadlines, one of which requires Zotero, this is the WORST possible timing for a problem of this nature); am posting my process & solution in hopes it can help someone else.

Problem occurred under Waterfox 18. Don't remember exactly which version of Zotero I was using, but was latest version as of last April, from which time I'd been using that combo without problems. Then suddenly three mornings ago when I opened Waterfox, the error occurred. No idea what could've caused it; I'd neither installed new apps nor made any kind of change to the system or registry that I can recall. During the past few days I had added only four or five citations to the database--not using it heavily (had been revising hard copy with pencil, better for my composition process, before electronically entering final corrections to a chapter--which entry I was just about to begin). And unlike a lot of folks with this problem, my Zotero database is not on a network drive; has always been on local system.

Here's what I did (many reboots in between not mentioned):

1. turned off security apps (Win firewall and antivirus) and checked permissions for the "..\Firefox\profiles\xxxxxx.default\zotero" folder. User had full read-write permissions for both folder and sqlite files inside, so the standard permission issue was clearly not causing my problem.

2. Uninstalled Zotero Standalone. It actually kept working after the Waterfox problem began, but I figured I'd better be safe; Standalone is really redundant anyway, since you need the browser version to download citations--so good riddance, and this eliminated it as a factor in the continuing browser-Zotero startup error.

3. Installed the newest version of Waterfox (24.0). Still getting the error.

4. Backed up database by copying the files to my backup drive, then removed the Zotero extension from Waterfox and deleted the entire "..\Firefox\profiles\xxxxxx.default" directory. Then uninstalled/reinstalled Waterfox w/option to remove all data. Some of these steps are redundant (uninstalling Waterfox with removal option should have taken care of the two previous steps, so I shouldn't have needed to perform them; but I decided to take no chances). Then finally installed latest Zotero (4.0). Checked permissions, and user retained full permission for the zotero profiles dir and the zotero.sqlite file inside it (the only file there after the reinstallation). But still no joy.

5. In the Firefox profile dir I found no compreg.dat and xpti.dat (per, so couldn't delete them. Because I couldn't access the browser with Zotero enabled, I don't know whether or not I had an about:config entry named "extensions.zotero.debug.log", but that's a way-old post and new versions of Zotero may not have either of those anymore; certainly the "debug.log" is not mentioned in any of the newer solutions I found. So if that's the case, a moderator should edit that thread and say which versions the solution is for, so users of later versions don't waste their time on it.

6. Deleted all the extensions.XXX files (per In order to retain error messages, this time restarted neither system nor Zotero. Went to Browser Console (Waterfox's equivalent of Error Console); found nothing at all. No messages whatsoever, let alone "chrome.zotero.XXXX". (And yes, all messages were enabled).

7. Checked all extra links provided in . Nothing relevant except perhaps for which suggests merely moving data dir someplace else, but I couldn't do that because I couldn't use the browser at all when Zotero was enabled, so it wasn't possible for me to tell Zotero where to go for a new location.

8. Uninstalled Waterfox with the option to remove all data, then did a general search on C disk for "Zotero." Lo and behold, found "..\Users\[username]\Appdata\Local\Mozilla". Deleted that entire dir (though left NET framework "firefox.browser" files in the .NET folders), then reinstalled Waterfox and Zotero.

Finally that did it; clean-slate Waterfox-Zotero started up fine. Changed database location to different drive and copied in current database (backed up when problem started); everything still OK. Rebooted system; all still fine. Next restarted Windows firewall and antivirus, rebooted again. Waterfox/Zotero still start without hiccups. Haven't tried to actually use the app yet, and probably won't until late tonight or tomorrow, but everything does seem like it's back to normal.

NOTE: I suppose the problem may have occurred because I have Zotero spread over two different physical drives: only my multimedia apps and big word-processor are on my SSD (C) drive; everything less intensive is installed on a separate disk (platter), including Waterfox, and I also put the Zotero library and base folder in that same directory; but of course various parts of Waterfox and Zotero are placed on C willy-nilly and there's little anyone can do about it without poking fairly deep into Windows's guts (the registry alone can't do it--truly changing the system User folders to another drive, however desirable from a safety point of view, takes some really heavy lifting that I decided I'd have to forego--see Ergo, Zotero (and the browser too) are not only on different logical but also physical disks, and this setup may have somehow been part of the problem. But as I noted at the beginning, I've been working merrily away since April with no issues, so it's certainly not the whole story; if the installation structure was indeed involved, something else was the catalyst. And again, I've no idea what that could have been. Made no major changes of any kind that I can think of. For sure didn't install any new apps; haven't had the blinkin' time to do any tinkering since Thanksgiving--it's always a mad rush from that point to semester's end--and while I'm a freeware junkie, thus might (on the fly without taking serious note) have uninstalled something I'd previously designated useless, I don't recall having done so. Thus as far as I remember there were no appreciable system changes for approximately three weeks previously, yet everything worked fine right up to zero hour. A complete mystery.
  • This may have coincided with a Zotero update that was meant to fix this issue. See

    We're sorry that this caused you so much trouble, but as a future note, if you are experiencing problems with Zotero, please don't hesitate to post on the forums for help (after a brief search for your problem). Furthermore, Zotero is not officially supported for Beta/Aurora/Nightly version of Firefox and non-Mozilla builds of Firefox (e.g. Waterfox)
  • Yes, this was the linked issue, and it occurred with unofficial/test versions of Firefox not called "Firefox". The update fixed it — not anything else you did. (As a general rule, check the forums before trying these sorts of drastic steps.)
  • check the forums before trying these sorts
    of drastic steps

    Dan, as my detailed post (which you must not have read) should have made rather obvious, I did precisely that, and quite thoroughly; which is why ...

    don't hesitate to post on the forums
    for help (after a brief search for your problem)

    ...I didn't post: the linked thread had not yet been started on Monday morning when I encountered the problem, but my fairly rigorous searches of course uncovered plenty of earlier posts about the "error starting Zotero" message, so the logical conclusion was that my problem constituted the same type, simply a more virulent subspecies for which no solution had yet been found.

    Anyhow, since my post isn't going to help anyone, it's probably best to just delete the thread so it doesn't cause any confusion. Moderators have my permission to do so.
  • (The linked thread was started on Sunday night, actually, but aurimas and I are just saying that we advise people against taking lots of drastic, time-consuming actions before asking for help. It sounds like this was an unpleasant multi-day ordeal for you, but we had fixed this in the 4.0 branch dev build by Monday night. Anyhow, we certainly appreciate your taking the time to post this for others, but I'll delete it, since as you say it might cause confusion.)
Sign In or Register to comment.