Not signed in (Sign In)
 

Quick Links

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

  1.  
    I get this error message and Zotero does not launch. There's also a yellow triangle on the Zotero logo.

    I'm using the latest version of Zotero so it seems like the solutions suggested in earlier replies for similar problems (i.e., installing the latest version) do not apply. The same version used to work until today.

    Any help greatly appreciated!
  2.  
    Please follow the steps in the Advanced Instructions section of the Reporting Bugs page and let us know what error shows up in the console.
  3.  
    I don't see "the pink background" to click; the background is white. Anyway, this is what I get:

    Error: Components.classes['@zotero.org/Zotero;1'] has no properties
    Source File: chrome://zotero/content/include.js
    Line: 1

    Error: Zotero has no properties
    Source File: chrome://zotero/content/browser.js
    Line: 664

    Error: Zotero has no properties
    Source File: chrome://zotero/content/overlay.xul
    Line: 380

    Error: Zotero has no properties
    Source File: chrome://zotero/content/itemPane.js
    Line: 49

    Please let me know if this is not what you needed or if you need something more. Thanks!
  4.  
    I'm afraid that's a generic error and doesn't provide any additional info. Did you make any changes in Firefox before the error occurred? Have you tried disabling other extensions?

    You might try removing the files compreg.dat and xpti.dat in the Firefox profile directory with Firefox closed and seeing if that fixes the error. The files will be regenerated on the next load.

    If that doesn't work, you could enable the debugging pref extensions.zotero.debug.log in about:config and start Firefox via the command line (Start, Run, "C:\Program Files\Mozilla Firefox\firefox.exe -console" on Windows) to see if there's additional info in the debug output.
  5.  
    I don't know if this is helpful but this is what I get in my error console running the same version seeing the same problem. I have disabled all of my other extensions with no change.

    Error: uncaught exception: [Exception... "ServiceManager::GetService returned failure code:" nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)" location: "JS frame :: chrome://zotero/content/include.js :: <TOP_LEVEL> :: line 4" data: no]
  6.  
    That doesn't help either, I'm afraid. Did you try the steps I suggested above, removing compreg.dat and xpti.dat from the Firefox profile or using the debug pref? We'll probably need debug console output to figure out what's happening here.
  7.  
    Removing compreg.dat, xpti.dat did not seem to help in my case. Adding debug logging didn't seem to produce too much either. Here is the output.

    firefox
    zotero(3): Using data directory /home/storeybish/a/zotero

    zotero(3): pdftotext-Linux-i686 not found -- PDF indexing disabled

    zotero(3): Opening database 'zotero'
  8.  
    storey: I'm not sure why it's not throwing a more descriptive error in the error console, but if it's not getting further than "Opening database 'zotero'", that's not a great sign. You might try grabbing the SQLite command-line client and opening zotero.sqlite directly to see if it gives you an error message.

    If it does open, you can run "PRAGMA integrity_check;" to check for DB corruption.
  9.  
    Seems the database is locked. Perhaps that is causing the problem? Any way to unlock? I don't see any unexpected firefox or zotero processes.

    storeybish@storeybish-desktop:~/a/zotero$ sqlite zotero.sqlite
    SQLite version 2.8.17
    Enter ".help" for instructions
    sqlite> .databases
    Error: database is locked
    sqlite> PRAGMA integrity_check;
    SQL error: database is locked
    sqlite>
  10.  
    You need to use the SQLite 3 client—version 2 won't work. The executable is usually sqlite3.
  11.  
    Seems the same.

    storeybish@storeybish-desktop:~/a/zotero$ sqlite3 zotero.sqlite
    SQLite version 3.2.8
    Enter ".help" for instructions
    sqlite> .databases
    Error: database is locked
    sqlite> PRAGMA integrity_check;
    SQL error: database is locked
    sqlite>
  12.  
    Still might be a version issue. You might want to grab the latest version from the SQLite site and try with that.

    This is assuming, of course, that the error persists after restarting, though you should be able to tell if it's an errant process with something like lsof | grep zotero.sqlite too.
  13.  
    Same thing. lsof doesn't show any other processes. Any suggestions?

    storeybish@storeybish-desktop:~/a/zotero$ ~/a/bin/sqlite3-3.3.17.bin zotero.sqlite
    SQLite version 3.3.17
    Enter ".help" for instructions
    sqlite> .databases
    Error: database is locked
    sqlite> PRAGMA integrity_check;
    SQL error: database is locked
    sqlite>


    storeybish@storeybish-desktop:~/a/zotero$ lsof zotero.sqlite
    storeybish@storeybish-desktop:~/a/zotero$
  14.  
    Did this error start when upgrading to b4.r5 or at some other time? Do you actually have data in your SQLite DB? (If not, you can of course just delete the Zotero data directory and start over.) If you do have data and aren't having any luck opening the file, feel free to send it to support@zo.....org, and we can take a look.
  15.  
    I suspect it probably did happen with the upgrade. At some point when I started firefox it reported that there was an update available and I let it go ahead and get the update. I'll tar up the directory and send it to your support e-mail.
  16.  
    I tried e-mailing the whole directory including attachments ~9Meg and hit the size limit for your support e-mail. However I think I've found my problem. I had a file
    zotero.sqlite-journal
    which the OS said was busy and couldn't be removed. I renamed the directory and moved everything but that file back to the old directory and I'm back in business.

    storeybish@storeybish-desktop:~/a/zotero$ ~/a/bin/sqlite3-3.3.17.bin zotero.sqlite
    SQLite version 3.3.17
    Enter ".help" for instructions
    sqlite> .databases
    seq name file
    --- --------------- ----------------------------------------------------------0 main /home/storeybish/fserv/zotero/zotero.sqlite
    sqlite> PRAGMA integrity_check;
    ok
    sqlite>


    Thanks,
    John
    • CommentAuthorctwardy
    • CommentTimeAug 11th 2010
     
    Same problem, Windows XP. In my case I found a zombie firefox process listed in Windows Task Manager, after closing firefox. It wasn't preventing a restart, but was locking the sqlite-journal file. Killed that process and then I could delete the journal file.
  17.  
    ctwardy: This thread is three years old and isn't related to your issue. Sometimes Firefox processes on Windows don't quit properly. Killing them via Task Manager or restarting the computer fixes it.

    Closing this thread.

Zotero Forums are powered by Vanilla 1.1.5a