Word cannot communicate with Zotero

This discussion was created from comments split from: HELP. Zotero says it cannot communicate with word processor.
  • hi,
    i have the problem "word cannot communicate with zotero"
    i am on MacOs 14 Sonoma with Word v 16.77.1 and Zotero v. 6.0.27

    i did all the step described to troubleshoot the problem (deleted existing zotero.dotm, restarted word, manually copied zotero.dotm in the startup folder of word)

    i was thinking of a problem with Sonoma, but zotero works well with LibreOffice
    so the problem is with Word, i think
    thank you for the help
  • edited October 6, 2023
    These are the troubleshooting steps you want to follow:


    If you're still having trouble after trying those things, provide a Report ID.
  • hi,
    i followed the indication for deleting the profile
    after restarting, in settings / word processors there aren't the buttons for installing the extensions for word and for libreoffice
    report ID is 54272088
  • edited October 6, 2023
    Deleting extensions.json, you mean?

    You should delete and reinstall Zotero, and then check Tools → Add-ons. Your data won't be affected.
  • i deleted and reinstalled zotero but yet the the settings / word processors area is void
  • edited October 6, 2023
    You didn't respond to either of the things I said. Did you try deleting extensions.json, with Zotero closed? Did you check Tools → Add-ons?
  • i think so, but i am not sure
  • i tried deleting extensions.json with Zotero closed but i am not sure about it being closed
    in tools addons there is nothing
  • Do you have Zotero in the standard location in Applications?

    If Zotero is open, go to File → Quit, open the Zotero profile directory, and delete extensions.json.

    If it still happens, open Terminal via Spotlight, paste in the following command, press Return, and let us know the output:

    ls /Applications/Zotero.app/Contents/Resources/extensions/zoteroMacWordIntegration\@zotero.org
  • hmm. i had deleted the whole profile
    so i restored the profile and Zotero is behaving well (buttons for the word processor plugin, extensions listed in the addon menu, etc.)

    then i closed zotero, went to the Zotero profile directory and deleted extensions.json
    then i started zotero and disabled all the extensions, and closed it.
    finally i reinstalled the Word plugin from this 'clean' Zotero.

    i started word and the error remains
    same if i close word, manually delete zotero.dotm, take zotero dotm from internally to zotero app, and copy it in the word startup folder

    BUT: if i go to the file zotero.dotm and choose open with word, word starts and all the zotero functions are working

    the content of the ls command in terminal is:
    COPYING chrome components install resource
    README.md chrome.manifest defaults install.rdf
  • then i closed zotero, went to the Zotero profile directory and deleted extensions.json
    then i started zotero and disabled all the extensions, and closed it.
    Why did you do this if you had already gotten the plugin to show up in Add-ons?

    And what do you mean "disabled all the extensions"? If you disable the Word integration plugin in Tools → Add-ons, that's going to break this.

    The Word integration plugin needs to be enabled in Tools → Add-ons, and you should be able to start Word normally.
  • "then i started zotero and disabled all the extensions, and closed it.
    finally i reinstalled the Word plugin from this 'clean' Zotero"

    i reinstalled the word plugin form a clean zotero without /any other/ extensions in order to avoid problems possibly caused by interference among extensions

    word /is/ starting normally.
    what i mean is that the plugin /is/ working but only if treat zotero.dotm as file which i open with word.
    this means the the plugin zotero.dotm i have, by itself is working, and is working with word (one could doubt that the plugin was there but somehow defective, which in fact is not)
  • So you're not seeing the add-on buttons unless you open Zotero.dotm directly or you're getting the "Could not communicate" error in that case?
  • after installing (in whichever way) zotero.dotm, i always see the zotero menu and its buttons, but
    - if i start word and click a zotero button i get the error "zotero cannot communicate etc.";
    - if i open zotero.dotm with word (select the file and then open with...), zotero communicates with word and i can use all the buttons

    don't know if this can contribute to spot the cause of this problem, but please note that for some months i was getting a message that the Word plugin was outdated, i was continuing to update it, only to get again the message after 15 days, sometimes i replied "ignore", sometime i was updating the plugin - but always without losing the functionality
  • That really sounds like you have an outdated version of the plugin installed in Word. Can you confirm that you've deleted Zotero.dotm from the Word Startup folder, restarted Word, and seen no trace of Zotero before reinstalling it through the Zotero settings?
  • as you ask,
    i deleted Zotero.dotm from the Word Startup folder, restarted Word, and saw no trace of Zotero (i.e. zotero.dotm was no more listed in the [tools | addons] of word) before reinstalling it through the Zotero settings

    nevertheless i continue to get the error "zotero cannot communicate etc."

    one question: how can i check the version of my zotero.dotm?
    because in the file properties it doesn't appear

  • i just installed v. 6.0.28 but i continue to have the problem of "word cannot communicate with zotero"
    i am sure that v. 6.0.28 installed the new version of the plugin because i got the message that i had to restart word.
    any idea?
  • Are you opening the Zotero.dotm file from your startup folder, which causes the plugin to start to work, or from somewhere else? What happens if you open the one in the startup folder?
  • hi adomasven
    if i open the zotero.dotm in the startup folder everything works well for the new documents
    but if i open a previous document where i worked with zotero, everything is 'plain' - there are no more fields in the document and if i click on anyone of the zotero buttons i get the message "word cannot communicate etc."

    but the instance of word is the same: with files created anew zotero.dotm works, with older files it does not

    zotero.dotm not working with old doc files is not terrible, but this could give you some hint about the reason why the plugin works if opened as a file and not if 'called' form inside word?

    (zotero 7 could be a solution to try? the beta is too risky for usual 'production' use?)
  • If you open a new document in Word (not Zotero.dotm, or an old file), does the plugin work correctly?
  • no, if i open Word, then create a new document, in the new document the plugin doesn't work
  • We've never really seen anything like this. Are you sure you have closed Word fully? Did you right-click the Word button in the launchpad and select Quit at any point, to make sure Word is fully closed, and then reopen it? Could you try restarting your computer?
  • hi adomasven,
    sorry for the delay
    i answer yet to all of your questions.
    i discover in the meanwhile that if in a new document i click on the Zotero menu, clicking onto "add note" opens the document preferences - and doesn't give the error "word cannot communicate etc." and i am able to add a note.
    but if after that i click on add citation, the error "word cannot communicate etc." pops up.

  • i have a feeling that all this happened in the days i updated my Mac to Sonoma and after that Word updated itself
  • So in a new document does clicking other buttons aside from Add/Edit Citation produce a Word communication error, or only that button? Do you have a quick-access button set up for the Add/Edit Citation button, or are you using it in the Zotero tab?
  • clicking all the buttons aside from Add Note produces a Word communication error.
    clicking Add Note in an all-new document starts the correct flow that is first of all opens the document references, then allows to add a note.
    by clicking Add Note i mean using the Zotero tab
  • And the other buttons in the Zotero tab cause a Word communication error?
  • Can you create a new temporary tesing macOS user account on your computer, and try using Zotero in Word there?
  • i did it
    Zotero was void but i created a dummy bibliographic entry
    then i started word, clicked on the zotero menu, and then on the "add citation" button, but nothing happened: no errors and no dialog windows.
    like i didn't had clicked
Sign In or Register to comment.