Chrome connector Zotero standalone

Hi All,
I know a bunch of people have tried the Zotero standalone in connection with the google chrome connector and had problems and are looking for answers. I did not find a respective thread (besides one that was closed). Has anybody gotten the chrome connector to work right at this point? In my hands it works with certain websites, but only transfers 1 citation at the time. The list view crashes in my setup. Any thoughts?
Irrespective, hats off to the guys developing the SA - greatly appreciated.
  • edited January 18, 2011
    We don't have, afaik, any detailed error reports, including sample pages, precise steps to replicate, error report and debug IDs, where possible etc.
    I'm sure it would be much appreciate if you (and said bunch of other people) would help to assemble these - that's the point of releasing an alpha version.

    edit: Such reports should also include the versions of all software used.
  • Adam,
    Thanks for the quick response. Happy to provide more information. I care about getting this to work. As a side, this is by no means meant to criticize the guys that develop ZSA. I seem to sense some sensitive issues here.
    1) steps: ZSA open, chrome -> search for interferon gamma. -> no zotero icon (e.g. the one that you see in Firefox with the regular Zotero plug-in).
    2) -> open one of the citations -> now able to copy this single citation to ZSA.

    Running chrome 10.0.634.0 (beta). No other issue with this version of chrome. How can I post screenshots? email?
  • Search where? Provide example URLs.
  • No, no sensitivity - I was truly just soliciting more details. There are only a couple of developers working on the standalone, they rely on community testing and high quality reports and of course it's fine to point out that things aren't working, especially if it's done in a friendly way. (The thread that was closed dated back to before the alpha release and was closed to avoid confusion, not to stifle contributions).

    search for interferon gamma where? google scholar?
    You say above it works for "some websites" - it would really be helpful to get some URLs here - Where does it work, where doesn't it?
    And where does the list appear and then crash?

    For screenshots - post to a free image hosting site like (works w/o registration) and paste the link here.
  • ok.
    open pubmed and search for interferon gamma. Safe to Zoteron icon appears but upon pressing a box opens briefly but nothing else happens. No literature can be picked.
    2) Open an individual reference -> safe to zoteron icon appears and citation can be copied.
    Simply google interferon gamma (or just go to wiki and search the term). open the wikipedia page -> no zotero icon. -> in the past could open and copy single reference. Not today for whatever reason.
    ZSA seems to work fine. Have not tried with word integration.
    Will post images tomorrow.
    Does this work for you guys as it works in Firefox?
  • Just noticed that it works (it seems) with google scholar. Also, got it to work with Pubmed a couple of times with double clicking the "safe to zotero) button. However, usually zotero extension crashes and No luck with wikipedia website. Thanks guys.
  • I think I can reproduce the problem with PubMed search results. We're looking into it now.
  • In Google Scholar, the Chrome extension does not respond to the Import into Endnote links; when these links are clicked, Chrome saves a scholar.enw file to the default download folder. When this file is opened, a new instance of Zotero is launched but it fails to load the file.

    The Save to Zotero icon does appear in the location bar when Google Scholar is accessed. Clicking it displays a dialog box listing links to the first ten items on the page. These links work and result in new Zotero database entries. However, the dialog box is not expandable. If the user has configured Scholar to display more than 10 items per page, items after the tenth one do not appear in the dialog.

    Thanks for developing this exciting new version of Zotero!

    B. Pfaffenberger, Univ. of Virginia

    Chrome 8.0.552.237
    Zotero SA and Chrome Extension downloaded 1/19/11
    Mac OS X 10.6.6
  • However, the dialog box is not expandable. If the user has configured Scholar to display more than 10 items per page, items after the tenth one do not appear in the dialog.
    that's general behavior, not limited to Chrome or the standalone version.
  • Just diving in (took a while to find this thread)...not sure if this is already a known issue, but the general "save webpage" icon doesn't show up in the Chrome URL bar if no other translator fires.

    And again, hooray for the SA + Chrome alpha...feels like coming home. :)

    Chrome 8.0.552.237
    Zotero SA and Chrome Extension downloaded 1/19/11
    Mac OS X 10.6.6
  • I think that the basic save webpage function has not yet been implemented for the connectors. The non-translator parts of the connection between Zotero and websites are pretty much absent at this point, but they should be coming into place.
  • ajlyon,
    Not sure about this because it works for Google Scholar pages. IMHO it may be website specific incompatibilities.
  • edited January 20, 2011
    Thomasdoc: They're talking about "Create New Item from Current Page" functionality, which isn't site-specific and has not been implemented in the connectors, not translator-based saving.
  • Meaning the "Create New Item from Current Page" functionality is not available in the current alpha Google Chrome connector? I haven't seen the "Z" appear in the address bar except once going through lots of different generic pages (e.g., not a literature search database with documents like PubMed). Example of one below is just a simple webpage of a textfile.

    I'm new to Zotero with the standalone and Chrome extension alphas. Never used with Firefox. Looking to replace Endnote. Not sure how/when things should work. Using system below.

    Windows XP S3
    Zotero standalone alpha 2.1a2
    Google Chrome current (9.0.597.67)
  • Meaning the "Create New Item from Current Page" functionality is not available in the current alpha Google Chrome connector?
    correct. Among "normal" sites you'd see it on NYTs articles and on amazon (among others)- otherwise its catalogs and databases mostly.
  • Hi guys - anything new on this topic? Is there a solution/workaround?
  • No solutions yet, except to use the Firefox add-on. These major issues will be fixed in the coming releases of the connectors.
  • edited February 1, 2011
    [EDIT: See update below---the issue I was having is resolved.]

    I'm not quite sure which specific issues have been identified so far, but here's some further detail on the issues I'm having with the Chrome connector.

    System info: OS X 10.6.6 ; Chrome 9.0.597.83 ; Chrome connector 0.9

    Based on the instructions I found here:

    I tried to the two suggested reference examples to see if the Connector would behave as expected. But nothing happens. The pages load, but no Zotero icon appears. I checked the Chrome console, and it gives:

    Failed to load resource |
    Failed to load resource |

    Any suggestions?

    UPDATE: Whoops, turned out I had missed something very basic: I didn't have Zotero Standalone running. Now when I try using the connector with Standalone running, it appears to work. Sorry for my oversight --- but perhaps there are others who have also overlooked this.

    aps not working with the chrome connector, works fine in 2.1b2 in firefox4.

    I just get a blank popup box, and there is no zotero error(report errors), debug info submitted D431896147
  • @pobrien86: Yes, I get the same behaviour. That URL works in Firefox but not with Chrome Connector.
  • Confirmed.

    For some reason, the translator isn't able to call the RIS translator. The last line of debug output is:(3)(+0000000): Translate: creating translate instance of type import in sandbox

    Usually, there would be more output as the RIS translator gets to work, but here it looks like it simply isn't being called. Thanks for pointing this out.
  • Adding to the chorus: Chrome connector needs to address less standard sites. Libraries, newspapers, pubmed, work fine; quasi-academic sites aren't detected.
    For example, is detected by Zotero-Firefox, but not plugin-standalone. Also second the request for generic-grab-the-site function.

    Very glad that standalone Zotero is underway -- has been badly needed. Thanks.
  • The translators not working in Chrome/Safari are those that do not specify specific target sites, but rather inspect every page for useful metadata. The way things work now, the entire source of potential matches has to be send to Standalone for processing, which would be just too inefficient if it had to happen for every page you visit.

    The next step is to have the browser plugins run the translators themselves -- at that point it will be possible to have the general translators (DOI, Embedded RDF, etc.) run in the Chrome/Safari connectors.
  • BUG REPORT: Chrome Connector's Zotero Item Selector downloads duplicate of first checked item when multiple items selected

    ERROR REPORT ID: 944119564

    1. Start Standalone and Chrome
    2. Browse to Google Scholar
    3. Search for "spectrum allocation" (with or without quotation marks)
    4. Click Zotero icon in location bar; the Zotero Item Selector appears.
    5. Check n items, where n > 1
    6. Click OK

    The Chrome Connector downloads n copies of the first checked item.


    OS: Mac OS X 10.6.6 (10J567)
    Chrome: 9.0.597.107
    Zotero Standalone: 2.1a2
    System: Gigabyte GA-EP45-UD3R, Intel Quad Core 6600@3.0MHz, NVidia GeForce 9800 GTX+, 4GB RAM
  • Upgrade to Zotero Standalone 2.1a3.
  • I was starting to notice that the Chrome Connector will only work for me on sites that I don't need a proxie for, like google scholar or amazon. However, the moment I need a proxie to get content for free through my library, I'm out of luck. Some examples:

    However, I then noticed it was working for Sage, Springer, and Factivia:

    Hope that helps some happy developer. I'm happy to spend some time testing and reporting if someone wants to contact me directly.

    OS: Mac OS X 10.6.6
    Chrome: 9.0.597.107
    Zotero Standalone: 2.1a2
    Chrome Connector: 0.9.1

    Thirding the request for generic site grab.
  • The main issue you're seeing is that the connectors don't yet support extracting DOIs from the page text, which is what you've been seeing in Wiley and I believe EBSCO. EBSCO's eJournals service isn't covered by the main EBSCO translator (iirc) and so we'd been using DOIs, which will eventually be supported by the connectors.

    For Wiley, try installing the translator I posted at -- it should start working.

    You're not the first person to report issues with JSTOR-- in my experience, URLs like the one you post are always redirected to URLs like (in this case), which Zotero reads fine. If you can get to the more standard URL, and not the OpenURL resolver address (which you posted here), then I think the connector should save the page fine. I don't use EZProxy myself, so I can't really replicate the issue and fix it.
  • Your translator worked! Thanks for the tip and the info.

    If you want to use EZProxy so you can find the issue and fix it, I can get you access...

  • I can't get it to even work for PubMed.

    I installed the extension. Saw the icon appear. But didn't have a chance to test it. When I started Chrome again, I have never seen the Zotero icon re-appear in PubMed.

    The standalone is running fine. I have check the extensions and uninstalled and reinstalled.. still... when I go PubMed and look at any reference, the Chrome Extension icon for Zotero fails to appear.
  • Does it work for other sites? NYTimes?
This discussion has been closed.