Zotero in Ubuntu 10.4 Lucid Lynx

  • I don't think it's even clear what exactly is causing this - it's not a consistent bug - so no, there is currently no way to have both working.
  • You could use the default zotero data directory, as it now seems to work for most people on Lucid who do this.

    Alternatively, you'll have to edit your apparmor profiles & the best place to get support for that probably isn't here.

    Some more work-arounds at:
  • michopop: The troubleshooting page has had instructions on disabling AppArmor for just Firefox for a while.

    Even more fine-grained changes might be possible—adding to AppArmor's Firefox profile exactly what's required to let Zotero work—but you'd have to figure out how to do that.
  • Dan, than you for the solution! It works well.
  • Despite disabling AppArmor and installing Sun Java I am still having this error. For three days I have tried to find a solution but have not been able to get around this and I am becoming desperate because I have a deadline I am about to miss.

    App Armor is set to complain:
    Setting /etc/apparmor.d/usr.bin.firefox to complain mode.

    Javatester.org gives me a pink square with: Java Version 1.6.0_22 from Sun Microsystems Inc.

    I have submitted an error report: Error Report ID = 1842446627
  • what's the output of
    sudo update-alternatives --config java
    did this suddenly start on a system it used to work?
  • edited December 23, 2010
    here is the output from sudo update-alternatives --config java.

    There are 1 choices for the alternative java (providing /usr/bin/java).

    Selection Path Priority Status
    0 /usr/lib/jvm/java-6-sun/jre/bin/java 63 auto mode
    * 1 /usr/lib/jvm/java-6-sun/jre/bin/java 63 manual mode

    Press enter to keep the current choice[*], or type selection number:

    i changed it to auto mode and now get this output:
    There is only one alternative in link group java: /usr/lib/jvm/java-6-sun/jre/bin/java
    Nothing to configure.

    no this is a new computer and it has never worked. however i am now getting the same error on my other ubuntu computers that used to work fine.
  • edited December 23, 2010
    treblekicker, this is a bug/regression in Firefox 3.6.14pre. We're working on getting it fixed. Firefox 3.6.13 should work fine.
  • Hi Simon,
    I am having the same problem with 3.6.13. Bug report: 1794955009
  • edited December 28, 2010
    Your new error is different ("java is undefined") and indicates that Java isn't working at all. Your error report indicates that you might be running 32-bit Firefox on 64-bit Ubuntu, which will break Java entirely, since Ubuntu ships with only a 64-bit Java plug-in. Either use the version of Firefox that ships with Ubuntu, or install the x86_64 build of 3.6.13 from here.
  • apparently i had the mozilla nightly build ppa for firefox and it was updating firefox to 3.6.14. when i installed firefox from the mozilla website i didn't pay attention and installed the 32-bit version. i have now removed the ppa and uninstalled and reinstalled 3.6.13 using synaptic and everything is working fine now. thank you very very much!
  • This might be naive, but if anyone is still having trouble getting Zotero to work with openoffice in 64 bit ubuntu then the symbolic link should be sudo ln -s /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so /usr/lib/mozilla/plugins/

    after this and a reboot the integration works for me.
  • Hello,

    I just switched to a new netbook and am using the same software setup as on my previous laptop (Ubuntu 10.10, Sun Java 6), on which Zotero worked perfectly. But suddenly I'm getting the error:

    Firefox could not load the component required to communicate with your word processor. Please ensure that the appropriate Firefox extension is installed and try again.

    I've changed the Java settings and apparmor as explained in this thread and in the how-to (http://www.zotero.org/support/word_processor_plugin_installation). The error I reported regarding this case is here:


    Any ideas on what could be causing this?

    Many thanks,

  • As a follow-up, I have since installed the 2.1 beta versions of both the Zotero and OpenOffice.org plugins and I am still getting the same error message. I hope I can figure out how to get Zotero working again soon so I can finish off my article.

  • joehill, you have exactly the same error as michopop did above. Have you tried disabling apparmor entirely?
  • Just to follow up again, after upgrading to 2.1b2 and finding that I kept getting errors about updating the document, I reverted back to 2.0 and uninstalled and installed and purged the OO.o python-uno directory several times, and it appears that Zotero is now working. Not sure what the problem was but it seems that uninstalling, installing, and purging is often the cure. Thanks Simon for your suggestions.
  • @ joehill: Would you mind adding a brief step-by-step explanation of your solution? I would very much like to try if it works on Ubuntu 10.10 where I am having similar issues.

    Best wishes,

  • @ Dirius:

    If I recall correctly, this is what I did:

    remove both extensions from Firefox
    close Firefox
    rm -r .openoffice.org/3/user/uno_packages/cache/
    rm -r .mozilla/firefox/myprofile.default/extensions/zotero*
    open firefox and reinstall both plugins.
    go into Tools -> Add-ons -> Extensions -> Zotero OpenOffice Integration -> Preferences and reinstall components.

    I may have had to do these steps more than once. I don't know why this sometimes works and sometimes doesn't. I hope this helps.

  • Hi all,

    Just tested it with the new IcedTea-web Java plugin introduced in Fedora 15. It works fine with LibreOffice.

    So I guess we can relief from this issue and embrace the openjdk from now.
  • The new Zotero OpenOffice plug-in doesn't use the Java plug-in at all (although it still relies upon Java support within OpenOffice.org), so this is indeed resolved.
This discussion has been closed.