Zotero in Ubuntu 10.4 Lucid Lynx

Hello all

I'm having difficulty getting Zotero to function in the current Ubuntu development release. As this is to be a "long term support" version of Ubuntu I think it's a good idea to get Zotero working well from the launch

Ok, here's what I've got -
Ubuntu 10.4 alpha 3
Firefox 3.6
OpenOffice 3.2 RC4
Both the latest Zotero plugins, with detected paths -

The Zotero toolbar shows up fine in OpenOffice, but on citing I'm told -

"Firefox could not load the component required to communicate with your word processor. Please ensure that the appropriate Firefox extension is installed and try again."

Based on suggestions and reading of several other threads here, I suspect that the problem may be the default install of OpenJDK, which is new in Lucid Lynx. sun-java6 is not (yet) in the Lucid repositories, although a bug is open on this (https://bugs.launchpad.net/ubuntu/+source/sun-java6/+bug/515678). I also noticed that openoffice.org-java-common is installed by default in Lucid, but not in Karmic

I've tried the various alternative paths suggested in other threads, installing sun-java6 from a PPA (https://launchpad.net/~voronov84/+archive/andreyv), and also uninstalling OpenJDK. No luck so far

My guess is that the Lucid/OpenOffice setup simply has a somewhat different java setup than in previous Ubuntus, and Zotero may need to make a fix for this. Just my guess

If anyone has got Zotero working in Lucid I'd love to know. And any other advice appreciated! Cheers
  • just as a note - I'm pretty sure I remember that Zotero has never worked with any of the non-sun Java versions, so that's likely the issue.
    Have you, after installing sun-java, tried "re-install open office components"
    from FF Tools --> Add-ons -->Extensions --> Zotero Ooo Intergration Preferences?
  • Yup, tried that. I think I've been pretty thorough :-)

    If OpenJDK won't work, and users have to subsequently install sun-java6, are there any additional steps required to ensure that Ubuntu and/or OpenOffice and/or Firefox and/or Zotero are looking for Java in the right place? Should OpenJDK be uninstalled or can they co-exist?

    Thanks for the input
  • edited February 26, 2010
    The latest version of Zotero OpenOffice Integration works with some versions of OpenJDK and the OJI IcedTea plug-in with Firefox 3.5 (i.e., it works with the version in Karmic amd64, at least on my system), although it's a little more finicky than using the Sun plug-in.

    With Firefox 3.6, Mozilla got rid of LiveConnect/OJI, and I believe the new NPRuntime IcedTea plug-in is currently in alpha (and should work, but may not). The NPPlugin version will not work under any circumstances.

    As far as I can tell, the Lucid repository currently contains only the old LiveConnect/OJI plug-in and the NPPlugin (in the package icedtea6-plugin), so if you need Zotero OpenOffice integration in Firefox 3.6, you'll have to build your own version of the alpha NPRuntime plug-in. Alternatively, icedtea6-plugin should work with Firefox 3.5, but I haven't tested it in Lucid, so YMMV.
  • Hello Simon

    Many thanks indeed for your work on this. On a Lucid alpha3 32bit VirtualBox setup, I downgraded to Firefox 3.5.7 from ubuntuzilla. Zotero was set up from scratch and I confirmed icedtea6-plugin was present in the default install. Sorry to say there was no change - I still get the error above.

    No movement either on the bug above on packaging sun-java6 for Lucid. But when that does happen it should all work fine, right? Or is there more to it?

    Again, much appreciation for looking into this one. Cheers
  • Hi everyone,

    I confirmed it's the problem caused by the experimental OpenJDK NPP plugin. I tested it on my Fedora 12 i686 with Firefox 3.6 (from Fedora Rawhide) and OpenOffice.org 3.2 Final (From Oracle)

    This problem only happens after I followed the guide here: http://forums.fedoraforum.org/showthread.php?t=239042

    Once I reinstalled the Sun plugin (libnpjp2.so) and disable the alpha OpenJDK one, Zotero OpenOffice.org integration works fine, as usual.

    There is no need to uninstall OpenJDK plugin. The plugins can be switched on and off dynamically, unlike extensions.

    Why wait for the packaging sun-java6? I used the self-extracted bin one and it JUST WORKS.

    Hope it would be helpful for you.

    Now I need to return to my coursework due tomorrow. :-)
  • edited March 2, 2010
    hello everyone

    just to report that as of sunday lucid now has sun-java6 in its partner repository. once that's installed (sun-java6-bin sun-java6-jre and sun-java6-plugin), there are two things to do in the terminal to get it all set up properly

    1) select your preferred java (if openjdk is still installed)
    sudo update-alternatives --config java

    2) make a link from sun java plugin to the firefox plugins folder
    sudo ln -s /usr/lib/jvm/java-6-sun- /usr/lib/mozilla/plugins/

    you'll also have to select sun java (instead of openjdk) in your openoffice options. with all that done, zotero works for me on lucid

    many thanks to everyone who has helped out on this thread

  • thanks for reporting back Roger - so Zotero/Ooo is now working for you?
  • edited March 2, 2010
    seems to be, yes!

    what all this shows is that getting zotero working on the default install of ubuntu lucid (which is to be a long term support version, relevant for some years to come) requires several additional steps due to the transition from sun-java6 to openjdk as default

    it might be worth zotero either publishing a simple script to automate these steps or, if it's possible to detect an os version, including this within the plugin. at the very least a clear howto should be in the FAQ section

  • edited March 2, 2010
    just for clarity, there's no need to downgrade firefox - 3.6 works fine. so the full list of steps required for ubuntu lucid alpha3 is -

    paste the following into a terminal, line by line -
    sudo bash

    sudo echo 'deb http://archive.canonical.com/ubuntu lucid partner' >> /etc/apt/sources.list


    sudo apt-get update

    sudo apt-get install sun-java6-bin sun-java6-jre sun-java6-plugin

    sudo update-alternatives --config java

    sudo ln -s /usr/lib/jvm/java-6-sun- /usr/lib/mozilla/plugins/

    go to openoffice options and select the newly-installed java
    then install the two zotero plugins as normal

    good luck!
  • oh dear, no it's not working. now that i've actually started using it properly i find that it doesn't manage to do a second citation. the error message is huge and can be found on the screenshots here -


    i've tried this in two different installs, btw. bah, back to karmic for now...
  • sorry, me again. this fault only happens when i use .doc compatible bookmarks. .odt referencemarks seem to work fine

    devs, do you have any leads on this?

  • Hi everyone,

    After today's sun-java6 update in Ubuntu Lucid, OpenOffice integration no longer works.

    If you followed (like me) the list of steps provided by rogerdean on March 2nd, then you will need to remove the old link and create a new one:

    sudo rm /usr/lib/mozilla/plugins/libnpjp2.so
    sudo ln -s /usr/lib/jvm/java-6-sun- /usr/lib/mozilla/plugins/

    After that, I ''reinstalled OpenOffice.org components" using the corresponding button of the Firefox extension...

    ...and it worked!

  • rogerdean and Alberto: THANK YOU! You both represents the best side of the open source community and are the everyday heroes of it. Your help on this matter is worth so much for us ordinary users.
    This is the most amazing part the Linux world, helpfulness, computer solidarity and a strong sense of self empowerment. You, and all the others who share your knowledge and tricks free of charge for all of us, you make the future of the open source, Linux and Ubuntu bright.

    I never want to go commercial again. :-)
  • Great, thanks everyone for your suggestions.

    My only suggestion is this:

    Instead of this:
    sudo ln -s /usr/lib/jvm/java-6-sun- /usr/lib/mozilla/plugins/

    sudo ln -s /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so /usr/lib/mozilla/plugins/

    In other words, link to the stable link, not the actual directory, which changes every time Sun Java gets updated.

  • It makes sense!

    Thanks joehill.
  • Thanks Joe, very good!

    This lack of linking is a bug in Ubuntu 10.4, and I'm sure it'll be fixed before release day at the end of this month. At that point I'm sure the Zotero devs will be able to post a howto in the FAQ section of this site...
  • Wonderful to find this thread! It worked for me. Thanks, everyone.
  • Worked for me too! Lucid just installed.
  • Hopefully a helpful FYI. I was having trouble installing java on the NBR version of 10.04, due to sun-java not being in the repositories. Anyway, the key command is this:

    sudo add-apt-repository "deb http://archive.canonical.com/ lucid partner"

    Then you can

    sudo apt-get update
    sudo apt-get install sun-java6-jre
    sudo apt-get install sun-java6-plugin
  • This thread is awesome! Thank you guys for your great job! I had big issues using the new Zotero version with the new Ubuntu, with the new Firefox, with the new OpenOffice, with the new Java, etc. I feared for my 600 footnotes of my document, but everything is fine!

  • I believe that the mozilla java plugin also should be set using alternatives. At least on my laptop (Ubuntu 10.4 x64) there was an entry in /etc/alternatives for mozilla-javaplugin which I noticed after running alternatives on java itself. So instead of hacking the link with the ln command by hand as per Joe or Alberto's comments above, one should probably do it with

    sudo update-alternatives --config mozilla-javaplugin.so

    At least, that, combined with downloading sun-java6 etc. as above and using alternatives to choose the sun version worked for me.
  • Ubuntu 10.04 (realesed)
    openoffice 3.2.0
    firrefox 3.6.3

    Hi guys

    I tried different ways and I still get error:

    Firefox could not load the component required to communicate with your word processor. Please ensure that the appropriate Firefox extension is installed and try again.

    Could someone write a clear instruction from beginning to the end of what should I do?
  • For me I did:

    add to /etc/apt/sources.list:

    deb http://archive.canonical.com/ lucid partner


    sudo apt-get update
    sudo apt-get install sun-java6-plugin sun-java6-jre
    sudo update-alternatives --config mozilla-javaplugin.so
    sudo update-alternatives --config java

    Choose the sun version in each case.

    Somewhere in there I also removed an reinstalled both the firefox plugin and the OpenOffice plugin, though that was before I figured out the sun java thing so it's probably not required.
  • Thanks to all in this thread.

    I've posted a step-by-step of the whole procedure, crediting you guys, at:

  • a good contribution martineve, thanks for that

    i think (as per docbrown) you could replace this -
    sudo ln -s /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so /usr/lib/mozilla/plugins/
    with this -
    sudo update-alternatives --config mozilla-javaplugin.so

    i'm also finding that referencemarks in .doc files still cause a zotero crash on the second or third action. it's probably worth mentioning that folks may have to use .odt format until this is fixed

  • sorry, referencemarks in .odt are fine, bookmarks in .doc are not...
  • Believe me if I tell you that i don't know how to say thanks to you people!

    I'm going to show this post to some people I'm trying to teach and show the spirit of free software

    Thanks a lot!
  • Wonderful. I followed Martineve's guide, and after a shutdown and restart everything works. Thanks a lot!
  • I can confirm rogerdean's description of the crashes when writing doc-files - this is a major problem since all my colleagues use doc- or docx-files. For the time being, this means that I simply can't use Zotero.
  • Very many thanks to those above who worked out this problem. I was gettign worried that I'd have to change my distro to keep using zotero
This discussion has been closed.