Crash on upgrade WordMac

Hello, this morning Firefox prompted me with a Zotero for Mac upgrade (I can't remember which version but I believe the latest).
After upgrading Firefox started crashing on startup. I am now trying to load in safe mode but everytime I do so I get the message below:

Components.classes[';1'] is undefined

I have Zotero 2.0.9 MacWord plugin 3.0.b6
On FF 3.6.10 Mac OSX 10.6.5

Any ideas?
  • Update: I checked all my plugins one by one and by doing so the message disappeared. I uninstalled some superfluous ones that might have caused FF to crash.
    Just in case this happens to others...
  • hi,

    exactly the same problem here. FF crashes on startup after upgrading to MacWord plugin 3.0.b6
    how can I check the plugins if I cant start FF?
  • Frankweber, I was having the same problems and also didn't know how to check the plug-ins! But teh interwebs had the answer. Start in "safe mode," by holding down the option key while starting firefox. Then, go to "add ons" under the Tools menus. Uninstall the MacWord plugin 3.0.b6. Restart to make sure that was the only problem. Go back to Add ons and enable everything else. Restart again. This worked for me!
  • I have the same problem - FF will not launch once MacWord plugin 3.0.b6 is installed (upgraded). I launched in Safe Mode and disabled it so that FF will launch, but now I am, of course, unable to utilize the Zotero toolbar in Word for Mac 2008. This is a serious bug - Any thoughts from the devs about how to fix this? Or how to downgrade to the MacWord plugin 3.0.b5???
  • UPDATE: I downgraded to the earlier MacWord plugin by uninstalling 3.0.b6, restarting FF, and then clicking here for the earlier version:

    Word is now interfacing fine with Zotero and FF does not crash (whew). So, heads up to all Mac users - don't upgrade the MacWord plugin to 3.0.b6 until this bug gets worked out.
  • jsullivan47: If you upgrade to 3.0b6 again, does it crash again?
  • I just reported this as an error, report ID 2108704185. Before doing this, I went through all the steps on and (uninstalling and reinstalling Python and then reinstalling 3.0.b6). FF still froze upon opening.

    Thanks, jsullivan, for the downgrade link, for some reason I couldn't find that!
  • For the record, we can't reproduce this, so we need confirmation that re-upgrading to 3.0b6 causes the crash again.

    Also, go to about:crashes in the Firefox address bar. If you see an entry for one of the relevant crashes, generate a report and post the URL here.
  • thanks a lot for the advice,
    the problem seems to be more serious on my mac

    - i managed to start FF (3.6.12) in safe mode on my mac (10.6.5)

    - I uninstalled the zotero-word-addon which had caused the problem - to no effect
    - then i started to deactivate all my other addons - to no effect
    - - delicious bookmarks 2.1.106
    - - Firefox PDF Plugin for Mac OS X 1.1.3
    - - Flashblock
    - - Web Developer 1.1.8
    - - Zotero 2.0.9
    - - Zotero OpenOffice Integration 3.0.b2
    - - PhytonEXT Addon

    - now i could start FF normally

    these are the addons i could reactivate without causing FF to crash on startup:

    - - Flashblock
    - - Web Developer 1.1.8
    - - Zotero 2.0.9

    if i reactivated any of these plugins FF kept crashing on startup:

    - - delicious bookmarks 2.1.106
    - - Firefox PDF Plugin for Mac OS X 1.1.3
    - - Zotero OpenOffice Integration 3.0.b2
    - - PhytonEXT Addon

    - reinstalling the previous version of the zotero-word-plugin also crashed FF on startup

    any suggestions?

  • Dan: Yes, FF crashes as soon as it relaunches after the upgrade to 3.0.b6. I've confirmed this twice. Each time I launch FF in safe mode, uninstall MacWord Integration, relaunch (which is fine), then downgrade to 3.0.b5, relaunch, then everything is fine and integration with Word for Mac is restored.
  • Dan, kind of. I reinstalled 3.0.b6 and FF did actually start up this time. But now, when I try to insert a citation, I get the error message "Firefox could not load the component required to communicate with your word processor. Please ensure that the appropriate Firefox extension is installed and try again." This is the message that took me to the python reinstall page in the first place.
  • Dan: Here's my best shot:
  • Scratch my previous comment, it turns out FF was still using the earlier 3.0b.5. When I re-enabled 3.0b.6, I'm back to the same situation as jsullivan47 with FF not loading. In my case, FF is not "crashing," just never loading. (I don't know if that's a real distinction or just one in my head!) Would you like the crash report that is generated when I force quit FF? It's very long...
  • Yeah, ditto that MM CW Project. I'm not sure that FF can even generate a proper crash report to Mozilla since it's unable to even launch after install the MacWord Integration 3.0b6. Once you launch it in safe mode, you can do "about:crashes", but I don't know if that's going to be helpful to Dan or the other Zotero devs. Nevertheless, for the time being, staying at 3.0b5 seems the safe bet.
  • If you're getting this, generate real-time debug output for the startup with the latest MacWord Integration 3.0 Branch dev build (assuming it still hangs) and post the last few lines here. You can skip Step 1—just starting up from the Terminal without changing any settings is sufficient.

    Also, what versions of Word do you have on your systems? There was literally one line of code that changed between 3.0b5 and 3.0b6, and it should be executed only if Word 2004 is installed.

    And yes, a freeze is not the same as a crash. It's important to be precise.
  • Word 2008, 12.2.0

    I tried to follow your directions, Dan, but I am not getting any information in the Terminal window. I reinstalled 3.0b.6, force quit FF, then followed the directions on real-time debug from step 2. Currently, FF is not loading and the Terminal window is blank (aside from my command). I might need painfully literal directions here...
  • edited December 2, 2010
    Did you press Return after entering the command? Is Firefox bouncing/open in the dock? And do you not have Word 2004 installed anywhere on your system?
  • Not that painfully literal! :)

    Yes, which bumped the cursor to the next line down. But nothing else happened. (Aside from FF starting-but-not-loading.) When I first tried this, I still had 3.0b.5 installed, and lots of lines of code or whatnot appeared as FF launched successfully.
  • No bouncing FF icon in the dock, just the spinning rainbow wheel and the word "loading" in the tab (also nothing in the little bar at the bottom of the screen that shows loading progress. The little light is, however, shining under the FF icon on the dock.

    As for Word 2004, this computer was bought new for me when I started this job in January 2010, so it's highly unlikely. I also looked pretty thoroughly to see if an old version of Word was lurking somewhere, and can't find anything. But I can't say absolutely no.
  • edited December 2, 2010
    Can those of you who are getting crashes with 2.0b6 but not 2.0b5 try reinstalling Word components (ignore the section heading) with 2.0b5 installed and see whether that also produces a crash? Also, the steps here may resolve the problem for some users. (Let us know if they work.)
  • Dan, Simon: Here is the debug output on the FF freeze that happens after upgrading to MacWord Integration 3.0b6:

    Hopefully I've followed your directions carefully enough to make this work.
  • Simon, I already tried your first suggestion, and no freezing with 3.0b5.
  • Oh, and BTW, I am running Word for Mac 2008 (Version 12.2.7 100910) on Snow Leopard (Mac OS X Version 10.5.6). Sorry for not including this info earlier. FF is version 3.6.12.
  • MM CW Project, I managed to reproduce your hang with FlashGot installed. Disabling only FlashGot, restarting, and re-enabling FlashGot should fix the problem and leave all of your extensions intact, although you'd have the same problem the next time you update Zotero MacWord Integration. I'm looking for the cause of the crash, but this should be a temporary solution.
  • Simon: Hey, eureka, that did it for me as well. Disabling FlashGot, and then upgrading MacWord Integration to 3.0b6 without it didn't freeze my FF. Afterward, I enabled FlashGot once again, FF restarted, and everything still worked. Thanks for the workaround.
  • Ah ha! All appears to be working on my end now. Thank you, Simon. I was just about to start plowing through the extensions. I so appreciate Zotero!
  • 3.0b7 is now available with a fix for this.
  • Brilliant, many thanks! This is what I love about the Zotero project - fantastic tool, and very responsive support. Cheers.
  • Wow sorry I've been away and could not reply but I see there has been a lot going on in the meantime. Actually I did not experience any issue after starting in safe mode and going through the plug-ins which anyway I am not sure being concurrent to the issue.

    Everything runs fine in my system - shall I upgrade to 3.0b7 anyway? is it safe?

  • It definitely fixes the FlashGot-related hang that I was able to reproduce, but it's possible, although unlikely, that there could still be incompatibilities with other Firefox extensions. If it still causes issues, you can open Firefox in safe mode, disable all extensions but Zotero, Zotero MacWord Integration, and PythonExt, restart, and then re-enable your problematic extensions. (Also, let us know.)
Sign In or Register to comment.