import/export: reference manager

i just stumbled upon zotera and it looks good. however, i have been using the reference manager for past four-five years and have a sizeable database there.

is it possible to import/export references between zotera and the reference manager 11? if so, how?

  • I believe (but have no way of confirming) that ReferenceManager can export an RIS file, which Zotero can import. Alternatively, look for BibTex or Endnot/Refer/BibIX export which it MIGHT have. Zotero also supports MODS, MARC, and RDF import, but I doubt ReferenceManager can export to those formats.

    Please report back here with the format or formats you can/can't export to help other users.
  • I've just tested NOKSAGT suggestion: exporting from RM to a RIS file and importing it in to zotero, and it worked fine, i.e. it did what it was expected to, and I save precious time of typewriting previously saved references. However there are some drawbacks in the procedure:

    1) Some fileds are not handled with the original name. Thus a link to PDF in RM will appear as a URL direction in zotero. This is not bad if you are not using the WEB/URL link in RM, but if you do, then you will get confusing fields.

    2) Special fonts are marked with squares during the importing to RIS. They doesn't appear as special or even marked (lets say Itlaics) in zotero and I haven't test if they do once they are used in the document (lets say Word).

    Hope this helps
  • Re. (2): RIS is supposed to be plain text. So it sounds like a non-standard export from RM to me...
  • I accounted similar problem when importing from RM11. In the RM records I have links to PDF files saved on a disk. In exported RIS file these links are saved as L1 field, e.g.:

    L1 - file://C:\folder\filename.pdf

    There are some special characters at the beginning and the end of file address. In a text editor (SciTE) they appear as NAK and ETB .
    It would make it easier to switch from RM if Zotero could include these links as attachments to imported records. I have >700 PDF files linked in my RM records, without automatic import it is impossible to have all these links in Zotero.
  • There is some movement on these issues here and here in the development forum.
  • How about to export files from zotero to RM11? I was using RM11 and now I use zotero. I've started to add references in zotero, once i found that the RIS format can copy from RM 11 to zotero, but, now I can't copy back to RM the new added references. It does not support import from RIS format. Is there any way of doing it easily?
  • Consult your RM documentation or the technical support that exists for it: it should be able to import RIS.
  • I followed the instructions but Zotero (and the entire firefox) freezes and I finally have to force the program to end with the task manager. Any idea?
  • How many references are in the file your trying to import? Try breaking the file into smaller chunks.
  • Hi Tjowens, thanks for your fast response. I've got 820 references, will try half of it and post the result here...
  • Alright! It was that! :oD Such a simple thing and I didn't figure out. Thanks Tjowens! It seems I can import citations in packages of 100. I get mistakes with accents and special characters but that's another thread...

    MANY THANKS! Dani.
  • On the PDF issue: does anyone have a 'good' fix? My poor fix was to make a copy of the database in RM and remove all the pdf links, (it hurt every time) and then the exported list imported fine into zotero. Is there something like a copy and replace we could perform on the RIS file so that zotero would understand the link?
  • I don't see why it should not work, what is your RIS output? When exporting from endnote it works. check here for discussion:
  • I am trying to import references from EndNote to Zotero 2.0.3 and having no success. I have 1400+ references, so I tried the export/import process on only the first couple hundred or so (letters A-C). Also didn't work. Error message, both times: "An error occurred while trying to import the selected file. Please ensure that the file is valid and try again."
    Could it be because of the pdf links? They are mostly broken links referring to where they were stored on an older computer. I don't really care if I import the internal links, though I would like to retain the web links. How do I know if this is what is causing the problem? If this is indeed the problem, how do I fix it? Go through the entire 1400+ records and delete the unwanted links? Help!
  • SUCCESS!! I have had success with exporting from Reference Manager including with the PDF link problem. I have a large number of PDF files that are saved on my hard drive and in reference manager I access them from the 'link to PDF' field.

    1) export files from reference manager as an RIS file (highlight records /file/export select RIS)
    2) open the RIS *.txt file that you just created in e.g. word notepad
    3) here is an example of one of my references in this file:

    TY - JOUR
    ID - 2
    T1 - ABC of diseases of liver, pancreas, and biliary system. Chronic pancreatitis. [Review] [3 refs]
    A1 - Bornman,P.C.
    A1 - Beckingham,I.J.
    Y1 - 2001/03/17/
    N1 - 11250854
    SP - 660
    EP - 663
    JF - BMJ
    VL - 322
    IS - 7287
    AD - University of Cape Town, South Africa
    L1 - C:\References\ABC of diseases of liver pancreas and biliary system Chronic Pancreatitis.pdf
    ER -

    4) note that my PDF is under the field L1 and that it has some junk characters at the beginning and the end
    5) when importing the RIS file into Zotero this causes problems. To get rid of these junk characters, cut and paste the whole exported file from notepad and into word (note that the junk characters are still there. You should be able to find and replace these but I was not able to cut and paste these characters into the find field of find and replace. However I found that if I cut and paste this back into the note pad, the character disappeared, however it was replaced with a space. To get rid of the space, you can e.g. find and replace " C:\Ref" with " C:\Ref" and then repaste this into the notepad file which you then save.
    6) import this scrubbed txt file into zotero and it works. The PDF links are now in the URL, when you click on the URL it takes you to your record on your hard drive.
  • dear lowrancesr - try opening the txt file that you created when you exported from endnote and look at a record with a PDF file reference. It should look like a simple path link in my example above. Or similarly each record should look similar to the record above. Junk characters can be removed or the file can be reformatted using find/replace in word or similar software. As long as your RIS input files follow the above format, it should work.
    Good luck!
  • edited October 25, 2010
    I just imported a large Reference Manager database into zotero (2.0.9). The problems I faced were:

    1) Special German characters (äöüß...) got lost.
    2) as described above, RIS export files contain non printable characters [\x00-\x1F], mainly arround the .pdf link, but also in other places...
    3) a export file named <something>.ris hangs up zotero. <something>.txt works well.
    4) I wanted the PM link to be a clickable web link in zotero
    5) Editors are not imported as such

    My solutions:

    1) specify IBM-850 as input character set, or convert the RIS file to UTF-8, and tell zotero that the import character set is UTF-8. The automatic recognition only worked sometimes...
    2) remove all non printable characters except CR. It has a special role in the "N1 - " record.
    4) change "UR - PM:" to "UR -"
    5) change "A2 - " to "ED - "

    This can be done by hand with notepad++ for example, or by the following script run under cygwin:

    #usage cleanup.rc infile > outfile
    iconv -f CP437 -t utf-8 $1 >tmp1
    sed 's/[\x00-\x0C\x0E-\x1F]//g' <tmp1 >tmp2
    sed 's|UR - PM:|UR -|' <tmp2 >tmp1
    sed 's|A2 - |ED - |' <tmp1

    This way all .pdf files which were linked in Reference Manager will be copied into the zotero storage, which is what I want.

    So far the result looks good, but it might be worthy to do some global edit things in reference manager before the export, like making author and journal names (abbreviations!) consistent before the export. As far as I know zotero lacks such functionality.

    Nice to have:
    The original reference manager ID appears under "Extra:" in zotero if you change
    "ID - " to "M1 - "
    This way I could import also Availability (AV - ) and Reprint (RP - ) into "Extra:".
  • edited November 22, 2010
    i just implemented the comments of the previous users like maba, thanks for that!

    Unfortunately, I additionally get for each imported publication

    -) a note containing the whole "N1"-subgroup (e.g.: DA - 19990304 IS - 0006-8993 (Print) LA - eng PT - Journal Article PT - Research Support, Non-U.S. Gov't RN - 0 (Receptors, AMPA) RN - 0 (glutamate receptor ionotropic, AMPA 2) RN - 0 (glutamate receptor ionotropic, AMPA 3) SB - IM) and

    -) a screen-shot of the medline publication.

    Is there any way to bulk-remove both the notes and the screen-shots, or better not to generate these unwanted items at first place?

    Thanks a lot for your comments in advance!
  • edited December 9, 2010
    I just face the following problem: Autor initials got imported as Mister M.W. for example. No Space between M. and W. In the bibliography I get

    Mister M instead of Mister MW. Adding a space solves the problem.

    Is there anything I have missed? Or do I really have to add spaces manually to all references that I want to cite in a paper????

    I tried several styles. Always the same problem...
  • The need to put spaces between initials is an old bug in Zotero 2.0. This will be fixed in Zotero 2.1, now available as a beta:

    (you'd have to decide for yourself though whether it makes sense to run the beta version)
  • @rintze: Thanks, that's good news! Maybe I stay with 2.0 for my current project. But I'm really happy that I do not have to edit all 3600 references ;-)
  • rintze, do you have any solution for my problem as well - or do you know someone who does, or did i miss something in another forum? please let me know, i'd really love to use zotero for my old refmanager citations and i sooo cannot edit them all manually. ;-)
  • edited December 10, 2010
    @epilepsy: you can use saved searches for this:

    For the notes, use "Note" "contains" " " (use a space).
    For the images, use "File Attachment Type" "is" "Image".

    Select one of the saved searches in the left column of the Zotero pane, and select all matching items in the middle column using a shortcut key (ctrl-A on Windows). Right-click one of the selected items, and select "Delete Selected items from Library..." (only notes or images should be highlighted; be careful not to accidentally delete the parent items).

    And, most importantly, I'd recommend you back up first:
  • edited December 10, 2010
    @epilepsy: I also have this notes, but in fact for me this contains valuable information. If you really do not like to import "N1 -" you could change it to something else that is not imported ("XX -"). Probably it would be good to remove the CRs also i.e. sed 's/[\x00-\x1F]//g' instead of sed 's/[\x00-\x0C\x0E-\x1F]//g'. It is up to you to test this...

    Concerning the screen-shot of the medline publication: in my hands I get a LINK to the medline entry, which I want to have. I got this by changing "UR - PM:" to "UR -". Just omit this change.
    I'm not sure if this is what you mean.
  • edited January 6, 2011
    sorry for the late reply:

    your suggestion works very nicely for the notes, rintze, only the image search doesn't yield a result.

    maba, you're right as well. the "content" of N1 is important and only put into the notes - and not where it properly belongs, for example "LA" isn't put into zotero's "language", the ISSN is only in the notes as well, etc.
    please tell me there's a way around it. ;-)

    i've tried the RTF export of both RM9 and RM12, but the format of N1 looks alike. i could send you a text sample as well of course to show you everything in detail and if you're willing to help me!
  • edited January 6, 2011
    @epilepsy: can you tell me what kind of files these screenshots are? You can do this by selecting one in the middle column of the Zotero pane, and looking up the Filename from the right column.
  • edited January 6, 2011
    it says attachment and it's the icon with a chain on the bottom. i've already tried all the other file imports and neither seems to work for it. regular pdfs and screenshots are perfectly recognised.
    another thing, it imports a folder with the imported file. but the publications are imported twice. so even if i remove the "imported" folder i have to look for them in the main library folder and remove them manually ... very annoying. spent 2 hrs today doing so with all my test trials. :(
  • edited January 6, 2011
    Is the icon with the chain white or blue (see )? If it is white, you should be able to tell me the filetype of these screenshots.

    As for the duplication during import, are you sure you're deleting the items from your library and not just removing them from the "imported" folder/collection (see ).
  • edited January 6, 2011
    @ icon: it's blue.

    the 'double items' seemingly were some left-overs. my mistake.
    you're right, removing a collection isn't deleting the items in it - and there's no option for doing that. but then, one can always go around this by simply selecting all items inside of the collection and bulk-deleting them. ;)

    thanks a lot again!
  • In that case, the "screenshots" are actually links. You should be able to select these with "File Attachment Type" "is" "Web Page".
Sign In or Register to comment.