Citing is slow

This discussion was created from comments split from: Zotero latest version - so slow & sluggish.
  • edited April 22, 2023
    Hi all
    Zotero is abnormally slow these times. I've been using it for a couple of years and never had such issues befores. Saving changes is becoming a real challenge because it takes at a looong time (more than 1 minute) to finish and many times it crashed. I tried disabling automatic citation updates, spliting my manuscript in 4 documents (237 references in total, 30 pages...) nothing worked. I'm using it on a PC at home but same issues happened at work. Any advice ?
    Thanks !
  • (Please always start new threads for new issues. I've moved this to a new thread.)

    I'm not sure what you're referring to here. What do you mean by "saving changes"? That's not something you do in Zotero.

    If you're referring to word processor integration generally, we'd want to see a Debug ID for an operation that was slow, along with details of your system and word processor.
  • Sorry for that and thank you for your response. More precisely, when I try to save a word file with citations, it takes at least 2 minutes to save and many times it crashes. In fact any change that I try to do right now is very difficult (now for example I'm trying to change the citations format and it does not react).
    I guess this is because I have reached my free storage limit
    I deleted many files but it seems not to work. I have submitted the debug ID D443433476
    Thank you for your help
  • But are you talking about actually saving the file in Word or something with Zotero? Zotero doesn't have anything to do with Word saving. If that's slow, that's a Word bug.

    Your Debug ID shows you syncing in Zotero. It doesn't show anything related to word processor integration.

    Changing the citation format via the plugin's Document Preferences window would be related to Zotero, and that might take a few minutes in a large document, so you should let it go.

    In general, if you're having trouble in a given document but it works in a new, empty document, see Troubleshooting Errors in Word Processor Documents.

    None of this has anything to do with Zotero Storage.
  • It's when I'm saving the file in word (i'm using Microsoft office professionel plus 2019) But actually every operation is taking abnormal time (insertion or changing citations, changing formats, etc...) I'm used to working on large documents and never found such issues.
    If this has nothing to do with the storage, I'll try the troubleshooting errors in word processor, thank you
Sign In or Register to comment.